[ROM] SC VIM3 Pie "Normal" Final v2 20190908

Hi there guys and girls, one more rom/fw for you all!
Many thks to Khadas for sending me the device to play
And many thks to @Robert for be my beta tester :wink:
Ok guys im going to write the max i remember i did on sdk… i can’t remember all of it!
Build from Latest source.
Debug Build ( i might do in the future a rls build with my own keys )
I also added my layout(in zip format in internal storage) for squarehome3, is not hard to import it, i will make a video on how to do it in the next days… or just search youtube i bet there is something explaining it!

Changelog Final V2:

  • Ported All my changes (see previous versions changelogs) to latest sdk and build from it.
  • Fixed a few issues present in latest sdk.
  • Now compatible with both v1.1 and v1.2 hw revision of VIM3 ( with Samsung and SkHynix rams)
  • Noise filter set to 1, i think is enough!
  • Other small stuff and cleanups.

Changelog Final V1:

  • Removed 1. boot pair remote page.
  • Added 2 more remote to power on from sleep.
  • Fixed Vulkan support.
  • Fixed Navigation and Status bar.
  • Long press menu to show navigation bar
  • Reduced the time mouse icon stays on screen.
  • Updated gapps again…
  • Other small stuff done in sdk.

Changelog BETA1:

  • NO ROOT (i do not root my roms… sorry… but you can have “su” in shell since is a debug build )
  • Small change in kernel.
  • LatinIme fixes and now can be used with remote DPAD
  • Fixed force_land.
  • Removed some “Null” pop ups
  • Some addtions and fixes to settings provider
  • Modified DroidSettings, “More Settings” now calls white settings.
  • Modified TVSettings, added “Display” to menu to call DroidSettings
  • Added White Settings(regular android settings), and fixed lots of stuff
  • Enabled vulkan (but still not detected by apps… so work in progress)
  • Added squarelauncher3 and also added my layout to internal storage so you guys can import it from there if you like my layout of course!
  • Added SetupWizard.
  • Double click home brings up Recent Apps in Grid View…
  • Long press home calls assistant
  • Long press Mic Key in remote calls assistant ( only tested in Beelink King Remote )
  • Added many KL’s for many keyboards.
  • Added Beelink King remote support. ( more to be added in the future )
  • Added Provision.
  • Added AndroidTV screensaver, by default will start in 1h… you can change that in settings.
  • Added AndroidTV remote control
  • Added some apps. ( not many since i dont like to add to much crap in my roms )
  • Compilation done with optimizations.
  • Changed system and vendor partitions size.
  • Optimized lots of stuff.
  • Gapps Nano, build from source already odexed from compile for a faster boot.
  • Some small fixes to systemui.
  • I know there are more… i but i cant remember now, keeping a good log is not my strong at least when is not for my work place, lol…


  • Remove 1. boot pair remote page.
  • Add support for more remotes to wake up from poweroff/sleep to uboot.
  • Fix Vulkan support.
  • Fix Navigation Bar and status bar.
  • Add long press menu button to hide/show navigation bar.
  • And other stuff i can’t remember now…

Bugs BETA1:

  • Of course there is bugs… there always be bugs…

Want to buy me a beer?

Download Final v2 IMG:

Install instructions:

  • Use usb burning tool to burn the IMG.
  • More information on how to put the device in flash mode refer to khadas wiki!



Enjoy it :slight_smile:


well… here is a report on what i done this last days from the TODO list.

  • Remove 1. boot pair remote page. - > Done
  • Add support for more remotes to wake up from poweroff/sleep to uboot. -> Added 2 more.
  • Fix Vulkan support. -> Fixed
  • Fix Navigation Bar and status bar. -> Fixed
  • Add long press menu button to hide/show navigation bar. -> Done
  • And other stuff i can’t remember now… -> A few other minor stuff!

Updated 1º post with “Final” (for now of course), read changelog for changes…


It seems that online doc needs update these two links(Linux and Android).

@alcohol The Third Party Firmware is in there.The first one is Android TV.

Hi @Frank , ye they are wrong is linked to this rom, this one is regular android.
The AndroidTV one is in another topic here in VIM3 section.
I posted 2 roms :wink:


Hi @superceleron, thanks for the rom! Just got my VIM board (VIM 3 V12) recently and was looking forward to giving this a try.
I’m struggling to flash it, though. I’m using USB burning tool and can’t get past 3% ([0x10303004]Romcode/Switch status/Identify/Error result). No luck using an SD card and burn card maker either: I lose output signal almost immediately after it starts updating, unless I don’t erase the bootloader where it completes installing but then I get no output signal on reboot. Same issue with the Beta1 image. Validated the checksum on both images, everything seems fine there.
That said, I have no problem flashing it with the stock Pie rom with the same setup.
I wonder if anyone else is having (had) a similar issue?

Hello, I had no issues flashing SC’s VIM3 ROM, went straight in using USB Burning Tool.
I erased eMMC prior to the burn.

Weird, no issues whatsoever here, and i already burn like 80x lol

i have the same problem.
([0x10303004]Romcode/Switch status/Identify/Error result).
no solution?

Not sure it would matter, but did you erase the eMMC prior to flashing? I am not referring to settings in the USB Burning Tool, but actually erasing eMMC as described here.

1 Like

I tried erasing the eMMC (using Interrupt Mode, rebooted to confirm) and still had the same issue. Will look at it further today, no solution yet. Any suggestions (no matter how simple) are welcome.
This is the full error log for reference:

[10:50:33 514][HUB1-5][Inf]–Download BL2
[10:50:33 514][HUB1-5]Aml_Libusb_bl2_boot2 start!
[10:50:33 518][HUB1-5]sequence= 0, datasize= 16384, fipOffset= 65536
[10:50:33 525][HUB1-5]sequence= 1, datasize= 49152, fipOffset= 393216
[10:50:33 531][HUB1-5]sequence= 2, datasize= 16384, fipOffset= 229376
[10:50:33 540][HUB1-5]sequence= 3, datasize= 49152, fipOffset= 245760
[10:50:33 559][HUB1-5]sequence= 4, datasize= 16384, fipOffset= 65536
[10:50:33 566][HUB1-5]sequence= 5, datasize= 49152, fipOffset= 393216
[10:50:33 571][HUB1-5]sequence= 6, datasize= 16384, fipOffset= 229376
[10:50:33 581][HUB1-5]sequence= 7, datasize= 49152, fipOffset= 245760
[10:50:33 618][HUB1-5]sequence= 8, datasize= 16384, fipOffset= 65536
[10:50:33 625][HUB1-5]sequence= 9, datasize= 49152, fipOffset= 393216
[10:50:33 632][HUB1-5]sequence= 10, datasize= 16384, fipOffset= 229376
[10:50:33 641][HUB1-5]sequence= 11, datasize= 49152, fipOffset= 245760
[10:50:33 659]BL2 report Error, code= 32
[10:50:33 659][HUB1-5]cmd error, cmdType:43984
[10:50:33 659][HUB1-5]Aml_Libusb_bl2_boot2 end!
[10:50:33 659][HUB1-5][Inf]–Release Semaphore
[10:50:43 773][HUB1-5][Inf]–Detect Device remove timeout
[10:50:43 773][HUB1-5][Inf]–Device is connected
[10:50:43 773][HUB1-5][Inf]–Close device handle 0x00000914
[10:50:43 824][HUB1-5][Inf]–Open device handle \?\usb#vid_1b8e&pid_c003#5&350590a7&0&5#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x00000bf4
[10:50:48 877][HUB1-5][Inf]–0-0-1-8
[10:50:48 877][HUB1-5][Err]–CheckFileRunState failed
[10:50:48 891][HUB1-5][Err]–[0x10303004]Romcode/Switch status/Identify/Error result
[10:50:48 891][HUB1-5][Inf]–Close device handle 0x00000bf4

well, is the same error…
I can install this Android pie

the sistem is like the first day… not avanced, but not briked at all :slight_smile:

@Terry did you guys change the uboot from this VIM3_Pie_V190809.7z to previous builds?
Because it looks like yes, because the “[0x10303004]Romcode/Switch status/Identify/Error result” only happens when uboot was changed, i notice you guys are now using another branch tree because the one i used is “khadas-vim3-pie” and now i see one new in there “khadas-vims-pie”…

1 Like

No, I don’t change the uboot from VIM3_Pie_V190809.7z to previous builds. I haven’t release new ROM with the branch “khadas-vims-pie”.

1 Like

I will release new ROM with the branch “khadas-vims-pie” in next week.:grinning:


and… Android TV ?
[[ROM] SC VIM3 Pie ATV BETA1 20190810]
not work

1 Like

hmm ok thks @Terry can you plz try to flash any of my roms in a v1.2 VIM3?

1 Like

Ok, I will try later. :smiley:

1 Like

The network is so slow :joy: