Vim3 Android Bluetooth HSP/HFP failed


Hello, I am trying to get my motorcycle helmet Bluetooth system to allow for function with google assistant etc.

I just got my Vim3 today and I tested it with three android builds and none allowed for it.
Actually I was not able to get any response from the mic input at all…
its like the android is not getting any input from the bluetooth at all.

I even loaded a simple recording app and it gets nothing from the BT headset.

I tested this on my cell ph and all things work, so I dont know what to do.
I cant find anything in the settings to change the input device or make any adjustments.

help plz

1 Like

Hi, there shouldn’t be any problems with Bluetooth, how are you doing with connecting other devices?

It is connecting and playing sounds fine, I tried a BT mouse and its fine.
Just no microphone throughput.

its as tho the O/S is set to look at another Mic input and I see no way to switch it.

I understand you, try to mark Terry in your message, he can probably help you.
good luck to you!

1 Like

Yes i suppose they cant monitor them all :slight_smile:


1 Like

hello, alternatively you can check the assembly from Superceleron, maybe you can see something useful there.

We are debugging for bluetooth mic. But it need more time.


I tried the superceleron build it appears to be the same for this.

1 Like

Terry responded to your problem, we will wait for good news

1 Like

hmm it should work fine in my next build, at least is works just fine with my BT remote mic.

1 Like

I will try your build again. I have a BT speaker ph I can use for testing now as well.

it will not work ok in the builds i have posted.
What i mean is ok in the build i still did not posted.
I will try to post it today or tomorrow.


Thanx, where should I look for your repository?

Do you have a github page I should monitor?

no i do not have it in my github, i will post it here in the forum.

1 Like

I just gave the V6 a test drive from my helmet bluetooth nada

Loaded it, connected wifi, logged in my google account and loaded the google assistant from the play store. paired the helmet, and clicked on the assistant.

Thats all I did, I can hear it in the helmet “beep” to say its ready, its on the screen with the lines but no movement in the lines, then the “beep” and it reports it did not hear anything.

tell me something, do you have any 2,4g usb stick in the vim3? the ones from lets say a airmouse remote etc…!?

Only things plugged in are power, hdmi monitor and a mouse.

air mouse? or a actual corded mouse?

Its a corded laser mouse, very basic bench tool kinda thing :slight_smile:

very strange, i tried 3 different BT remotes(brands) that have mic and all work fine.
Well without the device itself to debug theirs not much i can do :frowning:
I also take around 2 to 3 months between builds(time restrains), so maybe in the next official khadas build that could be fixed.

1 Like