Firmware VIM3_Pie_V200103+M2X+ME906E

yes, thank you, @ThomasHH-DE please change the things @Vladimir.v.v has given above and see if the color changes, regarding the mouse I will need to know more Info

All older ones have a lot of mistakes. The keyboard in particular can only be used to an extremely limited extent. Sometimes with older firmware I cannot use the keyboard at all because the physical keyboard does not output special characters and the touch keyboard is not shown.

Yes, the LTE modem is currently the biggest problem. Without this function, I don’t need to continue testing. I only have time to test this week, then I either have to install the device in the car or just send it back.

Ultimately, it is also good to know how to integrate other hardware.

I’m going to try the older firmware again and report.

Thomas, you tried the firmware from Superceleron, I’m not sure, but maybe there is a solution to the problem

Yeah, that is a good suggestion as well :thinking:, and also contains some of the other superceleron’s goodies :smile:

Now I will send a link

Thomas, please check!

and let us know about the changes. thank

So that’s not possible … I have now tried SC_VIM3_USER_NORMAL-v4.0-20200117.img and SC_VIM3_USER_NORMAL-v5.0-20200210.img. As soon as I click on the “Mobile Network” menu item in the settings, the part crashes 100%.

can someone show me a picture of how far a cell phone card has to be pushed into the card slot? We seem to have a different standard here in Europe. In European devices, you can only push the cell phone card in one direction and only up to a certain point. With this part here you can push the cell phone card through completely. You can’t even know how far you have to push them in.

you need it to be aligned in the middle, it is not any different standard in Europe, its the same thing here but the slot is open in both directions,

@ThomasHH-DE you say that VIM3_Pie_191122 firmware works right, but your problems are the screen and Mouse not working properly.

So the modem is not recognized at all and just crashes when I click on “Mobile Network”

It hadn’t worked properly either. There I had at least the menu item for mobile internet.

@ThomasHH-DE You didn’t toggle the PCIe on , how could it even recognize the device ?
Click on PCIe mode and restart the board, then enable mobile network

If you don’t toggle it and then enable mobile network it will definitely crash over hardware errors

Oh yes, sorry, - of course it doesn’t matter whether USB or PCI mode. Yes, I restarted the device after switching

@ThomasHH-DE can you show me a video of using the VIM3_Pie_v191122 ROM like the ones you have posted above, I can try to see what needs to be done to fix it :slight_smile:

1.Try changing the Video Settings for different color format
==> Android settings / display /screen resolution / color space settings

2.Try using a different mouse, see if it has less problems

On this ROM you just need to enable PCIe and restart, then in network settings you can enable Mobile network

I’m sorry, am I here, did any method help or not yet, and is there a need to create my own assembly?

It seems like superceleron’s ROM keeps crashing

I think you need to leave that firmware with drivers, and optimize for yourself, but in order for everything to be fine, you need to at least assemble your assembly or ask someone

Only Terry can help at this point :disappointed: