VIMs Ubuntu 20.04 V0.9-20200530 Initial Release

Here we release new Ubuntu ROMs V0.9-20200530 for VIM1/VIM2/VIM3/VIM3L.

Check Firmware Page to download the ROMs.

Note: You must use the latest Burning Tool v2.2.0 to upgrade latest images to eMMC.

Note: This is the initial release of Ubuntu 20.04, tons of issues not listed.

Note: Desktop environment switch to GNOME by default.

Change logs:

Vendor u-boot(2015.01) & linux (4.9)

  • linux 4.9.224

Mainline u-boot & mainline linux images:

  • U-boot 2020.04
  • Linux 5.7-rc7

Thanks BayLibre team for the support of mianline u-boot/linux!

NOTE: For mainline image, DO NOT use verdor u-boot to boot it, you need to erase the eMMC and fully boot from the SD card or you will get a green screen.

Account info:

  • User: khadas
  • Password: khadas

Upgrade guidance:

Fully installation

  • The image name contains EMMC means that it is for EMMC installation, can only burn to eMMC.
    Check Upgrade Via USB Cable to upgrade the firmware.

  • The image name contains SD_USB means that it is for SD/USB installation, can only burn to SD card or U-disk, need Android running on eMMC and activate multi-boot, please refer to Boot images from external medias.

About the Open Source GPU drivers

This release enabled Lima/Panfrost support for VIM1 and VIM2 by default.
Ubuntu on Wayland has better performance than Ubuntu on X11, but still has a long way to go, thanks Lima/Panfrost team for the efforts!

Install SD card image to eMMC

$ sudo emmc-install

By the way

Ths images are built using Fenix scripts, you can use it to build your own image!

Have fun!

8 Likes

Great work Khadas team :smile:, waiting for more updates on this

1 Like

Wow, how smooth is it?

Great work though.

I tried it out its really good, only problem is compatibility issue of older Linux firmware :face_with_raised_eyebrow: which I can’t understand and also in the mainline kernel python 2.x is dropped,
which means many of my old scripts don’t run

This has nothing to do with kernel, Ubuntu 20.04 is using python3 by default, but you should be able to install python2.7 manually then your old scripts will work fine.

Try it.

it seems that you can transform python 2.7 script into python 3 script and rejuvenate you old scripts that way.

Hmm , never heard that before :thinking: but I shall see, python 2.x as a lot of differences from the 3.x in the semantics, but the syntax is the same, for legacy reasons it was dropped from development and 3.x has been the brainchild of them ever since.

Hi!
Under X11, still many artifacts (especially with mouse cursor).
Under Wayland, it’s almost perfect! Web pages with firefox are fluid.
wifi oob.
mpv close (almost) to display HD.
Very promising!!
Thks to you guys! That was a huge leap, full of promises!
Can’t wait for a more stable release!

1 Like

On my vim2, VIM2_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530,

if WOL is enabled, it reboots when I power if off (poweroff command or power button).

1 Like

Yes, please disable WOL temporarily …

Yes. I confirm, things are ok when WOL is disabled.

I hope you’ll be able to fix this, because I need it in my setup.

1 Like

I am guessing it will take just a bit longer when considering this is released: VIM3/VIM3L Ubuntu 20.04 Linux 4.9 V0.9.3-20200814 OTA Release

Greetings,

  1. Installed VIM2_Ubuntu-gnome-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530.7z to 32GB SD Card using Etcher on Windows 10. (Failed on MacOS Mojave for some reason).

  2. Have VIM2_Pie_V200624.7z already on EMMC and it is working (well not totally sure but apps from appstore install / getting the odd ‘developer warning’ pop up).

  3. I run ‘aml_autoscripts.zip’ as per @numbqq multiboot instructions above. Here is a pic selecting the file in Android >
    https://photos.app.goo.gl/jaSX4iC7YhkQH4ES8

  4. It then boots to ‘Android Recovery’ screen as per the following pic >
    https://photos.app.goo.gl/cUYHcndkJMkQ6HLD6
    Clicking ‘Reboot to uploader’ just results in a bottscreen with the Khadas bootloader. Clicking on Mount /system does the same too.

How do i boot to Ubuntu Focal with Gnome?

Cheers!
Michael

just enter upgrade mode, it will boot into Linux on the SD card, USB thumbdrive…

1 Like

Hi @Electr1

Just to clarify. I don’t have to run the Android script > 'aml_autoscripts.zip’, while in Android?

I just have to powerdown and follow the Button Mode for upgrade. (I didn’t know ‘U_Boot’ was also installed on the SD Card.)

Okay i will give it a go later…

Michael.

Not necessary, you can just use the buttons to enter upgrade mode and that will do it,
If you have a v1.4 board I suggest going with the TST method as it is very easy with just 3 clicks :slightly_smiling_face:

1 Like

Hi, the first system you will have to start from sd / usb drive, the second you will have Android on eMMC, so you should always know how to reboot the system in Android.
Good luck :slightly_smiling_face:

You still need to have set the board in upgrade mode for that to happen in the first place…

if there is no switch as in coreelec, then of course you have to do everything with your hands