VIMs Ubuntu 18.04 V191231 Release

Here we release new Ubuntu ROMs V191231 for VIM1/VIM2/VIM3/VIM3L.

Check Firmware Page to download the ROMs.

Note: You must use the latest Burning Tool v2.2.0 to upgrade latest images to eMMC.

Change logs:

Vendor u-boot(2015.01) & linux (4.9)

VIMs common:

  • linux 4.9.206
  • fixed eMMC image bootup delay about 30S
  • added HDMI resolution auto detection
  • added HDMI resolution UI setting menu (Applications->Settings->HDMI Resolution Setting)
  • added kplayer command line player support
  • added gsteramer support
  • added opencv support
  • fixed WiringPi GPOIO AO domain
  • added WiringPi python3 support
  • preinstall firefox browser (has better performance for youtube video playback than chromium)
  • added system information UI menu (Applications->System->System Information)
  • added more compress/extract method
  • load bmp logo from rootfs partition


  • added cooling FAN UI setting menu (Applications->Settings->FAN Setting)
  • added WOL UI setting menu (Applications->Settings->Wake On LAN Setting)


  • added cooling FAN UI setting menu (Applications->Settings->FAN Setting)
  • added WOL UI setting menu (Applications->Settings->Wake On LAN Setting)
  • added NPU support (
  • added MIPI camera support
  • added USB3.0/PCIe swich setting UI menu (Applications->Settings->USB3.0/PCIe)


  • added cooling FAN UI setting menu (Applications->Settings->FAN Setting)
  • added WOL UI setting menu (Applications->Settings->Wake On LAN Setting)
  • added NPU support (
  • added USB3.0/PCIe swich setting UI menu (Applications->Settings->USB3.0/PCIe)

Known issues:

  • no sound for kplayer and gstreamer

Mainline u-boot & mainline linux images:

  • U-boot 2020.01-rc5
  • Linux 5.5-rc2
  • Working part:
    • HDMI
    • ETH
    • Wi-Fi
    • BT
    • eMMC
    • SD card
    • USB
    • PCIe (has some issues with VIM3 when NVMe SSD is removed)
    • HDMI audio
  • added u-boot bmp logo support (VIM1/VIM2 only)
  • added simple KBI support
  • added simple MCU driver
  • added FAN control
  • added support for Wi-Fi AP6398S/AP6359SA

Known issues:

  • For VIM3: USB can’t work when PCIe is enabled and NVMe SSD is removed (if NVMe SSD is attached, both USB and PCIe work well), so suggest to don’t enable PCIe in this version
  • HDMI audio crash with desktop

Setup HDMI audio:

# amixer cset numid=8 1
# amixer cset numid=11 "OUT 1"
# amixer cset numid=14 1
# amixer cset numid=17 "OUT 1"
# amixer cset numid=20 1
# amixer cset numid=23 "OUT 1"
# amixer cset numid=26 "I2S B"
# amixer cset numid=27 1
# amixer cset numid=29 "IN 0"
######### TEST ##########
# aplay test002.wav

NOTE: For mainline image, DO NOT use verdor u-boot to boot it, you need to erase the eMMC and fully boot from the SD card or you will get a green screen.

Account info:

  • User: khadas
  • Password: khadas

Upgrade guidance:

OTA Upgrade

You need to preinstall V190830(or newer) images and upgrade to the latest images.

Suggest you to use Krescue to backup your whole system before upgrade!

khadas@Khadas:~$ sudo apt update
khadas@Khadas:~$ sudo apt full-upgrade
khadas@Khadas:~$ sudo do-fenix-full-upgrade
khadas@Khadas:~$ sync
khadas@Khadas:~$ sudo reboot

Note: For VIM3/VIM3L mainline SD images, the OTA upgrade is broken for this update and you have to resintall the whole image.

Fully installation

  • The image name contains EMMC means that it is for EMMC installation, can only burn to eMMC.
    Check Upgrade Via USB Cable to upgrade the firmware.

  • The image name contains SD_USB means that it is for SD/USB installation, can only burn to SD card or U-disk, need Android running on eMMC and activate multi-boot, please refer to Boot images from external medias.

By the way

Ths images are built using Fenix scripts, you can use it to build your own image!

Have fun!


Is there a workaround for using Ubuntu on sd card without removing Emmc Android, like using older u-boot?

As i’ve read a little about this, this is Amlogic’s fault?

I forgot to ask, do we have any multimedia improvements in these images?

1 Like

Please share the 5.5 kernel link so we can try to built it and use it for Manjaro.
Also can 5.5 support LCD & TP ?


For VIM1 & VIM2 it’s OK.

But for VIM3/VIM3L mainline kernel you will get a green screen if you use android in eMMC.

Linux tag 5.5-rc2 and some patches


Not some a whole lot of patches lol…

Any on upstreaming these patches?

Many of them already in the mail list…

1 Like

Does Vim3 wifi chip work with mainline kernel?

Yes, it is, but the speed is lower than the vendor kernel due to the mainline kernel SDIO bug, but I think this will be fixed soon.

Should nvme work with latest VIM3_Ubuntu-server-bionic_Linux-5.5-rc2_arm64_SD-USB_V0.8.2-20200103.7z ? I can not get neither a Corsair MP510 2Tb nor a Intel 660p 2Tb to work. I have tried to switch /sys/class/mcu/usb_pcie_switch_mode fort and back. No /dev/nvme*

@odalg Did you setupPCIE port ?

In this image, I remove support for it due to some bugs.

Probably this has been discussed already, but what are your plans for images with lima/panfrost, vpu on s905x, as i’ve seen panfrost is already in good shape?

What are your plans for the future, as i’ve seen a lot of progress has been done with amlogic boards, so i think you should be working on software?

We don’t plan to work with lima/panfrost due to some depandency issues of mesa on Bionic, we plan to work with then on Ubuntu 20.04 LTS Focal Fossa.

Are you working on mainline kernel? I am aware of the patches but that’s alot of patches is there any mainline custom kernel you maintain ? We were able to get lima for other devices. I have been trying to use @balbes150 branches to build 5.5rc to get lima to work on vim1 but I am facing some issues with getting hdmi to work while i can login via uart.

Please let me know if your having a custom mainline branch .

Ok, so i tried SD card image with 5.5 kernel on VIM3L and i only got to the login screen, no keyboard or mouse inputs, also the screen was tinted blue. I also tried to compile mailine to emmc with PhenixScript with a downclock to 1.6ghz on the config file and it crashed near the end. Btw, how can i undervolt the cpu?

Do i need better charger to make use of usb 3.0, because i am using 5V2A charger on vim3, and as far as i know usb3.0 needs more power to work, 9V as i know, so it will work as usb 2.0 device?

I am thinking about flashing linux on my usb 3.0 flash drive, but it won’t be as fast as it should when using charger with less power, am i right?

multi-voltage power supply recommended for vim3


Yeah, i know about it, but i didn’t want to order it before, tbh this isn’t so cheap in my country, but it looks like it won’t get shipped soon, even if i order it, that virus messed things up seriously.