VIM3 Android Pie V200103 ROM Release

Well since the rom as root, just edit system build.prop or is vendor build.prop… well in one of the two LOL i just cant be sure now, just check both build.prop…
And just comment out ( put a # in the beginning ) ro.boot.wificountrycode=CN , save and reboot and voila 5g back.
In the sdk just go to, and comment ( put a # in the beginning ) the :

And that is it!


Thank you very much for your help! I’ll try to fix it, but I don’t understand much about it yet …:slightly_smiling_face:


find and fix


Many thanks!!! …

Thank you all for your help! Made changes to system / vendor / build.prop. WIFI 5 GHz began to work !!! …:hugs::hugs::hugs:


Good firmware with excellent performance!


how it works for me …
true 4pda today is very slow

1 Like

, Здравствуйте! Можете поподробнее написать как пофиксить?

1 Like

Hello! Dear superceleron announced in the near future a new firmware, there all this must be implemented.


Great news for all! Happy to see a fw treating VIM3 as a player.

1 Like

TS050 touch screen works fine but when I try to change the resolution to 720p or any other it does not change. Is a fixable issue?

All mainstream streaming APP not work properly on this FW: Douyu,Huya,Bilibili, …
Playing with black bar at bottom and right side. (dot to dot or scan issues)
The original FW(190809) is perfect on this.

Navigation bar can be closed in this FW, good news!
Status bar hiding still not available. o(╥﹏╥)o
The original FW(190809) is perfect on this.

pls Khadas considering the media-playing user who bought a remote.

1 Like

Hello, For those interested, @superceleron has just posted a new version of his Custom ROM for the VIM3.
I have not had a chance to try it yet, but he does good work, you may want to look in to it.

Hello, have you solved the green screen problem?

no problems, so probably decided :wink:

I found many S922X android 9.0 boxes can do this and streaming properly:
So pls Khadas try it!


Thanks for your feedback, I will try to add it.

Thx, and this pls too.

1 Like

Yes , it would be nice to hide those under certain apps

1 Like

i have VIM3 + M2X Extension Board with SSD and 4g module installed,

I installed latest ANDROID PIE
seems the data(4G sim) and gps dont work.

how can i fix this, i go to settings and location and try to turn on GPS location but it wont let me.

the 4G led light on the M2X is on but i still cant use 4g nor gps