VIM3 Android Pie V200103 ROM Release

Here release VIM3 Android Pie ROM

Check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: VIM3_Pie_V200103.7z
  • MD5SUM: 574ef67912283729fa291ce13c769761
  • The ROM is for EMMC installation only

Change Log

  • add os08a10 camera support
  • add screen rotation menu for hdmi only
  • add bluetooth connect menu support
  • add status bar control menu support
  • add wifi hotpot menu support
  • add quectel EM06 4G module support
  • add logitech wifi k400 keyboard support
  • add OTA url for next update
  • fix usb microphone recording noise issue
  • fix wol menu issue
  • fix some display issues
  • fix navigation issue

Known Issues

  • No Gsensor support

Upgrade guidance:

Tips for CoreELEC users:

As the Android ROM and CoreELEC used different version U-Boot on VIM3, and you have to edit config.ini file to solve the green screen issue:


CoreELEC team will update the Linux kernel in the future, and you don’t need to edit it manually then.

Have fun!


@Terry Hi! Would you update source code on github?

I wiil update source code on github in this week.

Hi, Khadas
the navigation bar and status bar can be closed this time??
The dream watching live streaming without bars comes true???


The Khadas team cannot solve this problem in half a year. This problem too tough for Khadas

1 Like

I solved this problem with a user script, the panels appear when you hover only, I previously laid out
in the branch Superceleron , the standard version

Picture-DNR-off works correctly!The main thing now to save for future assemblies! thanks!

The staus bar can be hide with Settings menu.

1 Like

I understand this is an amlogic error?
along the way…
-pq.AllPQMoudle.en = enable
can the word “MODULE” be correct ?! :upside_down_face:

1 Like

Navigation bar too???????

1 Like

Hope to add support for MCE remote control

1 Like

Hi! Not work wifi 5ghz!

1 Like

Yes confirmed, 5G wifi is broken in the sdk!!
Anyway is a simple fix… i already fixed it.


Can you tell how to fix it?

Hi, Superceleron, do you think this could be a misspelling?

you noticed?

in my case , in this SDK,
WiFi everything works quite well!
router: keenetic ultra
the nominal speed of my internet is Dow.200- Up.20.


By the way, now I’m watching a torrent movie online, 4K, weighing 110 gigabytes, about 10 minutes, WiFi-5ggz, no brakes.

modem at a distance of 3 meters, and here I am writing from the phone.

in the end, after 30 minutes of testing the movie, WiFi was very stable, no brakes. :stuck_out_tongue:
screenshot during the movie:

About 5G WI-FI, Can you describe it in detail?

1 Like

Not sure if there are issues on wifi, I am using netgear R8000 router, it has 2 5G wifi and 1 2.4G wifi running at the same time. for VIM3 with V200103 ROM, I can find the 2.4G and one of the 5G channel for my router. One of the 5G channel cannot be found.

On the router that cannot be seen, is that router broadcasting its SSID?

Hi. How to fix wifi at 5 GHz ???