VIM3 Android Pie V200103 ROM Release

GPS is really important to me too. Will be watching this for replies.

1 Like

Same here, seems to work fine except no data/internet connection

do you mean 4G modulo connection?

Thanks! :slight_smile: Yes, the 4G LTE, it does not say 4G only 3G on status bar
, but still no data being transmitted.

1 Like

Yes, I already understood, Terry promises to release a new firmware this month, I think there should be changes for you!

Ok, I needed it right away to be used on a project :S kind of misleading as it is my understanding that its advertised as functional with this module. On my leez P710 sbc, 4G module worked in android.

yes, I understand you, maybe Terry can give more information, contact him directly

by the way, WiFi is turned on by default, turn it off, maybe it gives obstacles

Its been turned off, unfortunately, still not working. @Terry Hi, Im new here :slight_smile: Was going to buy a bulk order of your boards, but this issue is holding me back at the moment. Do you have any info regarding this 4G issue? Should it be working or is there some fix in progress? Thanks!


You can try to flash the new firmware, I updated the 4G module support.


Thank you! Did test with new firmware, but no difference. I have set connection type to automatic and get 3G icon in status bar, service provider is listed correctly, but no data is being transmitted. Tested with your supplied antenna and also different manufacturers of antennas. Connected to M and D connector on 4G module.

When booting into android, I get the message “Phone Services” “Lost mobile data connection. Data roaming is turned off, tap to activate” I switch roaming on but still no data connection." Not sure why it asks for me to turn on roaming when all specs tells me it should work fine in my location. After reboot, leaving the notification alone, it disappears after some time and says connected to 4G with the name of teleprovider present. Still no data connection. One more edit :slight_smile: When network type is set to 4G (preferred) it displays 4G connection. Choosing 3G as network instead of 4G leads to device to go to 3G roaming. Still no data. Selecting Access Point Names under Mobile Network crashes the settings page and jumps out to desktop.


wait a bit, now in China there is a small holiday, Terry will definitely answer you!
Chinese Dragon Boat Festival


Wut? Really ?, Yongchao told this on the sysfs GPIO post: 你好呀!粽子节安康!

It meant: Hello Healthy rice dumpling festival!

please guys, stick to a single festival per day, its confusing to tell with so many festivals !:upside_down_face: :rofl:

but happy something day ! :tada:

(replace something with rice or dragons, whatever you like :grin:)


In any case, your question is under control, I’m sure!


yes @Makro you will probably get your answer by Tomorrow
once Terry Arrives your problem will depart :grin:


Well, the holiday will be 3 days, closer to Sunday most likely

Then not tomorrow, @Makro please wait patiently till then.


Thanks for feedback @Electr1 & @Vladimir.v.v. Beeing new here, Im not sure who you are, but thanks anyways :grinning:

1 Like

Lol, no Identity mismash here :grin:
If you want to know about us just check our Bio’s for who we are :slightly_smiling_face:

1 Like

Sorry guys, I have reached my limit on likes