VIM2_Nougat_V170831 ethernet connectivity, reboot problems

I noticed that VIM2 is loosing ethernet connectivity if it’s left idle overnight. I cannot find a way to bring it up as there is no option. If I try the “reboot” command from console, VIM2 turn off itself, so there is no reboot.

VIM2_Nougat_V170831 + openVPN app

Thanks for your feedback. I will verify it.
You can try to use ifconfig by console

$ su
$ ifconfig eth0 down
$ ifconfig eth0 up

Yes I tried
ifconfig eth0 down

but it does not complete the command unfortunately.

Hi @Terry I have noticed on V170831 build that if you enable ethernet and wifi connection, wifi is unstable by means some games can’t find internet connection. The only way to get internet for games is to unplug ethernet cable. Will test how it works on my test build and report.


what’s the hint message? Did you try to unplug ethernet port?

What do you mean hint message? After enter there is no other text. It is stuck there.

Today again ethernet connectivity was lost so I tried to unplug and plug the eth cable but to no avail.

The only option is to reboot, really inconvenient as you can imagine. To do that you need su first, otherwise after the reboot command vim2 does not power on.

EDIT: even with su, reboot does not work sometimes (random).

Can you provide printing log for me when your VIM2 lose ethernet connectivity.
How do I test it? Can you describe it more detail?
Thanks for your help.

Dear Support, Do you have any solution for that? I have the same issue as the topic owner wrote before.

Thank you, Gabor

What is the version of your ROM? Can you provide printing log for me when your VIM2 lose ethernet connectivity?

Just curious, are those with this issue using good power supplies with a minimum of 2 Amp output?

I have the same issue, my rom version is: VIM2_Nougat_V180209
I use a qualcomm 3A power supply.
Wifi is turned off, only ethernet cable is connected, and a keyboard USB dongle.

I’ve the same problem. It loses the connection about once a day. Any progress on a fix?
I’m using the latest Firmware: VIM2_Nougat_V180209

Hi, @Terry!
I have the same issue on my VIM2 powered by USB port. Firmware VIM2_Nougat_20171028.
I managed to collect logs (can send by email).
What could go wrong and how can I help determine the root cause of the problem?

@Kripton @McWizard @kzkzkzkz Thanks for your feedback, I tested it and found the same issue with you . Now I’m trying to fix it and the VIM2 still doesn’t lose connection during two days on my test Rom, But I think it need more times to test. The next release Rom will fix this issue.
Thanks :grinning:


Great news! Looking forward to the next Rom :slight_smile:

Hello. Same issue here. I’ve reported that last year as well, but as i am Portuguese, maybe they didn’t understand the way that i explained. Anyway, wanted to know if the fix is already available. I have the VIM_Nougat_V180209 firmware.

I’m very sorry for you. I will check it on VIM and reply for you next week. Thanks :grinning:

1 Like

Hi, frenchdj
I played network video two days on VIM with my test Rom. And It still doesn’t lose connection.
The next release Rom will work well for Ethernet. :smile:

@Kripton @McWizard @plagab @kzkzkzkz @frenchdj @mrboki
I released the new ROM for this issue. You can download it and have a test. Thanks.

Is this fix included when building from (currently Nougat: V180622)?

If I leave my vim2 device on over night the internet connection (via ethernet) is gone on the next morning. After replugging the ethernet cable, there is a new DHCP request and everything is fine.
We have a lease time of 2 hours, that’s why I guess, there is a renew missing.

Maybe you can point me to your commit which contains the fix for ROM V180619.