VIM2_Nougat_V170831 ethernet connectivity, reboot problems


#22

Hello, This may or may not help,…
From Android go to Settings/More Settings/About TV box and click Build number 4-5 times and it will enable Developer Options.
Back out to Settings/More Settings/ and click Developer Options. Scroll down to the Networking section. Turn on “Use legacy DHCP client”. See if that helps.
Not sure if this setting is available in the firmware, I am not with the VIM2 at the moment and cannot confirm.


#23

Hello @RDFTKV,

thanks for your help. Unfortunately this option was removed quite some time ago.

Best regards,
Matthias


#24

fyi, I was able to fix this problem.

Root cause was this commit. This introduces whitelists for apps which may use alarms causing wake-ups. Unfortunately the else case in line 1147 prevents alarms with direct callbacks from using wake-ups as well. This is needed by the WakeupMessage class which is used by the DHCP-Client.

So I just removed the else case from our image. Now network connection stays alive in idle mode after DHCP lease time is expired.