[ROM] SC VIM1 Pie ATV Debug/User builds v2 20200130

Hi there guys and girls, one more rom/fw for you all!
Many thks to Khadas for sending me the device to play
And many thks to @Robert for be my beta tester :wink:
This rom is as “TRUE” to AndroidTV as possible…
Build from Latest source.


IF YOU HAVE TO MANY ISSUES IN THE BUILD AFTER FLASH EVEN IF THE FLASH WENT OK, JUST REFLASH AGAIN THE IMG BECAUSE YOU GOT A BAD FLASH EVEN IF IT SAID IT WAS OK.


Overvations:

  • After the VIM1 boot and it shows the language screen pls let it idle there for 1 or 2 min so background tasks finish.
  • When you finish setup and you are on launcher screen, let it also idle there for 5 min when playstore suggestions appears on main screen of launcher go to play store and manual update the apps since in 1º boot looks like it won’t auto update the core apps that is needed to be updated.
  • Both above are only done 1 time on first boot after flash…
  • First time you put the Vim1 to sleep it will take long time to actually sleep… dont worry is normal it will eventually sleep, this only happens 1 time after a power cycle after that it will go to sleep fine and “fast”.

Differences of USER and USERDEBUG builds:

User Build : This build is done to be as close to a company rls as possible, it does not have root or twrp and is compiled with rls keys and SELINUX enforced, what this means for you?
Well it means lot more apps show in Playstore that didn’t show before, (EX: my isp androidtv live tv app, only shows in Playstore non rooted and SELINUX enforced devices, also the streams in the app does not even play in rooted devices.). Like this there’s lots of other ISP/NON ISP apps Out there…

UserDebug Build: This build does have root, selinux is permissive and some other stuff you will see in changelog down there…, but of course you will lose the above…


Changelog Final v2:

  • Used latest SDK
  • Again used AndroidTV build path.
  • Added Reboot to another OS or can also be used to reboot to recovery(not twrp) if you do not have any sdcard or usb stick with other OS connected ( DEBUG Build Only )
  • Improved lots of AndroidTV apps
  • Google Webview is now default, plz let me know if you find any issues and i switch back to AOSP webview.
  • Added support for many Gamepads, and i mean really many. ( Kernel Drivers )
  • And many many many other stuff…

Bugs?:

  • Of course there is bugs… there always be bugs…
  • Twrp is broken in this sdk, until i have the time to see where is the issue!
  • There is a bug only in Debug build where videos playing in small windows show with green noise, this only happen in Debug build, User build it ok… need to debug it to see where the problem is!
  • In setup wizard there is a bug where even if you choose to not install any of the previous app, it still install them… this only applies if you do a factory reset!
  • Googlecast will not work ok, nothing i can do to fix it since it need certification.
  • Netflix for AndroidTV will not work at all, so use regular netflix already present in the rom.
  • Rotation in advanced settings is disabled… well not really a bug… but lol i bet someone will mention it :stuck_out_tongue:

Changelog BETA1:

  • Build from latest source
  • ATV Build Path used.
  • NO ROOT (i do not root my roms… sorry… but you can have “su” in shell since is a debug build )
  • Small change in kernel.
  • Fixed force_land.
  • Reduce the time the mouse icon stays on screen.
  • Removed some “Null” pop ups
  • Some fixes to settings provider.
  • Modified DroidSettings, “More Settings” now calls white settings.
  • Modified TVSettings, added “Display” to menu to call DroidSettings
  • Removed White settings just like true ATV.
  • Double click home brings up Recent Apps in Grid View…
  • Long press home calls all apps
  • Long press Mic Key in remote calls assistant ( only tested in Beelink King Remote )
  • Added many KL’s for many keyboards.
  • Added Beelink King remote support. ( more to be added in the future )
  • Added Provision.
  • Density set to 320dpi as true ATV.
  • Added some apps. ( not many since i dont like to add to much crap in my roms )
  • Compilation done with optimizations.
  • Changed system and vendor partitions size.
  • Optimized lots of stuff.
  • Custom Gapps ATV.
  • Some small fixes to systemui.
  • Removed 1. boot pair remote page.
  • Fixed a few issues present in latest sdk.
  • Noise filter set to 1, i think is enough!

Observations:

  • No Vulkan support since the GPU does not support it.
  • Googlecast will not work ok, nothing i can do to fix it since it need certification.
  • Netflix for AndroidTV will not work at all, so use regular netflix already present in the rom.

Bugs BETA1:

  • Of course there is bugs… there always be bugs…

Want to buy me a beer?


Download ATV v2 IMG:


Download ATV BETA1 IMG:


Install instructions:

  • Read the docs or khadas own forum how to use Krescue, is pretty simple!

THIS ROM DELETES ALL YOUR DATA SO DO A BACKUP!

USE AT YOUR OWN RISK!

Enjoy it :slight_smile:

5 Likes

thanks so much for this rom.

could any one confirm if they have working ethernet? tia

yes ethernet is working just fine here.

1 Like

Works here too. I always start with Eth, worked fine.

2 Likes

working after a few restarts - thanks!

appreciate for the VIM1 Pie ATV BETA1 20190909 rom.

I was wondering if anyone was able to watch a movie or an episode after login to Netflix (the Netflix app included with the rom) after launching the Neflix app only Back and Home work on the remote keypads so I am not able to to watch anything from Netflix.

the remote works fine when play YouTube, VLC, etc…

I also paired a Bluetooth remote and a WiFi with the USB dongle remote in order to make sure the issue is not from the Vim1 remote and the result was exactly the same no other keypad on the remote except the return works.

the Netflix app included only works with a mouse or air mouse - hope that helps!

Sorry for super-noob question :expressionless: how to “cleanly” root such rom. Seems like it’s a “debug build”. I have a bad experience with KingRoot, therefore looking for some better solutions.
PS. This rom is great. No problems at all so far and it even stays quite cool even on “heavy” load!

Thanks for the work but the download link does not work.

Ye i know, we are fixing it!

This is a great rom indeed - thanks so much superceleron. It runs so cool compared to others I’ve tried.

Any ideas how I can create a custom boot logo and where I need to install it?

Any documents out there which can point me in the right direction?

@superceleron
Flashed this yesterday via bootmaker tool (USB burning tool not detecting Vim1)
I have an old Vim1 superceeded V 1.2 board.
I only have 1080 60Hz option in display settings.
No 1080 50Hz
My TV is 1080p maximum.
Most content on my very few apps is 50 FPS so not ideal.
Anyone else missing 50Hz ??
BTW Dual boot with CoreELEC nightlies on SD Card working a treat.

No issues here, i have the 50hz.
If you dont it means your tv is not sending the correct edid information to the vim1… im in v1.2 board.

2 Likes

I found the issue after flashing Newest Android pie on my Vim3.
Same thing happened until i toggled in Display settings / Resolutions and activated Auto switch to best resolution.
Deactivated it and then clicked on Display mode 1080p 60Hz
Then all my TV resolutions showed up including 1080p 50 Hz
Chose 1080p 50Hz and bang it works.
Had to do this same procedure on the Vim1 with ATV to jolt the handshake between my TV and the Vim1. :wink:

BTW I know Refresh rate switching is not working.
What i pleasantly found using this Rom is that TVHeadend Client in Kodi playback is working very nicely at 50FPS playback.
There was some slight Jerkiness in HD channels but i was able to fix that by changing settings for Smooth Playback using Activate Sync Playback To Display.

2 Likes

updated 1º post with v2 builds based on new sdk… word of warning… no TWRP in this build since this new sdk totally broke the support for it…
Also there is a bug in Debug build when it plays videos inside small windows, it shows green noise instead of the video, you guys will notice in launcher where in videos play in the small squares.
User build is ok, so is only debug build specific… i’m still debugging to find the issue!

4 Likes

All Good using Kresque:


Rom is so new its still wet

:upside_down_face:

3 Likes

This doesn’t look right.

And this is the Userbug Link
to Vim3.

2 Likes

Thks i used the vim3 link lol…
Fixed now sorry about it!

1 Like

I think the links are still messed up.
The “User” link gives a xxx.img.zstd.7z file that I don’t know how to extract on Windows.
The “UserDEBUG” link shows link for VIM3 file.

Can you please fix both the links for VIM1 please or have separate links for VIM1 and VIM3.

Update: I was able to find a tool on windows to decompress it but now the size is 15 gb? I don’t think that is right.

Thanks

Ye thks for letting me know.
Is fixed now!