Stuttering, plops and crackles Windows 1903

Dear Khadas and community,

I’ve used the Khadas with much pleasure for my Windows 10 setup connected to my studio monitors but since I upgraded to a new machine AND updated Windows 10 from 1809 to 1903 it started stuttering, crackling and popping.

I’ve checked DPC latency issues and my machine had some which were audible but I’ve managed to solve them.

What’s left is every time the audio get’s send through, it will plop crackle at the start of every sound. Even when just pressing Test in advanced device options. It will smoothen out when setting the sample rate to 32-bit 384Khz but some applications won’t accept it and I don’t want to let windows upsample everything and ruin the source audio.

I’ve tried both USB Audio 2.0 driver and Theyscon 224V from the website. It seems to be more severe with the Microsoft driver (Theyscon) than the dedicated Theyscon driver. But present in both. The drivers desperately need to be updated since other manufacturers already got to it with for example the latest Realtek drivers and an Windows update problems for onboard Realtek chips is mostly solved.

My Topping DX3 Pro also works flawlessly with standard Microsoft driver the Khadas should also be able to.

I’m hoping we can figure out how to solve this. Maybe a firmware upgrade is necessary. Other users have also reported issues with the Khadas. I’m curious if more will show up and how common the issue is.

Looks like Windows 10 bug “fixes” are breaking their bug “fixes”.

"… The September Patch Tuesday security update also fixed the Windows 10 1903 Cortana CPU issues but has broken Windows Desktop Search, according to users.

A string of bugs have occurred over the past month since the August 13 update KB4512508 for Windows 10 1903, which broke apps written in Visual Basic 6, VBA, and VBScript for all versions of Windows 10 back to Windows 7.

A week later Microsoft patched this issue for all versions of Windows except Windows 10 1903, which finally got fixed in a separate update, KB4512941, on August 30.

But KB4512941 also spawned reports from 1903 users that the Cortana process SearchUI.exe was causing severe CPU spikes, which Microsoft confirmed last week, promising a fix that arrived in the September Patch Tuesday update KB4515384 this week

As Microsoft noted on Tuesday, the high CPU usage from SearchUi.exe “issue only occurs on devices that have disabled searching the web using Windows Desktop Search”.

But whatever adjustments Microsoft made have caused more problems with Windows Desktop Search and the Start menu. The issue only affects Windows 10 1903.

“Microsoft has received reports that some users are having issues related to the Start menu and Windows Desktop Search,” Microsoft notes.

The company is “presently investigating and will provide an update when more information is available”…"

Windows 10 1903: Microsoft’s CPU spike fix breaks search on Start menu, desktop

This is non-related to the issue I’m describing. I have tested without all these patches and with. I’ve ran 5 fresh installation with different update configs. I’m currently on 1909.

The only thing left for me to do is trying the Khadas on another system (my laptop in the office) with 1809 windows build to make sure it’s not just the device that has gone faulty.

Like I said I’m running the DX3 Pro with the same USB Audio 2.0 without pops and crackles.

I’m pretty sure the Khadas needs a firmware update to be fully compatible with Windows 1903 and up again

The lack of support and response from Khadas surprises me. No more Khadas for me.

I have a VIM1 Pro that’s stuck on an ancient android too and android 8 in beta forever… Pumping out new products and dropping support quickly after. I guess for the ToneBoard the same will happen once a newer version will come out.

It’s literally paper weight now until it get a firmware fix.

its just standart usb audio - and must work same in any system osx | win | linux

i think its OS problem or broken HW

we try to find this windows version for test

1 Like

My other devices work fine with the same driver. I’ll bring the Khadas to my office tomorrow and test it there with another machine and see what it does. It still has windows 1809.

Hello, There is an Android Pie in Khadas Docs. Also custom Android Pie normal and ATV ROMs from superceleron.

I tried superceleron’s normal Pie ROM, seems to work pretty well for the short time I have spent on it.

I remember seeing another user with sound issues, in their situation, a different USB cable resolved their issue.

Thanks for this tip mate!

About time they gave an update… I checked a few months ago and nothing there yet.

And with the Khadas. It’s surely not the cable. I’ve tried several cables that worked fine previously.

Any updates?

I think as @FerrousBueller said, new driver might required for the the Win10 updates.

Hi @Cidious
Can you help do a test with another computer with the same KTB :wink: