VIM1 doesn't boot into ugprade mode at all

Come on dont be dissapointed. We will try to help you as much as we can.

Regarding the upgrade mode I faced the same problems in the beginning but then I found out that there are many ways to get it to boot in upgrade mode.

Have you tried the M register shorting method?

  1. Short the M register as shown in the documentation and then connect the usb c cable from vim1 to the pc. Make sure to have a working usb C data cable and a good usb port to power it.
  2. It will boot into upgrade boot automatically. Make sure to have the flashing software installed in the pc, for the os to detect the drivers of vim1.

Regarding the toneboard, I am not aware of it much but there is a thread where users have had the same concern and there is a way to resolve it too.

Please try the M register method for upgrade mode. It should definitely work.

Well that just brought forward the next problem.

It’s just hopeless. Endless stream of issues since I had the devices. Pardon me for having lost faith. So far just headaches and lost time and money.

Sometime we do get in troubles but that doesnt mean its the manufacturer or the support.

Lets be positive and try to solve issue one by one. So by the pic I assume you’re able to connect the device in upgrade mode, next you’re getting this error.

Can you check if the usb cable is causing the device to disconnect in the middle of the process. Else I would recommend you download the latest android rom again and extract it and attach it to the burning tool. As I suspect img issue here.

Also please share the connect error code from this image.

Dude. Thanks for your help. I mean it.

But in contrast I have 2 X96 Max boxes in the house working flawlessly at half the price. Updates and all.

I had already redownloaded the firmware but that didn’t matter I’ll use another browser and try again. I tried different cables and different USB ports and my laptop alternatively to my desktop PC.

Downloading with another browser now and seeing if that helps

Same error with fresh file.

[19:40:10 129][HUB2-5][Inf]--------------ERASE BOOTLOADER------------
[19:40:10 229][HUB2-5][Inf]–start SendIdentifyCmd
[19:40:15 229][HUB2-5][Err]–IOCTL_IDENTIFY_HOST_Handler ret=-116 error_msg=libusb0-dll:err [control_msg] sending control message failed, win error: The I/O operation has been aborted because of either a thread exit or an application request.

[19:40:15 229][HUB2-5][Err]–Identify status failed
[19:40:15 236][HUB2-5][Err]–[0x00101004]Erase bootloader/Lowper/Identify/Error result
[19:40:15 236][HUB2-5][Inf]–Close device handle 0x00000f30

Tried downloading different files, different cables, different computers.

It’s just a piece of unstable crap.

I’m just going to toss it in the trash. It’s dead weight. Rarely updated and just creates problems all the time. Better buy a couple of cheap X96 Max boxes that are faster and half the price and just work out of the box without getting headaches…

Every firmware update has been trouble so far… if there even was a firmware update in the first place… Tried Oreo once… didn’t even want to install packages… It’s just hopeless with these devices.

What did I pay extra for with Khadas? Black PCB?

USB Burning tools - not very nice software for update!!! (i think maybe can have diffs problems)

we try to do alternative way for images install !!!

now u can try just write image to SD
and boot from sd card if u cant write image to MMC

Hi @Cidious
Can you have a few more time tries with the Android Pie ROM, or have a try with the Android N(7.1).

The Android Pie ROM still not quite well suit for usb upgrade in some devices, but usually can be resolved with more tries :slight_smile:

We will fix the issue in next version ROM @Terry

For what it is worth, I have had no issues flashing the VIM1. I have found that getting in to upgrade mode successfully is largely a matter of timing on key presses. Humans are seldom good clocks or timers.:slightly_smiling_face:

If the Key press thing is such a complicated matter then Khadas has failed to program it in an accessible manner for usage.

And I tried flashing about 20 times now. it already gets stuck with downloading DDR. If I try again it will get stuck at erasing rom. After that nothing has changed. Still on 7.1

I did not intend to say it was complicated, it isn’t. If you are getting the tool to recognize your VIM1, then getting into update mode is not the problem. Forget my suggestion about erasing the eMMC, I don’t want to be the cause of further frustrations.
Hope you find the solution.

Android 7.1 works and 9.0 not on your device, right?

7.1 is still running. Pie doesn’t want to install.

Now at the point of Downloading UBOOT it just crash closes… not even an error code…

Now it just sticks at 5% low_power

Connected with original cable to rear I/O USB 3.0 port.

I spent some time trying to replicate your issue. I ran in to the issue when attempting to downgrade to the latest 7.1.
First attempt…

After 5 attempts(look at the tool’s log), never closed the tool or disconnected the VIM1, just clicked stop and then start again…

After burning Khadas’ Android 9…

After that I flashed superceleron’s Custom Android Pie(Normal), went right in.

I don’t know why yours is taking so many attempts, but it can be done.
By the way, these errors are not unique to Khadas products, but a product of the AML USB Burning Tool.
What i did…
1.) Open tool and load image, set to Erase all.
2.) Pushed and held power button, connected USB cable to the PC, held power button until the tool reported Connect success.
Clicked Start in the tool, when it failed I clicked stop, then clicked start again, repeated until it was successful.

Using the Burn Card Maker to update from micro SD card.
After all of that, I downgraded to the latest 7.1 again.
Using the Burn Card Maker, I loaded superceleron’s Custom Android Pie(Normal) in to the Burn Card Maker. I set the option in the burn Card Maker to Forcefully Erase All and made the card.
I ejected the card after the tool was done. With the USB-C cable removed from the VIM1, I inserted the card in to the VIM1’s card slot, held the power button and connected the USB-C(for power) cable to the VIM1, While holding the power button I immediately pressed the reset button for 2 seconds and released the reset button, held the power button for 10 seconds and released it. The screen goes black for a few seconds and then the Update screen with the little Android guy(see picture below) came on the screen, the progress bar advanced, when it was done the VIM1 rebooted. After a few seconds it started booting superceleron’s Custom Pie. Worked with out issue.
(Stock Photo)


thanks for your effor mate.

What I figured is that the Low_power thingy must mean the USB doesn’t get enough power. I tried ALL USB ports on both my AMD MSI B450M board AND my Dell laptop. But when I finally got my MSI GS60 laptop from the office to home, IT WORKED.

The strange thing is that I use the same USB ports that don’t work with the Khadas for my X96 Max boxes… so there is that…

Is the custom ROM worth flashing? benefits?

Thanks for the tips!


That’s great news and thanks for the update!

It worth if you want to dig more features of your VIM device.


So glad to hear you were successful. :slightly_smiling_face:
In the future, if you have issues with the USB update method, you can try the SD card update method using the Burning Card Maker, as defined in my post here, the last paragraph.

The custom ROMs from @superceleron are nice and as Gouwa said, they offer more features than the stock Android, as well as some tweaks to improve performance in some areas.
As he offers the ATV version you will have the option of using AndroidTV if that appeals to you.
Have a look at superceleron’s post on those ROMs for more information.
1.) Custom Android Pie ROM.
2.) Custom AndroidTV ROM.


There was no way of using the burning tool for me with my SD cards. I only have 64gb and 128gb cards and the windows format tool which is forced by the tool is not willing to format it in FAT32 since they are big.

I tried but it was a no go with exfat or ntfs.

I’ll try the custom rom then. I looked at stock and it’s very empty in the settings section.

Formatting larger SD cards to FAT32 can be done in Windows 10(may require 3rd party app/program). I do not have any cards 64GB or larger to test on at the moment. However, if you do a search you will find solutions for that. Some are on Youtube too.
Not sure if the SD formatter will do it, but worth checking in to.

1 Like