Khadas Vim3 + CoreElec all work!

I see :slight_smile:

Thank you for warning friend :), but I was not going to update what was originally installed incorrectly (messed up my device Khadas team, when installed CoreElect 9.2 Amlogic- ng and sent me this box TV maybe for solved this problem :)). I tried to install the android version of the image (using the multi-platform Etcher and Linux utility DD), but all the images available for installation (supposedly supported :)) are not bootable and are not recognized by the device. I already realized that the Khadas team does not have a 100 % working image for the VIM3L device. I’m not going to look for a solution for the seller :slight_smile: and simply already ordered raspberry pi 4 to replace this beautifully packed “garbage” (that’s all :)). I already don’t have confidence in this project :), Khados is a poor quality product for several times overpriced (“buy yourself a problem and solve it yourself” is the slogan of this project! :)) … which they spent not only mine money, but also what’s the most annoying - personal time (waiting delivery, trying to solve the problem, plus I’ll have to write reviews on other information resources so that other people do not get into a similar situation).

You are entitled to your opinion on all these issues, but let me beg to disagree.
The CE version packed with the VIM3L works and is fast. Its as described. The VIM3L you bought didn’t come with Android so it doesn’t fail to meet its sales description and it shouldn’t be a disappointment.
Khadas does tend to be slightly more expensive than other options - but the build quality and components used are better than most making for a more reliable product. I have a VIM2 which has been in continuous daily use for two years at this stage.

Let me just say, Etcher and DD are not the correct tools for loading Android images onto the VIM3L - the correct tool is AMLogic burn tool and if you fail to follow the instructions as to how to use the correct tool you should not be surprised that you meet with failure. Try it and report back.

So I suppose I would just say that I think you are mistaken in your assessment, but thats you right.

Shoog

3 Likes

This is absolutely not true, they have 100% working Android, Ubuntu and OpenWRT images that can be found here, you can follow the instructions here for flashing if you are unhappy with the CoreELEC image.

I have to disagree, it does not overheat (RPi) and it has working USB (N2).

I think you will be better suited at the RPi community, good luck. :point_up:

2 Likes

Уou apparently didn’t understand me correctly (sorry, this is probably my fault since I did not describe the problem initially) :). I am not indignant because the device with the pre-installed СoreElec (instead of Android) was sent to me (I can read the description of what I’m buying :)). I am outraged that seller sent me almost no working device (why not testing?) and there is no working image from Android and no image from СoreElec to solve this problem.

You claim that a person using the Linux operating system is not able to record the image and install it according to the instructions? :slight_smile: Seriously? :slight_smile: … is it easier to think that other people are dumb? :). Ok, let it be as you say. I am really a dumb user :slight_smile: because I bought what I need to fix now. I agree with you :slight_smile: it’s all my fault. It’s just strange why I didn’t have such problems with other TV boxes? :).

In any case, when I ordering Vim3L, I paid for a kit htpc that includes passive cooling :). Why if buy RP4 would not buy cooling for RP4?!?, what’s the problem (whose problem is this?!? exactly mine?)? :). USB - does not work in RP4?!? Seriously? :). You have RP4 or you have experience with raspberry PI 1-3 (these are different conditions :))?

I think so too. Thanks!

If I send you my address can you please send me the VIM3L? I’ll pay for the postage! Thank you in advance!

Because you’re either unwilling or incapable of making it work.

2 Likes

I wanted to try this device as cctv server or network storage, if can’t, I will send you :slight_smile: DHL Freight’s, ok?

some kind of weird logic / argument :rofl::+1:

I think it’s not weird. Are you able to make it work? It seems you can’t. So there are two options: either you don’t want to, or you don’t have the expertise to do it. After all, it’s a SBC, this version is very user friendly but it’s still s SBC.

1 Like

And if i cannot use it as a tv box should i send it to you? :thinking: Sorry, you are Russian (sorry for the comparison)?

Sorry I couldn’t catch that. I:m not into xenophobic comments.

1 Like

Where did I ever say that or insinuate that? I’ve tried to help you but I’m getting bored of this now buzz, instructions for Linux can be found elsewhere.

Hello, Sorry I have not been following this issue, as I do not have the VIM3L. I am curious if you were unable to flash firmware to the VIM3L using MASKROM mode?

You warned about the possibility of errors in the firmware of the architecture, and I sincerely thanked you for it :+1:. But then you wrote that I was 100% wrong when I claimed that there was no working image for Vim3L. Gave me the link :). Where do you think I looked for ready-made images? :). Now show where among the images you have listed, is there an image for installing (or reinstalling) CoreElec on Vim3l? Why do I need an openwrt or ubuntu on a TV box (of course I can install it, but why?!? I try use Vim3L how TV box, if I dont use this device how TV box, when I only try use how network storage with openwrt or ubuntu) :). I could not install the working image of the android system. I took it from the site (there is one more image here, I also tried to clone it SC_VIM3L_ATV_FINAL-v1.0-20191023), it did not help either.

ok! No problem :)… thanks for trying :slight_smile:

Hello Friend! I dont understand what mean “MASKROM mode”, I tried TST mode (recommended): 3 clicks for 2 seconds (as per the manual) and the Power-LED (Blue) turns OFF. I also tried through successive presses of the shutdown and reboot buttons ( Keys Mode (U-Boot is Running Normally). They are not bootable android image :). This image android system is not ready for the basic installation (I clone image with Etcher and DD linux utility dd if=sdcard.img of=/dev/sdX bs=4M), most likely it is for updating :slight_smile: or maybe not normal work U-Boot for Vim3L device. The seller answered me that he would prepare a normal image for recording on CoreElec. Maybe in a couple of months it will be possible to reinstall :).

maybe I have a similar problem :slight_smile: and it’s not even about the images for recording :slight_smile:

If you have been messing with dd then its highly probable you have messed up your uboot and the only path back is mreg

I would say read a lot more before trying to flash anything. All these procedures are well documented here and at the CE forum.

Shoog

You probably don’t understand that the firmware didn’t happen :), you can’t ruin anything if you can’t even flash it :).

you write obvious and banal things :slight_smile: without understanding problem :), and I don’t understand why you are writing this to me. Please do not write me anymore please (in your messages there is no useful information for me :)).

You can enter TST mode to reflash the image in any situation.

1 Like

I use Etcher for clone CD:
`


this message when cloning an official android image. The image is not bootable.

After enter upgrade mode do you follow the documentation to flash your device?

These Khadas are too complicated for normal users.
Perhaps for learning in universities or other similar uses, but to use as a movie player for the general public is a mistake.
I regret not having bought the RBP 4.
Everything would have been easier.

1 Like

:+1: I’m sorry about that too.