VIM3L htpc to android, on emmc, how i can do?


This text will be hidden

There is no working image :), none of the images on the Khados website for the android operating system is working (they are all damaged) :). At least when I tried yesterday I didn’t succeed :(.
Do you have any delays with the remote control on the pre-installed CoreElec system (can you press the button a dozen times for something to happen?)?

1 Like

Don’t give misleading advice when you haven’t tried the correct method to burn an image.
The correct method is to use the AMLogic USB burn tool, or the AMLogic SD burner tool.
No other methods are supported by Khadas.



ok :), dear @c8hd64bit, don’t listen to me, but listen to the advice of the user @shoog and write down a damaged image that will most likely ruin your device. Do not forget to thank the distinguished @shoog for his support :). Is that ok @shoog (you will no leave your “informative” messages for me in all topics?)?

Khadas SBCs are very hard to ruin via firmware flashing. I purposefully flashed a different maker’s firmware for a different SoC on to my VIM3. Of course it bricked the VIM3. No worries, using TST, the USB Burning Tool and a VIM3 image, the VIM3 was back in business. Easy to recover. I honestly do not understand why you are having difficulty, but we should be able to get you through it.
Above you said the images were damaged. Can you point to the specific image and the method you used to flash it? I will attempt to check it.


@RDFTKV image (both) + SC_VIM3L_ATV_FINAL-v1.0-20191023 (I don’t remember where I got the link from, someone on this forum gave me the link).
The method has repeatedly described: Etcher + dd if=update.img of=/dev/sdc bs=4M. The last time Etcher indicated that all the images used were damaged (I tried to write to different SD cards and one USB flash drive). The recorded image (when 2 days ago it was still possible to record), according to the instructions, I tried to overwrite it on the device using the TST. It seems that I would have said everything, just in case I tried and now write it down, here is a screenshot (By the way, I can’t check the integrity of the file since MDS or checksum is not specified)

OK, as it applies to Khadas SBCs, Etcher and similar are used for images designed for booting/running from an SD card or USB attached storage. Etcher and similar will not work for the VIM3L Android images as those are designed to be flashed using the USB Burning Tool or Linux burning tools. This also applies to superceleron’s SC_VIM3L_ATV image(s).
In some cases, the provided images can be used with the Burn Card Maker, though I have not tried it on the VIM3L, the VIM3 and VIM3L are very similar. A Linux method(not tried by me) to make the card is here.

You should be able to enter upgrade mode by using the keys method or TST.
MASKROM mode will be indicated by the VIM’s LED blinking blue for a few seconds and then it will go off.
Let me know what happens when you follow the above guides and instructions. Please let me know at what step it fails.

1 Like

ok. You gave a link to the installation manual from Linux (Ubuntu) :), I cloned a git (all the files I had already installed) and tried to run the script, assembly :). I do not have Ubuntu, so the script failed (my distributor has a different file structure, so the Khados manual didn’t help me with anything). I will not reinstall the operating system due to the fact that the developers of Khados have not learned how to use universal tools (utilities) and cannot assemble the image that is normal for installation.

And that is Sabayon?

The script filed, than i’m looking at krescue but I still haven’t understood how to use it

Have you tried installing virtualbox ( or similar and running the burning tool on an Ubuntu guest is?

By the way the burning tool is amlogic’s tool not khadas and it is their tool that only supports Ubuntu. You could try editing the install script to match your file structure and see if it works? But I would try virtualbox first.

This method of burning images is pretty standard for anything with emmc. I’ve personally burnt somewhere in the region 350-400 images onto khadas boards using this method and it works. I personally think it’s better than burning to SD cards or usb sticks but that’s because I can do multiple boards in parallel with a usb hub and the burning tool, but do realise that is an edge use case


I’m tryng right now.

Sorry @c8hd64bit that comment was aimed at @laritus. But if you’re trying to install on a non Ubuntu platform that might work for you as well!

1 Like

no, this is Archlinux

You were told by Khadas and myself the way to do it and you chose not to follow instructions. Like trying to be a car mechanic with kitchen tools - it doesn’t work.
Its a shame, but life goes on.


It’s a shame when you say to a person, don’t write to me anymore, but the person writes anyway (I already said three times, but the person didn’t understand :face_with_symbols_over_mouth:). Your advice is not concrete or objective, you just constantly get tired and reproach other people, and you don’t understand even half of the problem (as now, when you write the next nonsense). I’ll ask you again, do not litter in the topic, do not write anything to me (I don’t need your advice! Do you understand? Not at all).

Are you going to try to use the tools recommended, or are you going to continue to bitch about how you can’t get it to work doing it your way ?


While I was studying how to do it, while I was using the media center it started to crash and a red light appeared. I was no longer able to get it working, but fortunately I managed to install android but even this, after the first start, it never restarted.

I would check the power supply. If it cannot be measured, substitute with a suitable power supply, 5 volts, 2 amps or better.

The power supply is ok, I left the board turned on for a about 10 min, and now its works. But some other problems comes to me. I will open a specific discussion.

1 Like