Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

For VIM1 (s905x) used kvim.dtb

Hi balbes,

Thanks for your reply

Yes I have tried kvim.dtb, but with Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate_20180128.img but it does not appear to work kvim.dtb for me, it just gives a blank screen.

Maybe I am doing something wrong
"cp ./boot/kvim.dtb ./dtb.img"
or is something more that I am to do with this image.

The monitor that I am using for the test is a 27" 1080p screen
I have tested
Which have all worked.

Is there something else that I am meant to do with the Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate_20180128.img

For kernel 4.9.40 on VIM1 need the right u-boot. What firmware is installed now ?

I am running Vim_Marshmallow_Root_170603 and I updated via that was included with Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate_20180128.img

Is there a different method that I would be following?

Need to check with @Terry , which version need to update u-boot in Android that would work on core 4.9 VIM1.

Can you tell me how to download the Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate_20180128.img?
I will hava a try for it. Thanks.

Hi Terry,

Thanks for having a look, the image can be obtained from

You need to following below steps to boot Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate Rom.

1) Flash VIM_Oreo_Preview_V171229 Rom into your VIM

2) Insert your TF card with Armbian Rom

3) Long press power key and don’t release

4) Connect your VIM Type-C port with DC adapter

5) Release power key after 10s


Don’t insert the TF card with Armbian Rom while the VIM device enter into android system. Because the system will change the property of ext4 file on TF card. To solve this problem, instead of the droidvold executables with adb command.

//The IP_ADDR is the IP address of your VIM
# adb connect IP_ADDR
# adb root
# adb connect IP_ADDR
# adb remount
# adb connect IP_ADDR
# adb push droidvold /vendor/bin/
# adb shell sync
# adb shell reboot

Good luck for you!:grinning:

1 Like

Thank you, I now have Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate up and running, smooth and without any flicker, and I did have a successful push in of the droidvoid – I just used adb commands from another Linux box via a USB cable, after setting the Android in developer mode, with USB debug enabled.

My next step see if I can rotate the screen to portrait mode via using xrandr or if anyone has any hints.


Hello, I had success with this. May have been running an older version.

But check this too, xrandr may not be necessary.


Do you have the link of the screen rotation that does not need xrandr, as the links that yuo have supplied are both the same links.


I have this firmware installed on my VIM, I just checked and xrandr(using the commands below) is not working on it. Also rotation options are greyed out in the native display manager on my installed version.

My version is different than the version shown in this thread. So my previous post may not apply. My apologies for that.

BTW each link should have gone to a different post in the same thread. First link was to my post demonstrating xrandr. The second link should have gone to a post in that thread by balbes150 where he stated rotation worked from the display manager(on his version). The display manager can be located at Preferences/Hardware/Displays. But as stated, rotation not working on the Mate version installed on my VIM now.

xrandr worked on an older version, not working now…
Open terminal and enter one of these lines…
xrandr -o left
xrandr -o right
xrandr -o normal
xrandr -o inverted

O.K. I have got rotation now on Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate to work, not sure if I can skip the of replacing the X server, yet as I was just hacking away, being very rough.

What I done
apt-get remove aml-mali-905
apt-get install xserver-xorg-video-fbturbo
edited /etc/X11/xorg.conf.d/50-fbturbo.conf
Just after the line
Option “fbdev” "/dev/fb0"
I then added
Option “Rotate” “CCW”

That section now looks like
Section "Device"
Identifier "Allwinner A10/A13 FBDEV"
Driver "fbturbo"
Option “fbdev” "/dev/fb0"
Option “Rotate” "CCW"
Option “SwapbuffersWait” "true"


A little surprise to Chinese New Year holiday.

Image update Armbian 20180203.


Image update 20180204 kernel 3.14.29 and 4.9.40. Added version of the images with mali-6 (Ubuntu Mate and Debian XFCE). In these images uses a new library libMali r6p3. These images are in the directory mali-6 on the website. In the directory mali-5 are all old images 20180203 (server and desktop variants). Added to the website version of the images with the kernel 4.9.40 a working version of KODI. Pay attention to the images 20180204 c kernel 4.9.40 Mate and XFCE desktops contain a version of KODI 17.3, which can work on models with S905X. Important. The image with the kernel 4.9.40 to run KODI, you need to log on desktop (which would have been on MATE or XFCE) and from it (via the menu) to launch KODI. Only in this mode will work the sound in KODI. When you exit KODI the screen will remain blank (black), for the appearance of the desktop you need to switch to another console with CTRL+ALT+F1 and go back to your desktop CTRL+ALT+F7.


you build so many roms that it has become difficult for you to surprise us,
the real surprise some of us expect will be when you will publish a linux rom we can flash to emmc over the usb cable :gift: and not depending on some android being on the emmc first

As always: congratulations.
Just curious, where does the libMali r6p3 originate from? Did you build it from source? If so, which source? As for the 4.9.40 kernel. It was built from your linux-khadas github, right?
have a nice day

I don’t plan nor any options to use through USB Burner Tool. To install in the eMMC there is a script Maybe in the future I will add a shortcut to it to desktop the DE versions image, it was possible to run install in eMMC directly from the desktop clicks.

The library and the source code for the kernel I used from GIT Khadas (Fenix = libMali, Linux = gpu\arm). Yes, the version of the images with the kernel 4.9.40 I gathered with the use of my GIT (linux-khadas branch ubuntu-4.9).

1 Like

A corrected version kernel 3.14.29 of the images with mali-6 20180205.
Fixed KODI in HW mode.

1 Like

New Image 20180210 5.41

1 Like