Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

Sorry for the delay, its a 912 model. I’m going to re-format the sd card and try again.

Okay… I am not sure what I did wrong the first time around but I changed the whole way I did everything.

First I downloaded Etcher which works for windows, linux, and Macs.
Then I downloaded another image version ubuntu_mate_17_04_4.9.40_20171216.img.xz

On my SD card I ran this command in terminal to zero everything out sudo dd if=/dev/zero of=/dev/rdisk2 ( Tried this with DU but kept throwing an error from previous try at it ).
Then used DiskUtility to format in Fat32.

Next I used Etcher to put the image on the SD.

There are still Failed loading resources couldn’t tell which. I also noticed that the initial login screen is for Kodi. I entered my pass word 4 times and it just kept cycling back to the login screen.

Finally I clicked on the icon on the top right and switched to Mate… Now I am at the desktop :slight_smile:

Other than the Kodi login not working which doesn’t bother me, I just wanted Linux on it. I can use Kodi on the Andriod side. Now I wonder if rebooting back to Andriod will be an issue. Otherwise I’ll just remove the sd card.

Thanks for your help

I leave for vacation. :slight_smile:
All the questions and answers after the holidays.

Wish you a nice holiday!

Yes, enjoy your well deserved holiday. Have fun! :slight_smile:

1 Like

Added the files to MEGA. Try this link.!Xw4WVBqY!xgPbJkJkfMUIVoCAX2hBlQ

1 Like


I have a problem, when i’m running nand-sata-install on my tv box i got:

root@amlogic:~# nand-sata-install
Start copy system for DATA partition.
Formatting DATA partition…
umount: /dev/data: mountpoint not found
The file /dev/data does not exist and no size was specified.
e2fsck 1.43.4 (31-Jan-2017)
e2fsck: No such file or directory while trying to open /dev/data
Possibly non-existent device?
Copying ROOTFS.
mount: special device /dev/data does not exist
Copy BIN

Copy VAR
tar: var/log/syslog: file changed as we read it
tar: var/log/messages: file changed as we read it
tar: var/log/kern.log: file changed as we read it
Copy fstab
umount: /ddbr/install: not mounted

Done copy ROOTFS

Writing new kernel image…
dd: failed to open ‘/dev/boot’: No such file or directory
/dev/boot: No such file or directory
/dev/boot: No such file or directory
/dev/boot: No such file or directory
/dev/boot: No such file or directory
Writing new dtb …
Write env bootargs
Cannot parse config file ‘/etc/fw_env.config’: Invalid argument
Error: environment not initialized

Complete copy OS to eMMC parted DATA

After that nothing happend i still can boot android installed on eMMC.

  1. What model VIM ?
  2. What firmware is in the eMMC ?
  3. Which version of the image Armbian ?

I am not sure what i am doing wrong.

What i want is Ubuntu + Kodi running on the eMMC.

No need to backup my eMMC, no need for wifi (cable attached for better and stable performance).

  • Model: Khadas VIM2 Max
  • Firmware eMMC: Currently VIM2_Ubuntu-mate-16.04_Linux-4.9_V171028.7z installed but it can be removed.
  • Version Armbian: Tried both of these
  • Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180116.img.xz

  • Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180116.img.xz

Tried using USB-cable method (extracted them so i was left with a *.img file), but it did not work, then i read i have to put on the sd-card first i believe (and ./install etc.). This is the output i get using etcher.

Error: stdout maxBuffer exceeded
    at Socket.onChildStdout (child_process.js:270:14)
    at emitOne (events.js:96:13)
    at Socket.emit (events.js:191:7)
    at readableAddChunk (_stream_readable.js:178:18)
    at Socket.Readable.push (_stream_readable.js:136:10)
    at Pipe.onread (net.js:560:20)

I also tried formatting the micro-sdcard to fat32 and then write the image, but same result. The sd-card i am using (SanDisk Ultra 16GB (10) MicroSD HC 1)

Is there no method of just using USB-cable method of writing to the NAND/eMMC?
Also does hardware acceleration work now? As i have not found any indication of Mali T820 being merged in to the kernel or does it work now with 4.14?

  1. Installation Armbian in the eMMC, use the description sections of the standard Android firmware. So setting Armbian in eMMC only works when you have staffing in eMMC firmware Android. Therefore, from the beginning to restore staffing in eMMC firmware Android (latest version VIM2_Nougat_V171028). Then run Armbian external media and install Armbian in eMMC.
  2. Version KODI in the way Armbian does NOT work with VIM2 (S912). To play full screen video on the VIM2 you need to use the system Libreelec or Android.
  1. Its not VIM i found this topic on armbian tvbox its “Mi box mdz-16-ab (Amlogic s905x)” i accesed uart and changed to boot from usb
  2. On tvbox is nougat 7.0 beta 1028
  3. Armbian 5.37_S9xxx_Debian_stretch_3.14.29_server
    Tv box partition are named:


when i try to moutn mmcblk0 it says “is write-protected”

So to repeat if i have understood it right what you have said.

  1. Restore to the original settings in the sense of having Nougat installed on the eMMC because of the functionality “staffing”. The latest version currently being (VIM2_Nougat_V171028)

  2. To install (rewrite) over Nougat on the eMMC, i have to put Armbian on a external media. What software do i need to use to put Armbian on for example Microsd-Card? As i was having problems with Etcher (Using Ubuntu 16.04 desktop to do this)

  3. As my reason to use KODI with VLC as external player that could be done very easily, it is rather kind of a full stop of having Armbian then right? Why does KODI not work properly yet with VIM2?

  4. What would you recommend me to use instead? As i want to be able to update to latest KODI when available without any extra work (just a apt upgrade using a repository) and have also access to latest VLC using a repository, not to forget using VLC as external player for KODI. I’m sorry for bothering you with so many questions.

EDIT: Life is good…LG…ooh i mean things have worked out so far. I have chosen Android Nougat as OS and KODI from playstore with “Kodi boot” as an app to launch KODI when booting Android. I have tested some of the videofiles and so far everything is working fine and VLC not needed.

Do not confuse VIM user, I suggest to write your questions in the appropriate topics on the forum Armbian.

To use KODI to automatically update, I recommend to use the version Libreelec collected Kszaq (the forum has a special topic about it).

Hi balbes150,

What’s the difference between Armbian_5.32_S9xxx_Ubuntu_xenial_3.14.29_mate_20171012.img and Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180116 ? Does image V20180116 KODI work well on VIM? I found that image V20180116 login interface is strange, and KODI can’t play 4K video smoothly. And with the same VIM board and SD crad image V20171012 work well. Do you ever meet this ?


Hi Nick. I don’t have 4K equipment so I have not tested it in this mode. In the latest images 20180116 use a modified (test) kernel, with a set of dtb files from LE Kszaq. Perhaps you need to change settings in the dts file kvim (I haven’t tested this).
You can check the work of 4K with VIM version 20171226 (which is on my website) ?

Hi balbes150,

Yes, I tried V20171226, KODI works well.:wink:

By the way, which branch you use to build armbian images? Branch armbian or le?


Version 20171226 - branch armbian, version 20180116 - branch le. It looks like the branch le something is broken, I will understand.

1 Like

Hi Oleg,

Thanks for your patient reply. :wink:

For the image Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_mate_20180128.img

What’s the best dtb file to use with the Khadas VIM? that is the standard VIM not VIM2

The files that I see in BOOT/

On other versions that I have tried with the 4.9 kernel I had used “meson-gxl-s905x-khadas-vim.dtb” but this file does not appear in this image or does this image only support VIM2?