Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

Updated Armbiam images, version 20180212 with kernel 3.14.
Fixes WiFi for the VIM2. Please check the operation of the Wi-Fi in VIM1 s905x (1\8) and VIM2 Pro (3\32).

1 Like

New version Armbian 20180305 (kernel 3.14.29) of the KODI-17.6 (for s905\s905x).


I updated the KODI-17.6 package for Ubuntu and added the KODI-17.6 package for Debian. Now these packages can be installed on any system (Server, ICEWM MATE\XFCE etc).

If install KODI-17.3, remove all old packages starting with “aml -*”.

Download and install the command "dpkg -i " new packages
(aml-amremote_5.41_arm64.deb aml-codec_5.41_arm64.deb aml-mali6_5.41_arm64.deb).

To install the new version KODI-17.6 aml-kodi-debian\ubuntu package, use the command

for Debian

apt install -f /full_patch/aml-kodi-debian_5.41_arm64.deb

for Ubuntu

apt install -f /full_patch/aml-kodi-ubuntu_5.41_arm64.deb

to install all the dependencies.

1 Like

Can you please tell me - I have a remote installation on ARMBIAN 5.37 user-built Ubuntu 16.04.4 LTS 3.14.29 . Is there any newer version of it with x11 mali gpu support?

This version does not.

And what version does have?
I can make a new installation easily ради такого счастья.

Armbian_5.37_S9xxx_Ubuntu_xenial_4.9.40_server_20180204.img fails to load module dhd (on VIM2 Max) - modprobe dhd gives error

> dhd: Unknown symbol wireless_send_event (err 0)

Armbian_5.41_S9xxx_Ubuntu_xenial_4.9.76_icewm_20180219.img also cant get WiFi to work: in this case there is confusion as kernel is actually 4.9.40 - /lib/modules/ has subdirectory 4.9.76 but in any event has no …bcmdhd/dhd.ko

In version 4.9.40 20180315 wifi module (dhd) is.

Yes the module is present but gives an error loading.

Everything works right for me.

Update image Armbian kernel 4.9.40 20180315.

1 Like

For reasons I fail to understand I can no longer download Armbian (to my yandex disk or local).
Anyone else experiences issues?

I have downloaded twice in last 6 hours with no problem from Yadi link in first post (4.9 subdirectory)

I am doing something wrong I guess :frowning: But can not work out what!!

  1. Download image (I have tried Armbian_5.41_S9xxx_Ubuntu_xenial_4.9.40_server_20180315.img.xz and Armbian_5.41_S9xxx_Debian_stretch_4.9.40_server_20180315.img.xz)

  2. unxz Armbian…img.xz

  3. sudo dd if=Armbian…img of=/dev/sda bs=4M

All the above is done on my VIM2 Max (64G eMMC), which is running Khadas Ubuntu server image flashed via USB cable. And runs wifi fine, loading dhd.

  1. I do NOT change any dtb.

  2. Insert sdcard anto VIM2 and boot. Armbian comes up fine, reset root password, create user, reboots.

  3. Login - always get fail to load dhd as per my post 130 above: (unknown symbol wireless_send_event in dmesg). I can modprobe mali fine.

Any magic suggestions welcome!!

Use the dtb file for VIM2.

I’m trying to run Ubuntu with Mate (Armbian_5.41_S9xxx_Ubuntu_xenial_4.9.40_mate_20180315.img) from a sd-card.
When I try to log into the gui with my newly made user the screen flashes with some “startup lines” (to quick to se) and returns to the login screen. When I try to login with root I get an error message - “ttyname failed: inappropriate ioctl for device”.
I can start Mate via ssh but then I’m stuck as root in the gui. I got the same scenario with the 20180204 and the 20171226 image.
Anybody know what I can do to fix this?
Thank you

I’m on a VIM2 Max by the way

See these topics. It describes all the details. Unfortunately, I can not post this info in the first message of this topic (I can’t edit old posts).

1 Like

I’ll look through them. Thank you

I tried kvim2_linux.dtb, no difference. Then I tried some of the other dtb, still no impact. Indeed, even if I place a completely unviable dtb.img Armbian boots fine but modprobe dhd always fails.

When running the Khadas server image from emmc I can find no apparent active dtb.img. My vim2 seems to have some hidden dtb that I cannot override!