VIMs Ubuntu 18.04 V181030


#41

Tnx
I think I will be able to solve this issue and through the addition of need (my) startup script … :wink:


#42

I’ve tried latest image made from khadas fenix script v0.5, ubuntu bionic xfce with 4.19.7 kernel.

I must say system is much smoother now, i can’t compare it to armbian, i now really can’t tell if there is any difference in terms of speed.

It runs pretty decent with my sd card, i really hope that we will soon be able to run accelerated desktop along with working video decoder.


#43

@numbqq, can you update fenix repo, 4.20 is out?


#44

Yes. just found that 4.20 is released, will do it…


#45

@numbqq, you still haven’t updated…


#46

Yes, not yet. I will do it next week…


#47

Any expectations about working Wi-Fi on VIM2 Pro/MAX(AP6359SA)?
What about Ubuntu 18.10?


#48

No driver for AP6359SA on mainline kernel yet.

Will add support on Fenix.


#49

@numbqq, i’ve made Ubuntu 18.04. xfce 4.20 image using fenix scripts.

It works, but i do have a problem, now i don’t have any sound coming from my hdmi monitor.

In the past, i would sometimes need to enable hdmi audio, but now i don’t have any hdmi audio option to check in settings, it only finds “dummy output”.

Is there any workaround, some config file to edit or something else, vim is connected directly to hdmi monitor.

Any help is greatly appreciated, i didn’t have any problems with 4.18 and 4.19 kernel, maybe this new kernel broke something?

I did made deb packages, but when i lost sound, i tried to reinstall whole image, and it didn’t help.


#50

Yes, the sound card not work, you can find the description in this commit about this, I’m not sure what’s going wrong yet, maybe something changed or I missed some patches…


#51

I did return to kernel 4.19, running on a 32gb ssd connected through usb, i must say the system is now faster than it was when running on sd, there really is a difference.

@numbqq, can you please investigate what went wrong with sound, and fix it if it’s possible.


#52

i had no sound also on x86 18.10 and 18.04 on my teclast x16 power intel atom x7 tablet,
it was due to some ubuntu unexplained bug
workaround was to blacklist hdmi audio like this…

sudo vi /etc/modprobe.d/blacklist-snd-hdmi-lpe-audio.conf

insert “blacklist snd_hdmi_lpe_audio” in that file,
reboot


#53

@ravelo, tried it, didn’t work for me!


#54

ok, a fix is to be found and applied at kernel level , first