VIMs Ubuntu 18.04 V181030


#1

Here we release new Ubuntu ROMs V181030 for VIMs. The images with mainline kernel 4.19, thanks @narmstrong and BayLibre team!

Check Firmware Page to download the ROMs.

ROM Infos:

Change logs:

  • Ubuntu

    • Update to 18.04.1
  • Kernel

    • Linux 4.19
  • U-boot

    • 2018.11-rc2

Known issues

  • VIM2 Pro/MAX(AP6359SA) Wi-Fi not working
  • VIM2 Bluetooth not working

Upgrade guidance:

  • The image name contains SD_USB means that it is for SD/USB installation, can only burn to SD card or U-disk, need Android running on eMMC and activate multi-boot, please refer to Boot images from external medias.

By the way

Ths images are built using Fenix scripts, you can use it to build your own image!

Have fun!


Linux only distributions
#2

Can you please be so kind and help me with the question:
How to upgrade an existing Ubuntu 16.04.5 LTS system to it?


#3

Hello kkkkk,

You can’t upgrade from 16.04 to 18.04. You have to reinstall it.

Thanks.


#4

Any special changes, what is working or not working in this image?

About fenix scripts, few days ago i’ve tried to run it to check which kernel version is used, 4.17.x was the last, so my question is do you need to update the scripts to update kernel version, or is it done automatically?

Are there any special vpu patches included in this image, or will you work on it for the future releases, 4.19 is lts release?


#5

I’ll push the code to GitHub.

Yes it is. You can use mpv player to play video but only 1080P or lower, can’t play 4K video yet.


#6

Don’t care about 4K, i don’t have any 4k monitor or tv, i am happy with 1080p videos and 720p videos when browsing for now.

I’ve flashed 4.19 xfce sd image, synaptic search is very slow, i can’t remember what file i need to edit to be able to correct it, can you help?


#7

I’ve no idea yet, but this topic maybe will help you


#8

OK. Please try this:

khadas@Khadas:~$ sudo rm -rf /etc/apt/apt.conf.d/02compress-indexes
khadas@Khadas:~$ sudo rm -rf /var/cache/apt/
khadas@Khadas:~$ sudo mv /etc/apt/sources.list /
khadas@Khadas:~$ sudo apt-get update
khadas@Khadas:~$ sudo mv /sources.list /etc/apt/sources.list
khadas@Khadas:~$ sudo apt-get update
khadas@Khadas:~$ sudo reboot

And try again!

Thanks.


#9

I did it, search now works normally, however i now can’t install packages, getting errors.

E:Could not open lock file /var/cache/apt/archives/lock - open (2: No such file or directory)
E: Could not open file descriptor -1
E: Unable to lock the download directory.

Issue solved, everything works now, “sudo apt-get autoremove && sudo apt-get clean && sudo apt-get autoclean” did the trick.


#10

thank you khadas team !!
but where is the 4.19 based ubuntu distro for emmc ?


#11

The images are for SD/USB installation, but you can write them to eMMC, too. Please follow the steps:

1. Boot from SD card

2. Write image to eMMC

khadas@Khadas:~$ sudo dd if=VIMs_Ubuntu-xfce-bionic_Linux-4.19_arm64_SD-USB_V20181030.img of=/dev/mmcblk1 bs=8M
khadas@Khadas:~$ sync

NOTE: For VIM2 you need to update the u-boot. For VIM1 ignore the step.

khadas@Khadas:~$ wget https://dl.khadas.com/Firmware/VIM2/U-boot/u-boot-v2018.11-rc2_VIM2_Ubuntu_20181031.bin
khadas@Khadas:~$ sudo dd if=u-boot-v2018.11-rc2_VIM2_Ubuntu_20181031.bin of=/dev/mmcblk1 conv=fsync bs=1 count=442
khadas@Khadas:~$ sudo dd if=u-boot-v2018.11-rc2_VIM2_Ubuntu_20181031.bin of=/dev/mmcblk1 conv=fsync bs=512 skip=1 seek=1
khadas@Khadas:~$ sync
khadas@Khadas:~$ wget https://dl.khadas.com/Firmware/test/extlinux/VIM2-mainline.conf 
khadas@Khadas:~$ sudo mount /dev/mmcblk1p1 /mnt/
khadas@Khadas:~$ sudo cp VIM2-mainline.conf  /mnt/extlinux/extlinux.conf
khadas@Khadas:~$ sync
khadas@Khadas:~$ sudo umount /mnt

3. Remove SD card and reboot

Edit

Try to write image to eMMC on VIM2 and boot to login prompt successfully, but I can’t login. Maybe I need to find other way to do this…


#12

For VIM2: Another way to write image to eMMC. Use some scripts from @balbes150.

1. Boot from SD card

2. Write image to eMMC

khadas@Khadas:~$ sudo -i
[sudo] password for khadas: 
root@Khadas:~# wget https://dl.khadas.com/Firmware/test/install.sh
root@Khadas:~# chmod +x install.sh
root@Khadas:~# wget https://dl.khadas.com/Firmware/VIM2/U-boot/u-boot-v2018.11-rc2_VIM2_Ubuntu_20181031.bin
root@Khadas:~# mv u-boot-v2018.11-rc2_VIM2_Ubuntu_20181031.bin /boot/VIM2-u-boot.img
root@Khadas:~# ./install

3. Remove SD card and reboot


#13

I have maybe a stupid question… but since this is using the mainline kernel, does that mean the kernel will get updated along with the rest of the system straight from the Ubuntu repositories?

Or is it somehow patched and will stay at 4.19?


#14

Hello geokon,

The kernel will keep updating with mainline kernel for future release.


#15

Oh wow. So after this I will no longer need to reinstall new images and as GPU/VPU support improves in the kernel they will automatically start working for me?


#16

Is there a way to get Wi-Fi working on KVIM2 Pro/Max?


#17

Will it be possible to update kernel only in future updates, without touching the system, this is now possible on Armbian Amlogic images?

I am a little bit tired of frequently changing Linux images, both Armbian and Khadas, installing same software all over again, this would be great to have.


#18

I do have a question.

I am using Windows for most of my life, sometimes dual booting it with Ubuntu or Linux mint, mostly using gui software with it, so i don’t understand many Linux technical terms you use here, and there isn’t much info properly explained on the internet for a noob like me.

Will all of these future patches for our Amlogic boards make it in kernel 4.19. lts?


#19

To be honest, I not quite understand your question here :wink:

You mean VIMs or your PC?


#20

I mean Vim’s, will all the future Amlogic updates also be updated in kernel 4.19?