VIMs Ubuntu 18.04 V181030

#61

Update:

There are two ways to use Mali on VIM1:

  • Closed Source mali driver
  • Open Source In Development Lima driver

For Closed Source mali driver, Fenix is supported, and you can build Ubuntu Mate 16.04 with X11 GPU support, but the mali blobs provided by Amlogic is defective, the fps of glmark2-es2 is only 7.

Lima for X11 is still not usable, you can find some information here:

0 Likes

#62

Well, i am not sure if they are using lima drivers, you can see on @narmstrong github that mali is updated, i really don’t care if it is open source or not, as long as it works, probably lima will be much better than closed driver once it matures.

0 Likes

#63

Nice article about lima driver: https://www.phoronix.com/scan.php?page=news_item&px=Lima-DRM-Driver-Mainline-V2.

0 Likes

#64

Is this image to SD or eMMC?
https://www.phoronix.com/scan.php?page=news_item&px=Lima-DRM-Driver-Mainline-V2

0 Likes

#65

There is no image in this link, it is an article!

0 Likes

#66

Sorry, wrong link:
khadas-vim-ubuntu-bionic-gnome-wayland-4.19.8-V20181219

0 Likes

#67

This image is for Emmc only.

0 Likes

#68

And can be installed with sing USB-C Cable

(Upgrade Using USB-C Cable https://docs.khadas.com/vim2/UpgradeViaUSBCable.html)

I already tried but it fail.
Other files to eMMC with same procedure worked well.

0 Likes

#69

Didn’t try to install it, so i can’t really help you, if you are using usb burning tool, try to change usb port, maybe that silly solution could help.

0 Likes

#70

[Is possible to put the wifi working on this image (http://VIMs_Ubuntu-xfce-bionic_Linux-4.19_arm64_SD-USB_V20181030)

0 Likes

#71

Both Ethernet and wifi are working.

0 Likes

#72

I have the VIM2 Max. Is this your case?
Ethernet is working but Wifi not.

I was searching the forum but didn`t found anything that solved the problem with wifi with this image (see it in previous post).
Any help would be appreciated.

thank you.

0 Likes

#73

I am using Vim 1, i thought you were too, wifi works only in Vim2 2/16.

0 Likes

#74

This is the mali used, DX910-SW-99002-r7p0-00rel1_meson_gx, not lima.

0 Likes

#75

Off topic

I install this Rom on my VIM2 MAX that works very well.

https://dl.khadas.com/Firmware/VIM1/Ubuntu/SD_USB/VIMs_Ubuntu-xfce-bionic_Linux-4.19_arm64_SD-USB_V20181030.7z

I would like to add a few applications to complete my “Portable Desktop”. :slight_smile:
One of them is a Vivaldi Browser.
I tried to install it but it fail some dependencies.
Probably my source list needs some additional repositories that I could not found.
Any help would be appreciated.

khadas@Khadas:~$ sudo apt install vivaldi-stable
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vivaldi-stable:armhf : Depends: libappindicator3-1:armhf but it is not going to be installed
Recommends: adobe-flashplugin:armhf but it is not installable
Recommends: chromium-codecs-ffmpeg-extra:armhf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
khadas@Khadas:~$

Solved. :rage:

0 Likes

#76

You can now browse with Vivaldi on the recent models of the Raspberry Pi (2/3), along with other boards (and devices), such as CubieBoard and ASUS Tinker Board. Vivaldi for khadas is not build

0 Likes

#77

Dear Khadas team!

Don’t you think that if you sell a device and declare Ubuntu support, that mean you should offer the latest full feature working LTS build with mainline kernel or at least drivers working with the mainline kernel?
I’m talking about WiFi on VIM2 Pro.

I understand that you are not developers of the driver, however I suppose you had to have some agreements with chip vendors about driver support.

User decision to buy or not to buy a product is based not only on a good hardware, but on software and support too.

Have you made any request to a vendor in order to get a Wi-Fi driver for VIM2 Pro for mainline kernel? What is the answer?

Thank you!

2 Likes

#78

@numbqq, when will you update fenix repo?

0 Likes

#79

Do you mean mainline kernel? If so will update to 5.0 in next week.

1 Like

#80

Please share the mainline linux kernel source.

I will try to compile it for arch linux/manjaro

0 Likes