Vim3 pro no hdmi signal

Thanks for your willingness.
I connected my new Vim3 pro to my tv and my projector but there’s no hdmi signal. I tried another new hdmi cable and an Anker USB-C power adapter (25w) but I have the same problem. I successfully installed android os on EMMC using USB burning tool but hdmi doesn’t work. I installed krescue.img in a microsd and hdmi doesn’t work. I just purchased the original Khadas power adapter from aliexpress but it will arrive on 27 April (or 9-12 April spending too much). I hope I will can quickly fix this issue. Sorry for my terrible english, I’m Italian and my technical knowledges are limited. Bye, thanks and regards

Suspect the issue might be your power adapter. When the Khadas adapter arrives it might work.

How were you able to use Krescue if the HDMI did not work? Did you ssh into it or UART?

If you have a lab or quality power supply you can cut the connector off of the cable, the larger diameter wire is + and the braid is -.

I didn’t use krescue. I just installed it on microsd. I’m sorry but I’m not able to use SSH or UART but I would like it. I never had similar issues with my others SBC computers. It"s incredible I can’t use a new one. Thanks again and bye

Keep in mind the other SBC’s are not high performance like the VIM3 so the current demand is different. For example the Pi4 is crawling along at 45Mbs when reading the SD card 150 Mbs on a USB 3 SSd. Your vim on a NVMe is around 520 Mbs, and if memory is correct the emmc is around 350 Mbs.

Krescue doesn’t need to be run with SSH or UART, it will provide display output on your TV,
by chance does your TV have ability to manually select HDMI source ?
that could be the reason for issue some times

In my not recent LG TV there are only two hdmi ports. I tried one time using a switch and another time directly to hdmi port. My recent Xiaomi projector has two hdmi port but nothing happens with both. I tried also an hdmi port of an usb-c hub powered by a 100w PD without results. I’m a newbie and I don’t know what I can do. Thank you very much

In that case connect to the UART and see what is actually going on while it boots up. You need to see what is actually going on before the issue can be resolved.

I’m sorry but I’m not able. Is there any instructions about it? I purchased a Vim to install CoreElec and watch TV series and movies. I spent 200 euros for that. I’m not a programmer, I’m a newbie. Thank you very much

Have you installed any other OS than the pre installed android firmware?

I installed again Android OS using usb tool. I will try to install CoreElec on emmc. Thanks

USB tool error installing coreElec: “Parse burning image fail”

coreelec cannot be flashed directly, you will either need to run it from a sd card or flash via krescue on sd card

I used rufus to flash CoreElec on microsd but I always have hdmi problems. I can’t use krescue if I don’t see anything. I cancel the order from Aliexpress and tomorrow a new original khadas charger will arrive. I hope for a resolution. Otherwise I spent 230 euros for nothing. I’m desperate. Thank you very much

you need to connect to VIM3 to your PC with krescue instead of TV and then install to the eMMC from the options, after connecting vim3 to computer you can go to Krescue - Status
that will present you with a menu to interact with krescue

some questions:

  1. to connect the khadas to pc does i have to use a usb c to usb c cable or an usb c to usb 2.0?
  2. is hdmi cable necessary?
  3. which image does I have to download and flash to sd? krescue or android image?
    I’m very sorry, I’m a newbie. I need step by step instructions
    Thanks for your trouble

What OS (operating system) does your host PC have?

You will need a USB to SD adapter to program the SD card with Krescue.

I have it. Windows 11. Thanks

I flashed krescue on sd card with adapter using rufus and I put the krescue sd card in the Vim., I connect usb dongle (keyboard) to khadas usb port, I connect the khadas to power adapter (usb c to usb c cable), do I have to connect a cable from khadas usb port 2.0 to PC usb-c port? Do I have to connect the pc and Vim using an hdmi cable? Sorry bu I’m 57 years old: I haven’t a clear mind and google translate is not perfect. Thanks

Just connect the hdmi to the monitor. When Krescue boots you will see it on the monitor. No need to connect the PC to the VIM3. Make sure you have a good power source and use the USB c cable. If you have a powered USB hub try that since it might have more power than the USB connector on your PC.

The USB port on your PC might not supply enough power. It has a pretty high peak current when it boots up.

Put your keyboard dongle in the USB 2 port.

Connect your ethernet cable to the VIM or have your wifi credentials so you can configure the wifi.
When you see the K screen use the top selection, its the wizard, simple, fast and it works good.
Be sure to follow their instructions exactly and partition the “dump” partition.

I know but my problem is hdmi no signal on my TV and my projector. Check my first posts. I don’t have a monitor with hdmi port. Thanks