VIM3 No HDMI Signal & SSH Suddenly Stopped

Hello Khadas Team & @lilysun

We purchased a Khadas Vim3 in September 2019 but not until May 2020 we had the opportunity to try it. Since last year we have been evaluating various SBC platform, from raspberry, minipc, jetson and finally to khadas for our research that leads to production.

Unfortunately we found our Vim3 is defective as the HDMI port is not working. We have tried multiple HDMI cables and monitors that are working well but the device does not show anything on the monitor.

We also experience sudden freeze/lost in SSH connection repeatedly while the device is running. No problem with power and ethernet cables.

With all these problems, how we can get replacement unit under warranty? Or should we send back the device for diagnosis?

Thank you fro your attention.

@achmadgv please try to diagnose yourself before sending it out for warranty,
Please check all of these possible circumstances once more,

Are you using a monitor of supported Resolution preferably use a HD monitor(1920x1080) ?

This is a common issue if you use a Linux image with Desktop manager, I have experienced it myself, It is caused due to the Automatic timeout present on most images with desktop manger (xfce, gnome etc.), if your application required a long SSH session, please use a linux server image. it will solve the problem

Thank you.

1 Like

hi, maybe you did something to restore the board? since this is an integral part of working with the board, be able to diagnose first yourself, and only then try to return it.

Probably we could help you diagnose!

Please tell me, is there an LED on the board during a loss of communication with the board?

1 Like

Yes, the LED was functioning properly.

I see, thank you for this advice. I didn’t know about the timeout.


You say normal, check if it burns during a loss of connection, or does it not work at all now?
Need as much information as possible to help you.

The LED still works during conntection loss.

By the way, what is your OS?

Yep that’s a sign of the SSH timeout.
If I am right, you are using a 4.9 Kernel image, am I correct ?

@achmadgv what about the HDMI display problems? what is the resolution of your Monitor ?

I tried both Ubuntu 18.04 Desktop and 20.04 Desktop

I use Acer P166HQL with max resolution of 1366x768.

well, thanks, for more accurate information, work on another OS, to understand that this is a hardware problem, not a software one and vice versa

Please note these are the only possible resolutions for VIM3,

Try another display with one of these resolutions,

I am really sure you are facing software problems, not hardware problems, But its good to cross verify once.

how much time is the timeout, and is it possible to fix this somehow?

I do not think that the problem is in the display, if it breaks on ssh

About 15 to 20 Mins, @Vladimir.v.v I believe you remember this event that happened just about 2-3 weeks back :grin:

1 Like

well that’s not normal of course

No no, timeout is related to SSH, when Headless, usually when connected to a display with keyboard mouse etc. you will get the hibernation thing if you do not use the device for more than 10-15 mins, same thing in headless SSH, you are not physically interacting with a device, the SSH is just a service running in the background, and so the computer thinks you are not using it and basically sleeps, even though in reality you are using the computer

maybe something related to WOL?