VIM3 Android Pie V200103 ROM Release

in my case , in this SDK,
WiFi everything works quite well!
router: keenetic ultra
the nominal speed of my internet is Dow.200- Up.20.


By the way, now I’m watching a torrent movie online, 4K, weighing 110 gigabytes, about 10 minutes, WiFi-5ggz, no brakes.

modem at a distance of 3 meters, and here I am writing from the phone.

in the end, after 30 minutes of testing the movie, WiFi was very stable, no brakes. :stuck_out_tongue:
screenshot during the movie:

About 5G WI-FI, Can you describe it in detail?

1 Like

Not sure if there are issues on wifi, I am using netgear R8000 router, it has 2 5G wifi and 1 2.4G wifi running at the same time. for VIM3 with V200103 ROM, I can find the 2.4G and one of the 5G channel for my router. One of the 5G channel cannot be found.

On the router that cannot be seen, is that router broadcasting its SSID?

Hi. How to fix wifi at 5 GHz ???

Well since the rom as root, just edit system build.prop or is vendor build.prop… well in one of the two LOL i just cant be sure now, just check both build.prop…
And just comment out ( put a # in the beginning ) ro.boot.wificountrycode=CN , save and reboot and voila 5g back.
In the sdk just go to, and comment ( put a # in the beginning ) the :

And that is it!


Thank you very much for your help! I’ll try to fix it, but I don’t understand much about it yet …:slightly_smiling_face:


find and fix


Many thanks!!! …

Thank you all for your help! Made changes to system / vendor / build.prop. WIFI 5 GHz began to work !!! …:hugs::hugs::hugs:


Good firmware with excellent performance!


how it works for me …
true 4pda today is very slow

1 Like

, Здравствуйте! Можете поподробнее написать как пофиксить?

1 Like

Hello! Dear superceleron announced in the near future a new firmware, there all this must be implemented.


Great news for all! Happy to see a fw treating VIM3 as a player.

1 Like

TS050 touch screen works fine but when I try to change the resolution to 720p or any other it does not change. Is a fixable issue?

All mainstream streaming APP not work properly on this FW: Douyu,Huya,Bilibili, …
Playing with black bar at bottom and right side. (dot to dot or scan issues)
The original FW(190809) is perfect on this.

Navigation bar can be closed in this FW, good news!
Status bar hiding still not available. o(╥﹏╥)o
The original FW(190809) is perfect on this.

pls Khadas considering the media-playing user who bought a remote.

1 Like

Hello, For those interested, @superceleron has just posted a new version of his Custom ROM for the VIM3.
I have not had a chance to try it yet, but he does good work, you may want to look in to it.

Hello, have you solved the green screen problem?

no problems, so probably decided :wink: