VIM2 is dead? How to revive it?

No idea does the wrong operation demage the hardware or not, as usually, the M-Registor way should always work out.


And accoarding the printing log, should be something relative with CPU.

Do you want to ship back to us to confirm and repair?

I think that CPU is dead…

Yes, I want to repair it.

PS: My VIM2 MAX work in my car every day. Thank you for the good device. And I want to try Edge-v on the future. :slight_smile:

@kenny will contact you for the details soon.

1 Like

Thank you!!!

hi davemf,
it seems like that the capacitor(location: C128) has been lost, and the tow pad is short circuit whit something. can you kindly confirm Is it related to this?(may be you have a soldering iron or something like that, just disconnect the short circuited and boot the system again. )


Ok, I’ll checking it in the evening.

Thank you, kenny!

I checked it.
It does not has short circuit.
I can see loop log only.

I think, the capacitor has been lost after removing the cooling system.

my khadas vim2 also died unexpectedly. When turned on, the white LED lights up. there is no power supply on ports. If you connect an HDMI cable and supply power, the white LED lights up immediately and stays on.
M-Register does not work.
Linux uart is silent.
Help. What should I do with him?

I sent vim2 to aftersaller service on China.

Hi Sleep:

Can you check again that if the TX & RX pins are right connectted?

Can you specify more details on this? Do you mean that the USB ports can not supply power for devices like USB mouse, right?

Can you specify more details on this? Like, what circumstances it under when this occurs?

More details like a simple video will be helpful for us to understand your issues.


Thanks for responding to my problem.
TX & PX I connected correctly. USB to RC232 converter is tested on other devices.
when connected to the power supply, the device does not boot

yes my Khadas does not power USB ports for a USB mouse
Voltage AO_5V normal.
fuses F1 (500mA) and F2 (900mA) are OK
VCC5V is missing
HDMI_5V_EN always 4.9V

Also, my laptop does not see it when I try to launch a firmware update (while holding the power button while connecting to USB)

for power, I used a proven power supply, applying a voltage of 5V to the DCIN input and using a regular monitor. With this connection option (external power supply), it worked for more than two weeks.
I could not confuse the polarity, because I use the connector with the keys

after what happened, I specifically once again checked the power supply for possible power surges when switching on and off. But found nothing - the power supply is working fine

Maybe this page can help u.


Thanks you
I checked the recovery using MRegister Mode ( but unfortunately it did not help.

Maybe u try to reinstall the USB Burning Tool on your Windows PC. I have faced this problem before. I just reinstall the USB Burning Tool and plug usb to my VIM2. And that’s it. I didn’t use the MRegister mode.

1 Like

I tried to reinstall USB Burning Tool. and tried to do it on another computer, but there is no reaction to connecting VIM2 to a computer. The computer does not see it

Thanks for the videos, it should be something related with the VIM2 board hardware. And please confirm again and reply follow questions one by one to narrow it down:

  • Does your VIM2 device works out at first? Or it just not work at all when you receive it.
  • Do you know what circumstances it under when this occurs?

You might need to contact the customer service for the return details if it proved a hardware issue in the final :wink:

Good day!

Yes, my VIM2 device worked fine when I received it.
I originally used a power supply via USB-C.
when I got the cable I connected the power through the VIN port
For almost a month after switching the power on to VIN, it worked perfectly for me, but it did not suddenly turn on.


Not sure if you connectted the VIN port in wrong way and demaged the device, as from the videos you posted, the white LED light on just a moment if you press the power button or plug-in the DC, it’s not a normal and should be power issues.

If you still cannot locate the issues, you can contact the customer service for the return details.

Good day!

How can i do this?
can i send it in for repair?


Hi Alexandr,

Please check your PM for the instructions.

Good day!