VIM2 is dead? How to revive it?


#21

Hi Sleep:

Can you check again that if the TX & RX pins are right connectted?

Can you specify more details on this? Do you mean that the USB ports can not supply power for devices like USB mouse, right?

Can you specify more details on this? Like, what circumstances it under when this occurs?

More details like a simple video will be helpful for us to understand your issues.

Thanks!


#22

Hello
Thanks for responding to my problem.
TX & PX I connected correctly. USB to RC232 converter is tested on other devices.
when connected to the power supply, the device does not boot

yes my Khadas does not power USB ports for a USB mouse
Voltage AO_5V normal.
fuses F1 (500mA) and F2 (900mA) are OK
VCC5V is missing
HDMI_5V_EN always 4.9V

Also, my laptop does not see it when I try to launch a firmware update (while holding the power button while connecting to USB)

for power, I used a proven power supply, applying a voltage of 5V to the DCIN input and using a regular monitor. With this connection option (external power supply), it worked for more than two weeks.
I could not confuse the polarity, because I use the connector with the keys

after what happened, I specifically once again checked the power supply for possible power surges when switching on and off. But found nothing - the power supply is working fine




#23

Maybe this page can help u. https://forum.khadas.com/t/mregister-mode-not-working/3035


#24

Thanks you
I checked the recovery using MRegister Mode (
https://docs.khadas.com/vim2/HowtoBootIntoUpgradeMode.html) but unfortunately it did not help.


#25

Maybe u try to reinstall the USB Burning Tool on your Windows PC. I have faced this problem before. I just reinstall the USB Burning Tool and plug usb to my VIM2. And that’s it. I didn’t use the MRegister mode.


#26

I tried to reinstall USB Burning Tool. and tried to do it on another computer, but there is no reaction to connecting VIM2 to a computer. The computer does not see it
thank


#27

Thanks for the videos, it should be something related with the VIM2 board hardware. And please confirm again and reply follow questions one by one to narrow it down:

  • Does your VIM2 device works out at first? Or it just not work at all when you receive it.
  • Do you know what circumstances it under when this occurs?

You might need to contact the customer service for the return details if it proved a hardware issue in the final :wink:

Good day!


#28

Yes, my VIM2 device worked fine when I received it.
I originally used a power supply via USB-C.
when I got the cable I connected the power through the VIN port
For almost a month after switching the power on to VIN, it worked perfectly for me, but it did not suddenly turn on.

thank


#29

Not sure if you connectted the VIN port in wrong way and demaged the device, as from the videos you posted, the white LED light on just a moment if you press the power button or plug-in the DC, it’s not a normal and should be power issues.

If you still cannot locate the issues, you can contact the customer service for the return details.

Good day!


#30

How can i do this?
can i send it in for repair?
thank


#31

@sleep

Hi Alexandr,

Please check your PM for the instructions.

Good day!