MRegister Mode--not working


#1

Hi. I accidentally erase my Vim2 by pressing Power , Function and Reset buttons. I want to reinstall os in the emmc but I don’t know how to use the MRegister Mode. I have read the document but there are 4 pads in the picture. There is a ‘M’ point to a pad. I should connect this pad to the upper one or the one in the left? Thx


VIM2 is dead? How to revive it?
#2

Hello, from the picture below, looks like the pad to the left is occupied by a component. I have not used M register on the VIM2 yet, but my assumption would be to use the pad above the pad with the M marking. I have highlighted the pads with a green mark in the following picture.


#3

Thank you for your quick reply. Will I break it if this it’s not the right one? Also, I am curious about those pads. What is that actually?


#4

I will check the schematic when I get to my PC. However, I do not believe any damage will result from shorting the pads I indicated in the previous picture. However, care should be used when applying a tool, to avoid physically damaging nearby components or board traces.

As to the pads, put simply, shorting them puts the device in to MASKROM mode, this will force update mode. Generally MASKROM should only be used if you cannot get the VIM2 into update mode using the standard method.

Update:
I have checked the schematic and confirm the information and picture I posted above.

The first picture is from the VIM2’s Schematic, showing component number R152, notice the schematic shows NC or “no connection”…
MaskromSchematic1

The second picture is from the VIM2’s PCB Drawing, showing the location of component R152. Notice it is between the pads I identified in my original reply…
MaskromScematic2.

@lolll You will not damage the VIM2 by shorting the pads identified in my original post.

Let me know of your progress.


#5

Hi, I am back. I have tried several times but not success. I followed the MRegister Mode instruction from this https://docs.khadas.com/vim2/HowtoBootIntoUpgradeMode.html. First, I connect the usb cable from my pc to vim2.(There is a gap before I did the next step.)Then, I use a tweezer to short-circuit the two pads of M register and without release. And finally short press Reset key and release it to boot into upgrade mode. But my pc cannot recognise my vim2. Please help me.
Can I use gpio or external spi programmer to reinstall a uboot? Is there any other way? Thanks in advance.


#6

Can someone help me, please!


#7

Hi loll:
Can you just take a picture together with your VIM device, PC and together with the USB-C cable, so we can try to figure out the issue.

More details will be help out, basically we still to know the windows version you installed etc.

Btw, have you tried with another usb-c cable or PC?

Good day!


#8

Before I accidentally erase the emmc in vim2, I reinstalled os several times by using the usb upgrade mode. Therefore, I think it is not the problem of my PC. I have tried to connect my phone to pc with the usb cable that I used to connect vim2. Its works. I can access the file in my phone. Here are the details Screenshot%20(7)


#9

Not sure if one of the USB-C side not working in some case, just try with both sides.

Have you installed this tool below:

Have fun!


#10

Thank you for your help. Since my vim2 is not working, I have tried to use the both sides of the usb cable to connect my phone. I can access the file in my phone. Yes, I did installed this tool. When I tried to use the MRegister mode, I opened this tool. But the tool didn’t show me that it’s connected. And I have also checked in the Device Manager. Here’s the detail


#11

Yep, that’s say the USB-C cable is fine, works for both sides.

Any more detail on this?


#12


#13

The Mregister mode is not user-friendly. I follow all the instructions and tried many times(about 10 times), but its useless. I hope this problem can be solved and won’t be happen again. I think this Mregister mode should be replaces by another one, which is user-friendly.


#14

Can I use gpio or external spi programmer to reinstall a uboot? Is there any other way? Thanks in advance.


#15

If you just erase your VIM2, the VIM2 device should can boot into upgrade mode automately after powering on. If not, the issues may on PC side. Can you just uninstall and reinstall the upgrade tool and take a try? or just try with another computer?

If you VIM2 can still boot into u-boot, the Serial Mode should works for you if you are a devlopers and own a serial tool.

Thanks for your suggestion!


#16

Yea I have tried that before.
I forgot to say that. Before I accidentally erased, the upgrade mode was not working already. But I can still bootup a Ubuntu mate os.

I think make a one-click button is better.


#17

Button mode or MRegistor mode?

Do you know how to use a Serial Tool? In this case, you can locate the issue from the printing log faster.

Thanks!


#18

Button mode.

But I have used the buttons to erased all the data in the emmc so no uboot, right?


#19

Yes, should be. but as I said aboved, if your eMMC is erased, your VIM device should can boot into upgrade mode automately.

And actually, even the eMMC is earsed, the serial tool should also print some message there.


#20

U mean that I can boot it into upgrade mode with just connecting to a pc with the tool installed?

I don’t have a serial line. I think the problem is related to the driver. The driver is not digitally signed.