[ROM] SC VIM1 Pie ATV Debug/User builds v2 20200130

I do not want to say that this is somehow bad, but I would suggest that you go the proven way, USBBurningTool. But I look in the “header” there are no standard images. Maybe Superceleron could fix it somehow. :thinking:

You need the “Krescue” software, from it you need to install the above archive.

Yeah, I would’ve tried that first, but the images provided for this ROM are for Krescue only.

I have Krescue on an SD booted right now. I had issues getting it booted at first, but it was just my SD card. That’s been resolved.

I would try downloading the image through Krescue, but it won’t connect to my wifi and the only image for this I saw (when I was able to plug it in with eth) was for the DEBUG version. I’m hoping to install the USER image.

I imagine @superceleron would be the person to ping. I know he didn’t make Krescue, but is the developer of these ROMs and packaged them for Krescue.

WiFi is currently available in “Krescue”, but you don’t need WiFi to write an archive-image to eMMC.

I do not know for certain what Superceleron was guided by, perhaps as some kind of test, but then it was better to do it as an alternative to the standard recording method.

buddy, please check
I think , need to put everything in the “hat” :grimacing::grin:

http://freaktab.org/56b0b900348e50fb, it seems a standard installation with USBBurningTool.

also found post

Here in general v.3

Thanks, I’m going to spin up an Ubuntu session and do this the good ole fashioned way now!

Just wait for next build they will be in IMG format, is already done for a while now.
Just lack the time to post it, i will try to do it today.


Hy @superceleron any update of an img

Ho damn i totally forgot lol i have the img’s done for over 1 month now…
I will post them later today.
But i do tell you guys this sdk seems slower than the previous one.


it works on vim3 pro ?

this is for VIM1 board only, VIM3 is completely different, it is not compatible…

okay thanks …

here you go: [ROM] SC VIM3 Pie ATV Debug/User builds v3 20200803

thanks alot @superceleron

Hi @superceleron . Is there any updates on this ROM? I’m asking because on DEBUG v3 I have one issue (green screen was fixed by v3 OTA) - if I send my VIM1 to sleep by power button, then after some time it won’t show the home screen. The only way to fix it - reboot the device, because no way to get back to launcher.

ye i know of that bug, but im not doing any more updates to VIM1, i cant maintain or have the time to work on 4 different devices :frowning:

That’s sad. Maybe you have VIM1 device tree somewhere on github? I could support VIM1 ATV builds…

sorry no i dont, anyway i cant have any google stuff on it anyway, remember the build i do is not totally “legal” since it uses google propriety apps.
I think they just do not care of custom stuff, since is in an small scale.
That is why i do not share anything from atv builds, max you can do is grab my rom and grab the stuff from it and add it to the stock khadas build, of course there is more changes that i did but some of them i cant share them since they are propriety of my work, all code i do to any android sdk belongs to them!
So in other words, i cant share nothing lol only parts, i did share in the past some code to khadas but i had 1º to ask permission to do it!

1 Like

Thanks for the explanation, no problem. So, maybe you could share your thoughts on that bug, if you had a chance to meet and fix it on other platforms?

That is a very old issue, it happens to all AOSP converted to work as ATV, is a “feature” of the launcher that it simple continues to fill the ram/cache until is gets stuck.
There are still no fix other than using the real ATV sdk, an ye is google only private and is different from AOSP in some of its internal “workings”.

Thanks for the explanation. It’s better and faster to me to create my own launcher application that will function and look like ATV. Thanks again.