No more SDBoot possible after Update to VIM3L_Pie_V200624

you need to have mainline uboot in the eMMC for that…
or the mainline uboot somewhere…

yes, but if you sew via USBBurningTool, there should be no problem with this

BUMP :frowning:

Hi ,what happened ? do you want to contact someone from the Khadas team? you can do this through private messages or tag someone.

Hello, Have you attempted to erase the eMMC? If so does the problem persist?

yes, we tried to help, but I should note that the person’s device is fully functional! but it does not work to boot into sd, while the sd slot itself works! :thinking::confused:

1 Like

yes I did - with Burning Tool and even via “android boot menu” (green robot with open belly) which is accessible, wen using android>>update>>

Mailed Khadas support half an hour ago, with request for assistance on this topic - maybe some Devs have another trick up their sleeves :wink:

1 Like

you have a very strange problem for me, but I hope you solve this problem! :slightly_smiling_face:

1 Like

When you say you erased eMMC using the USB Burning Tool, do you mean you set it to erase flash, or you interrupted the flashing process around 15%?
@4ltj4 @hyphop
I can confirm the same difficulty as you have described, on my VIM3, ref latest Krescue boot failure with latest Android 9( VIM3_Pie_V200624.7z) on the eMMC. I understand yours is VIM3L, but they share much.
I resolved the issue by clearing the eMMC using the USB Burning Tool interrupt method, then reflashing the VIM3 with the previous Android 9(VIM3_Pie_V200319.7z) image using the USB Burning Tool. Krescue would successfully boot after that.
I again flashed the latest Android 9 and again the Krescue would not boot successfully.
At this point I have flashed the previous Android 9 version and Krescue successfully boots again.
Something seems amiss.

I set Burning Tool to “erase flash”

So- the “interrup-method” is like Burning a valid Image and PULLING THE PLUG @15% ?
(will try later)

Yes, disconnect cable after 15% completion, doesn’t have to be exactly 15%.

UPDATE: now my Vim3L is absolutely dead.

-tested with 3 different Power Supplies (5V, 9V, 12V) and 2 different cables.
not even the initial blue LED lights up :scream:

You did the interrupt? If so, did you try to boot Krescue?

I brought you medicine :pill:

now you need to define the board

do a triple quick press of the middle button, preferably in the USBBurningTool to monitor this action.

Yes, I tried three methods after clearing the eMMC.
Triple function button press - works
Hold power, press reset, release power after 10 seconds - works
Hold power and connect USB cable - works.
Also, with cleared eMMC, I think the board will be in update mode by default when connected to the USB Burn Tool.

  • Yes, did the “interrupt” worked:

Power+3times Function --> flash older Android with AMlogic Burning Tool
afterwards. HoldPower10sec+Reset. boots up my emuelec :smiley:


THANK YOU SOOOOO MUCH for your support!!!

1 Like

none the less… this android image is crappy. :wink:

Glad you are making progress. I was working on a reply to your pre-edited post when I noticed the edit. I like the edited post better. :grin:

As to the Android image, with you and I both having the issue, perhaps hyphop can identify the error and it will get fixed in the next Android 9 release.

Very glad your VIM3L lives. Hope you enjoyed the burger. :slightly_smiling_face:

1 Like

I have not looked closely to see what Khadas firmware these are based on, but superceleron offers a couple of custom ROMs for the VIM3L. A standard Android and an ATV Android.
I recommend reading each of his post carefully to determine their suitability for your needs.

I will installtoemmc my EmuElec and use my Kodi on SD – I’m fine for now (and exhausted) :laughing:

(but I know these roms - but they dont offer vulkan support - this was the only reason I tried the v200624_android :wink:

1 Like