New Tone Board is not recognised by Macbook Pro

Hello All
I received my Tone Board today. I plugged it via USB to my Macbook Pro but the MB doesn’t seem to recognise it. I don’t see the TB in the output audio options.

My MP is from 2011.

Thank you for any help provided!

Hello! not much theory … :slightly_smiling_face:

try different ports to use

I have tried the 2 USB ports in my mac but still I don’t see the tone board showing.
Any other idea?

Thank you so much

Hello, Are you connecting the TB with a USB-C to USB-C cable? If so, try a USB-C to USB-A adapter on your Mac, then use supplied Khadas USB-C to USB-A cable.
The TB’s USB-C port functions as a USB2.0 port.

I’m connecting via the USB cable provided with the TB.
I can see the light turn on, but nothing else.

Do you have a different cable you could try?
If you want to see if the TB is on and functioning, and you have a source with SPDIF output, you could supply an SPDIF input to the TB and see if you get audio. If you do get audio, could be the supplied USB cable is not transmitting data.
Sorry, I have no MB experience and cannot help from that angle.

I have now tried two macbooks pros, none of which identify the TB Dac.
Bothe are mid 2012, intel core i5, 4GB. One running El Capitan and the other running Yosemite.

Anything relevant here?

Hi Perro,

Sounds like it is a cable problem. The Tone Board also has an issue with USB 3.1, which your Macbook’s USB-C port uses.

The workaround which others have used (assuming your cable is good) would be:

Macbook Pro —> USB 2.0 Hub —> USB-A to C cable —> Tone Board

I have tried a direct connection from my Macbook Pro to the Tone Board using a USB-C to C cable, and I can confirm that it does not work.

If your Macbook is from 2011, it still has USB-A ports right? The big rectangular ones? In this case, what OS are you using? Older OS versions likely don’t have the correct USB drivers installed. If everything fails, try a different USB cable.

2 Likes

Thank you @tsangyoujun.

I am now updating the iOS to Catalina. I will see if this works. If not, I will try a different cable or the hub trick.
I will report back.

Regards

1 Like

You mean MacOS right ?

Ahh, correct!
Download and install still going.
This happens for trying to use my son’s old laptop as a streamer.

Success!
It had nothing to do with the OS. I just used a different cable.

1 Like

Thank you for all the help!

2 Likes

Well done !, All the best on your project :slight_smile:

3 Likes

Nice !, Minimal and ECO-friendly :smile:
what do you say @RDFTKV

1 Like

It is a wise use of materials. Fortunately the Tone Board’s box is a pretty good looker. :slightly_smiling_face:

1 Like

Yep, fully black with a subtle logo…

Incredible idiocy, Mac owners! ‘Nothing to-do with macOS’ you don’t say… How many people would of tried a different USB-C cable first? Logical? pffft