MRegister Mode--not working

Hi loll:
Can you just take a picture together with your VIM device, PC and together with the USB-C cable, so we can try to figure out the issue.

More details will be help out, basically we still to know the windows version you installed etc.

Btw, have you tried with another usb-c cable or PC?

Good day!

Before I accidentally erase the emmc in vim2, I reinstalled os several times by using the usb upgrade mode. Therefore, I think it is not the problem of my PC. I have tried to connect my phone to pc with the usb cable that I used to connect vim2. Its works. I can access the file in my phone. Here are the details Screenshot%20(7)

Not sure if one of the USB-C side not working in some case, just try with both sides.

Have you installed this tool below:

Have fun!

Thank you for your help. Since my vim2 is not working, I have tried to use the both sides of the usb cable to connect my phone. I can access the file in my phone. Yes, I did installed this tool. When I tried to use the MRegister mode, I opened this tool. But the tool didn’t show me that it’s connected. And I have also checked in the Device Manager. Here’s the detail

Yep, that’s say the USB-C cable is fine, works for both sides.

Any more detail on this?

The Mregister mode is not user-friendly. I follow all the instructions and tried many times(about 10 times), but its useless. I hope this problem can be solved and won’t be happen again. I think this Mregister mode should be replaces by another one, which is user-friendly.

1 Like

Can I use gpio or external spi programmer to reinstall a uboot? Is there any other way? Thanks in advance.

If you just erase your VIM2, the VIM2 device should can boot into upgrade mode automately after powering on. If not, the issues may on PC side. Can you just uninstall and reinstall the upgrade tool and take a try? or just try with another computer?

If you VIM2 can still boot into u-boot, the Serial Mode should works for you if you are a devlopers and own a serial tool.

Thanks for your suggestion!

Yea I have tried that before.
I forgot to say that. Before I accidentally erased, the upgrade mode was not working already. But I can still bootup a Ubuntu mate os.

I think make a one-click button is better.

Button mode or MRegistor mode?

Do you know how to use a Serial Tool? In this case, you can locate the issue from the printing log faster.


Button mode.

But I have used the buttons to erased all the data in the emmc so no uboot, right?

Yes, should be. but as I said aboved, if your eMMC is erased, your VIM device should can boot into upgrade mode automately.

And actually, even the eMMC is earsed, the serial tool should also print some message there.

U mean that I can boot it into upgrade mode with just connecting to a pc with the tool installed?

I don’t have a serial line. I think the problem is related to the driver. The driver is not digitally signed.

Hello, In the folder you installed the USB Burning Tool on your Windows PC, you will find a folder called, “World Cup Driver”. Inside that folder is an exe file to install the driver. It also has uninstall feature. Run the exe and uninstall the driver, restart PC. After reboot, run the World Cup exe again and select install driver, restart PC and see if VIM2 is recognized.
Good luck.

1 Like

thanks. I will reinstall the software. And I use the MRegister mode?

Oh YEAH!! I can now use the usb tool. Thank you for your help! But I didn’t use the MRegister mode… Why my pc can recognize recognize it automatically? Then what is the usage of MRegister mode?

1 Like

That is why it was automatic.

M-register may be required if boot loader or firmware become corrupted or I incorrect image is flashed to the VIM(2).

As to the USB Burning Tool, I have had to reinstall it a couple of times. I also have boxes with RK processors, they have their own burning tool. Often I have to reinstall the World Cup driver after using the RK tool. I don’t know why, some conflict I assume.
Glad you got it going.
Have fun. :slight_smile:

= KBI?

=firmware in programable MCU?


More details at: Khadas Docs.

Have fun!