Looks like I killed my VIM3, is it possible to reuturn to KHADAS for repair?

I think you need to learn how to restore your vim, otherwise you will go broke on the postage, just kidding of course.

inspect the board for damage and please take a photo in good quality for us to inspect, thanks!

I thought Khadas boards were unbrickable

sorry. i think you will get it figured out

Nothing is unbrickable, but Khadas boards are much more resistant than many.

Don’t rule out coincident issues, check power supply and cable. Otherwise, attempt to get in to MASKROM mode again.

Update: I see you have already tried different PS and cable. Can you take a picture of the area encompassing the “M” contacts?

1 Like

If I am not wrong this issue seems to be , because the eMMC might have been wiped, this same scenario was solved by simply flashing the ROM again…

I just searched MRegister Mode on google took me back here to a different user who did the same thing

Keep trying man, this board wont beat you

dont take the easy road and send it back, figure it out!

There is like 3 or 4 ways to get back up, download balenaetcher and try the Krescue, turn on wifi and run the file from the Krescue list

SDcard force flash https://docs.khadas.com/vim3/UpgradeViaTFBurningCard.html

Try em all


You got some motivation buddy :wink:

Thanks for all the motivational posts, I really do appreciate them! I’ve spent the past 6 hours trying to boot the VIM3. including all the methods recommended in this thread. Unfortunately the SBC remains dead with no LEDS or other signs of life. I am attaching photos’ of the ‘M’ contact area. Any other ideas are welcome.

@Donanon can you make a short video showing the reaction shown by the device when trying to enter the various upgrade modes ? do it while connected to a computer with the USB burning tool open…

Yep, a short video will be helpful for us to figure out the issue.

Okay, I will post the video shortly.

I forgot, did you mention what type of power supply your using?

Is it the stock Khadas 24 watt (white) brick for the Khadas?

24 watt, 5volt 3 amp, 9 volt, 2.67A and 12 volt, 2A

can you remember after which it stopped working, could something strange be the reason? thank

The VIM3 unlike the VIM1 and VIM2 is cross compatible with 10w and 24w power bricks, there shouldn’t have been a problem there…

I just looked over the thread again and i dont see anywhere he said what power supply hes using. The 10 watt might be compatible but its also LIGHT duty

I think he knows for sure about this, he has a whole family from Khadas

Yes, I cannot say anything about that…

The power supply is a 12volt, 2 amp that I have been using with the VIM3 for several months now with no issues. I did not smell any thing like burned components.

The attached videos show me trying to reboot the SBC while connected to my TV. I tried it using USB-C and using the 12volt supply but no luck. I am working alone so the videos are a bit out of sequence but they do show the results of my efforts to reboot.

in my opinion, it will be better if you check it all with USBBurningTool