LTE modems working with VIM3L+M2X EXTENSION

Hello everybody,

is there a list with supoorted LTE modems for Android?
I found 2 device here in the forum(Quectel EM06 and a Huawei)

Are these 2 the only supported devices?

Thanks in advance and best regards

Yes, this model is support by our official.

Are there other modems which are working out of the box?

Or is it the only one?

Best regards

Normally, it can support any model of LTE module, with it’s driver & ril library built-into the image.

We only add Quectel EM06 model at the moment.

I have the new extension board and EM06-E on VIM3 pro. There is a green led flashing on the board, LTE module gets detected and network is correct, but no data/internet is available. Mobile phone with same card works fine. PIN code on sim has been deactivated. Also tried with Quectel EM05-E, same result. Changed antennas, same result (good reception). Activated PCI-e mode. Still same issue. Changed SIM for different network provider, still same. What could be the cause? Has this 4G module been proven to work? Running android VIM3_Pie_20200319.

maybe he’s still in test mode.

Yes, maybe it may have not been fully fledged to work yet, but we are unsure as not many people have talked about it, hence getting a glimpse of user experience has not been possible,

Could you also verify that your SIM is 4G, please note whether the Module is compatible with your country, there is Americas, European and Asia and pacific Band types.


ok, does your module fit your region?
EM06-A-North America / Mexico
EM06-E - EMEA / APAC / Soli

Yes, its, 4G. Module is compatible with region, its EM06-E and EM05-E that has been tested in Norway. EM05-E works with 4g and this simcard on Leez P710 sbc.

Yes, its correct region. Also one of the modules do work fine on another SBC running android 9.0, Leez p710. Same sim card.


Ok then it might be a firmware problem, but consult with @Terry about it.

You can try to flash the ubuntu rom and have a test.


Thanks I will test. Simcard is Norwegian and location is Norway. Teleoperator is telenor, Module used is em06-e

1 Like

We got the 4G to work. But only with a few sim cards. I will try Ubuntu to see that there are no hardware issues, and that android build works as it should.

LTE works stable on the ubuntu rom, so the hardware and sim card should be fine. How can we make it work better on android? In ubuntu I have all these options to choose APN and other mobile data settings, not so in android , there the options are greyed out in the mobile settings menu.

You can flash the new android rom and have a try. Thanks!

I flashed the newest ROM several times, clean wiped EMMC several times, tested multiple SIM cards. Tested Ubuntu.

My conclusion:

  1. 4G works fine in Ubuntu.
  2. I am not able to select what mobile network to connect to in Android. Deselecting “Automatically select network” under advanced pane in mobile settings reverts me back to the main menu. Network in Ubuntu is correct, in my case “”, in Android it states “Telenor Telenor” with the same sim card. I have no way to set another network manually.
    3.4G works with some sim cards in android. Therefore I believe it is a mobile network configuration issue.

I believe something is missing for the 4G to work properly in your latest android build.

Which operator does your SIM card belong to?

Telenor. I believe is the correct APN in this case

I need you to provide more logs for me following below steps.

# adb shell

# su

# mkdir /data/quectel_debug_log

# reboot

# adb root

# adb remount

# adb pull /data/quectel_debug_log/ .

And provide the three log files. Thanks!

<1> xxx_logcat.txt

<2> xxx_radio.txt

<3> xxx_dmesg_mainLoop.txt

1 Like