LibreELEC for Khadas EDGE (RK3399)

I check the old version 20190425 on EDGE-V and Caption.I got the same phenomenon.

  1. No system crash occurred.
  2. Bluetooth adapter lost.
1 Like

Okay, now there’s a starting point in the source code when the system doesn’t crash. Now we need to find the culprit falls. :slight_smile:

1 Like

Test version 20190727.

1 Like

OK, I will do it today.


  • The problem of system crash did not recur. Can you tell me what caused the system crash and how you solved it?

  • Bluetooth adapter lost again.

  • Mouse returns often fail when entering the settings interface.This won’t happen on other interfaces.

I haven’t finished the process yet. When I finish, I’ll write the result.

This is the next bug that needs to be dealt with.

Describe more the bug.

1 Like

I later tested the bug again.
I went into the settings to check the Bluetooth device. When I wanted to go back to the previous menu, the right mouse button did not respond.It often takes a certain amount of time for the system to respond.I returned the previous menu to the other.One thing I noticed was that when the settings returned unresponsive, I moved the mouse to the settings option. The content on the right side was blank. I think it might be a carton caused by loading information about the settings option.

Perhaps the reaction to the mouse button depends on the location of the cursor. I have this happen on a different TV boxes (AML RK) I just move the cursor to another location and the right button starts working.

1 Like

@balbes150 I will try it later.

If the information on the right side is empty, it cannot be returned at any location.

New image LE 20190729.


Maybe I found the “culprit” of the fall of LE.
If you roll back the rkbin package and the u-boot settings to the old version, the images stop falling.

To eliminate the error, @Frank you can check the latest version 20190730 for drops ? I tested it on all my edges with one common dtb by default, everything works on EDGE+captain and EDGE-V.


How can I download the image? On Yandex, I am only getting “Произошла ошибка”.

I am using the image 20190628 and I have no crashes, but terrible (unusable) HDMI sound issues.

UPDATE: OK. I just overlooked the download button at the top.

@balbes150. I will test it today.

@wanthalf . There you can download the image.

This is sad news.The system crash again.

[    6.527192] b660: 0000000000000015 00ffffffffffffff 0000000000000004 0000000000000000
[    6.527196] b680: ffffff80092e4c53 ffffffc0dc29ac30 ffffffc0dc29a958 ffffffc0dc29a9c0
[    6.527199] b6a0: ffffffc0dc29aa28 ffffffc0dc29aa90 ffffffc0dc373e38 0000000000000000
[    6.527202] b6c0: ffffff80081f4870 0000000000000000
[    6.527209] [<ffffff80081e3c68>] __brelse+0x54/0x5c
[    6.527213] [<ffffff80081e3f58>] bh_lru_install+0xf8/0x12c
[    6.527216] [<ffffff80081e4088>] __find_get_block+0xfc/0x194
[    6.527220] [<ffffff80081e4e70>] __getblk_gfp+0x3c/0x78
[    6.527226] [<ffffff800827e690>] squashfs_bio_submit+0x1d4/0x434
[    6.527230] [<ffffff800827ed30>] __squashfs_read_data+0x104/0x240
[    6.527235] [<ffffff800827ef98>] squashfs_read_data_async+0x4c/0x60
[    6.527240] [<ffffff8008282abc>] squashfs_readpages_block+0x288/0x2ac
[    6.527244] [<ffffff80082808e0>] __squashfs_readpages.isra.3+0x6a8/0x794
[    6.527248] [<ffffff8008280abc>] squashfs_readpage+0x78/0x144
[    6.527254] [<ffffff8008163e50>] generic_file_read_iter+0x3a8/0x538
[    6.527260] [<ffffff80081b0c54>] __vfs_read+0xbc/0xdc
[    6.527265] [<ffffff80081b14d0>] vfs_read+0x88/0x118
[    6.527269] [<ffffff80081b6948>] kernel_read+0x58/0x84
[    6.527274] [<ffffff8008116dbc>] copy_module_from_fd+0x94/0x108
[    6.527278] [<ffffff800811aa74>] SyS_finit_module+0x9c/0xbc
[    6.527283] [<ffffff8008082f30>] el0_svc_naked+0x24/0x28
[    6.527316] VFS: brelse: Trying to free free buffer
[    6.527331] ------------[ cut here ]------------
[    6.527334] WARNING: at fs/buffer.c:1207
[    6.527340] Modules linked in: gpio_ir_recv(+) rc_core midgard_kbase(+)
[    6.527341] 
[    6.527346] CPU: 3 PID: 310 Comm: systemd-udevd Tainted: G        W       4.4.154 #1
[    6.527348] Hardware name: Khadas Edge (DT)
[    6.527351] task: ffffffc0edccc380 task.stack: ffffffc0dc5f8000
[    6.527356] PC is at __brelse+0x54/0x5c
[    6.527360] LR is at __brelse+0x54/0x5c
[    6.527362] pc : [<ffffff80081e3c68>] lr : [<ffffff80081e3c68>] pstate: 60000145
[    6.527364] sp : ffffffc0dc5fb770
[    6.527367] x29: ffffffc0dc5fb770 x28: ffffffc0ede50000 
[    6.527371] x27: 00000000000009f8 x26: ffffffc0dc70a380 
[    6.527374] x25: ffffffc0dc5fb7e0 x24: ffffff800915ef10 
[    6.527377] x23: 0000000000000000 x22: ffffffc0dc373e38 

Confirmed. It does the initial FS resize, but then it does not even start KODI, just dumps tons of crash dumps on the screen.

This is probabilistic. Thank you for your test. This bug is being solved.

How does the 20190729 version behave ?

@balbes150. I am testing with the 20190729.This version performs well.There was no system crash inEDGE-V or Caption.

1 Like