LibreELEC for Khadas EDGE (RK3399)

Ver 20190110

add repo addons aarch64

https://mega.nz/#F!m94wGS5R!vbDg0PrlU0rVFdcxS5u2Jw

2 Likes

New version LE 20190118

New version LE 20190305

New version LE 20190320

Update image ver 20190412

1 Like

Update image ver 20190425

1 Like

Update image ver 20190517

3 Likes

Update image ver 20190606

Hi balbes150, thank you for all the time and effort you’ve put into making these images. I just received my new Edge-V (v13?) in the mail today and tried loading these up, but unfortunately am having a lot of trouble getting networking to work (both Ethernet and WiFi). I lose probably 1 of every 5 packets and over SSH the connection drops repeatedly. I tried both the arm and aarch64 images, but the same results (also noticed no WiFi shows up when I used aarch64).

I noticed when booting into Android on the eMMC the networking is rock solid, which at least rules out my own networking.

I’m also unable to get my m.2 NVMe drive to show up in the LibreELEC image. It’s formatted as ext4 and shows up when I run Edge_Ubuntu-server-bionic_Linux-4.4_arm64_SD-USB_V20181115.img, but don’t see it listed in /dev/ on any of the LibreELECs.

What DTB are you using ? The dtb for edge + Capitan is enabled by default. It’s not the same with EDGE-V. I don’t Have EDGE-V , so I didn’t check on it. Maybe @numbqq can test LE and Armbian on EDGE-V . May need to adapt the current DTB to the new edge-V version.

@Frank Please followup.

Hi @balbes150, I test it in EDGE-V and edge+capitan with LibELEC,I’m unable to get it .So can you tell me which DTB is right.I’m not sure whether I need to change the DTB.

What image do you use ?

LibreELEC-RK3399.aarch64-9.1-devel-20190606140016-a41fdf1-khadas-edge.img

This image on EDGE+Capitan should work without changes. Download. Unpack. Write a special program on the SD card. Connect SD to the EDGE (Capitan). Turn on power. The system should start. Do you have a UART console ?

Try the 20190517 arm version.

LE is no patch to work NVMe. I’ll add it to the next issue. The patch is in Armbian with kernel 4.4

1 Like

Hi @balbes150. The borad work well,just I can’t find my M.2 SSD.My command is df -h ,I don’t find it. and in /dev I don’t find the node.And I will test with 20190517 arm version.

@balbes150 Thank you so much, I’m really excited! I’m using the “rk3399-khadas-edge.dtb” DTB file. I didn’t see any specifically for the Edge-V. (In fact, I can’t even find any others on your build - is there a site to grab the dtb files from?)

I’m familiar with https://github.com/CoreELEC/device-trees-amlogic for Amlogic, but don’t know of a Rockchip equivalent. I found references on the lkml for a “rk3399-khadas-edge-v.dtb”, but have no idea where to find this file. I checked in the nightly Armbian Ubuntu “next” image you provided, but didn’t find it in /usr/lib/linux-image-next-rk3399-tv/rockchip/, only the -edge version.

Khadas Edge V5 seems to have extra gigabit LAN and PCIE, not present in Khadas Edge. So it’s dts for LibreELEC can perhaps just get changes from mainline patch @numbqq posted.
Also ‘vopl’ must be disabled for 4K playback to work correctly.

I hope the mainline driver for the wifi for Khadas Edge V5 will also be able to be build in future.

1 Like