Krescue - take full control of your VIM device! easy way to install ANY OS! + back/restore your system

in the past, I’ve had issue setting up a perfect build environement for fenix. Then I tried (successfully) to use the provided instruction for doing it in docker container as seen in

I need to combine them with your instructions before…
and we’ll hopefully see some positive result I’ll report once the current build is finished

Here are my steps inside docker :

khadas@9d6fa07dc338:~/fenix$./scripts/ VIM1

LD vmlinux
SORTEX vmlinux
OBJCOPY arch/arm64/boot/Image
Building modules, stage 2.
MODPOST 1746 modules
warning: same module names found:
make[1]: Leaving directory ‘/home/khadas/fenix/build/linux-mainline-5.5-rc2’
Info: Building debs…
Building package: linux-u-boot-vim1-mainline
dpkg-deb: error: control directory has bad permissions 777 (must be >=0755 and <=0775)
Makefile:7: recipe for target ‘all’ failed
make: *** [all] Error 2

Something needs to be fixed, I’ll try t o find how,
@numbqq do you have any idea ?

UPDATE: as my FS in NTFS, and according to
the problem is know, I need to move thing on an ext3 or ext4 FS…

I fixed the filesystem issue, but this is how it still ends…

  LD [M]  sound/usb/line6/snd-usb-variax.ko
  LD [M]  sound/usb/snd-usbmidi-lib.ko
warning: same module names found:
make[1]: Leaving directory '/home/khadas/fenix/build/linux-mainline-5.5-rc2'
Info: Building debs...
cp: cannot stat '/home/khadas/fenix/linux/arch/arm64/boot/dts/amlogic/meson-gxl-s905x-khadas-vim.dtb': No such file or directory
Makefile:7: recipe for target 'all' failed
make: *** [all] Error 1

khadas@38b1d52425fb:~/fenix$ cd /home/khadas/fenix/linux/arch
bash: cd: /home/khadas/fenix/linux/arch: No such file or directory

ah ha !!

You use the source code from @hyphop. And this issue already has beed fixed in Khadas Repo. But @hyphop have not fetch the latest patches.

You can cherry-pick this patch and try again.

1 Like

I applied your patch and retried,
this time it goes farther but we still have some error as we see below:

wiringpi_debs-c1f48d2dbe [ <=> ] 120.17K 375KB/s in 0.3s

2020-03-12 23:24:31 (375 KB/s) - ‘wiringpi_debs-c1f48d2dbe0417cf34699f2edd6bc0ff6bf86f40.tar.gz’ saved [123054]

Calculated checksum is: 281c2711485b3495d076825fc3c933fe3d911879ff96bb82252aa36aa2f687c3
Extracting 'wiringpi_debs-c1f48d2dbe0417cf34699f2edd6bc0ff6bf86f40.tar.gz' to '/home/khadas/fenix/build'...
./scripts/ Warning: This script requires root privileges, trying to use sudo, please enter your passowrd!
Info: Preparing rootfs for VIM1-buster
Info: Creating new rootfs for buster
Info: Installing base system - Stage 1/2
/usr/sbin/debootstrap: 1455: /usr/sbin/debootstrap: cannot create /home/khadas/fenix/build/images/.tmp/rootfs-VIM1-buster-server/test-dev-null: Permission denied
E: Cannot install into target '/home/khadas/fenix/build/images/.tmp/rootfs-VIM1-buster-server' mounted with noexec or nodev
Makefile:7: recipe for target 'all' failed
make: *** [all] Error 1

maybe this is related to this apparently unsloved github issue ? :cold_face:

No idea yet, haven’t tested Debian buster.

plz open new thread or use other exist for fenix build ! we can try to solve it

please join me in this new thread Fenix, docker build, debian buster, krescue
@numbqq and @hyphop and whoever is interested

1 Like


COREELEC.9.2 nightly krescue image for VIM3 VIM3L ( one image VIM3x.COREELEC.9.2.nightly.emmc.kresq for both devices ) + Krescue - take full control of your VIM device!


NEW COREELEC.9.2.1 krescue image for VIM3


  • multiboot fixed (USB / SD)
  • broken update fixed
  • installation time 17 sec
  • khadas IR/RC configured by default
  • used last nightly build from 20200313
  • 9.2.1 VIM3 green color fixed by default

online shell installation (megaimage)

# VIM3 9.2.nightly
curl -sfL | sh -s - VIM3 VIM3x.COREELEC.9.2.nightly.emmc.kresq > /dev/mmcblk0
# VIM3L 9.2.nightly
curl -sfL | sh -s - VIM3L VIM3x.COREELEC.9.2.nightly.emmc.kresq > /dev/mmcblk0
# VIM3 9.2.1
curl -sfL | sh -s - -A VIM3 VIM3.COREELEC.9.2.1.emmc.kresq > /dev/mmcblk0




still worth 20191227.

please update the image!:slightly_smiling_face:
maybe the update server crashed?

plz check must be 2020-03-16 07:28 205M this 20200313 nightly


3918ab8f9cb8be5dc3eb58aa565ff08c VIM3x.COREELEC.9.2.nightly.emmc.kresq

I just check it work fine ! and check autoupdate from 20200313 to 20200316 - same works fine without problems


this nightly image will be updated every week

1 Like

figured out, thanks, just while there is no online update with sd :slightly_smiling_face:

Krescue online updates coming very soon (still in testing stage)

PS: at this moment if u need fresh image

  • rewrite krescue image
  • re download installation images (advanced -> format dump storage - at FIRST )

everything is so easy and simple! :+1:
Спасибо тебе большое!!!

@hyphop any chance we could use krescue to change the boot image?

yes! sure :wink:

if necessary write only uboot (bootloader to emmc)

at this moment its experemental mainline uboot for all VIMx boards

another simple for write any bootloader to emmc

its usb export emmc storage to host machine via krescue


lsscsi | grep Krescue | grep MMC
[3:0:0:0]    disk    Krescue. MMC                    /dev/sdc

cat bootloader.bin > /dev/sdc && sync

Oops, what I meant to say is that “is it possible to change the boot up picture?”

For example change khadas.bmp to mypicture.bmp? :smiley:

1 Like

yes ! if u know right place for logo and file format :wink:
its depend from uboot version and distro ! dont have universal solution


Firstly, amazing job :laughing:
Secondly, is it possible to add the User version of “VIM3L.Android.TV.v2.0-20200120.SC” ? It seems that the current version is the user debug, so it is rooted by default, and many apps with DRM refused to work when the device is rooted

Thank you

Ok.I will prepare soon

Hi all, i am trying to install Android 9.0 Pie on my VIM1 v1.2, but after installing Krescue in the EMMC memory of the VIM 1, it doesn’t boot.

The only thing that shows is the KRescue boot logo, but after that, there is only a black screen with the TV showing “No signal”.

I have tried to flash KRescue on the SD card, but no sucess in booting up.

The Amlogic Flashing Tool does not recognize the VIM 1 when trying to flash a normal image.

Can you help me please to revive my SBC VIM 1 v 1.2 ?

PD: I forgot to mention that i can access via Putty with the IP it has asigned and the root user, however, i dont know what else to do after that