Krescue - take full control of your VIM device! easy way to install ANY OS! + back/restore your system

All nightly images for Official CoreELEC are
HERE

Nightly Forum is HERE
It’s happening to Vim3 and Vim3L hardware.
I haven’t picked it up because i have been using official CoreELEC images via SD Card
and SuperCeleron ATV Internal eMMC .
Members on Khadas forum and our forum are now poping up with this issue.

To repair and install CoreELEC Official

1 Like

i have VIM3 + M2X Extension Board with SSD and 4g module installed,

I installed latest ANDROID PIE
VIM3.Android.Pie_V200103.emmc.kresq
, seems the data(sim) and gps dont work.

how can i fix this, i go to settings and location and try to turn on GPS location but it wont let me.

the 4G led light on the M2X is on but i still cant use 4g nor gps

Your Krescue CoreELEC images introduce different Boot Labels.

I can confirm this behavior on VIM3 Pro.
Posted question about this on CE forum.
CE was installed with krescue VIM3x image from 2019-12-28, and is broken since CE nightly update 20200228.
Clean install with krescue fails to update to latest nightly, same as previously working install updated on demand every time.

There are Android versions from SC that may or may not help.

[ROM] SC VIM3 Pie ATV Debug/User builds v2 20200117

all questions about android to android thread plz - not there !

1 Like

Hello @hyphop

Seems the krescue for VIM3 the ethernet not work?

i have seen sometimes some strange behavior with Ethernet
its problem for all mainline Kernel on VIM3

i think need more testing!

  1. board booted from emmc? and which uboot version ?
  2. clear emmc boot ! and try start krescue fully from sd and check what happens with ethernet

hyphop
VIM1.Android.Pie_V190823.emmc.kresq

can you add root?

not at the address, Terry does the firmware, and yes, there has been a root update for a long time

the last time i used fenix, it was still not able to produce mainline kernel debian for emmc, and your khadas recue initiative was our only solution to get mainline kernel install to emmc and booting from emmc, please push harder fenix to become compatible with mainline linux debian kresq :sob:

i have made this one (like a fork) already but in test mode yet (after testing it will be integrated to master branch )

git clone https://github.com/hyphop/fenix.git
cd fenix
git checkout hyphop
../scripts/make_debian_mainline_server.sh [VIM1] [VIM2] [VIM3] [VIM3L]

NOTE: last script generate raw and compressed image which suitable write both to EMMC same as SD

NOTE: mainline uboot + mainline kernel + debian 10 buster base

PS: after complete testing we will make announce about new debian images

2 Likes

UPDATED & FIXED MAINLINE UBOOT kresq image

DOWNLOAD uboot files for each VIMx devices

1 Like

This looks good. So I can just flash this on the SDcard while emmc have legacy uboot, will that be fine ? or this should be on the eMMC ?

  1. can write it to SD/eMMC
  2. VIM3 VIM3L always start from emmc if uboot presented on emmc and sd uboot was ignored
  3. if u have legacy uboot on emmc - u will have same problem with GREEN screen

That means this will not help those you want to keep the android on EMMC and use Linux on SD :frowning:

i still not find elegant universal solution for multiboot - but i try :wink:

  • u can patch your kernel for usage with legacy uboot

We cannot patch it for every use case. So Instead we will just wait for a fixed solution to follow.

at this moment i think krescue installation to emmc its best choice

because if u try to boot somthing from sd u can always depend from emmc uboot

1 Like

I dont have any problem. I am just trying to give a stable solution to normal regular home users who like Khadas Hardware :smiley:
Thanks for your work.

Hey, this does not work, but
./scripts/make_debian_mainline_server.sh VIM1
gives…

# cd ./scripts/..
# ln -sf build/linux-mainline-* linux
[i] build uboots: VIM1
[i] build VIM1
./scripts/create_image.sh

***********************PARAMETERS************************
Fenix Version:         0.8.3
Khadas Board:          VIM1
Uboot Version:         mainline
Uboot Configuration:   khadas-vim_defconfig
Uboot Branch:          master
Linux Version:         mainline
Linux Configuration:   defconfig
Linux DTB:             arch/arm64/boot/dts/amlogic/meson-gxl-s905x-khadas-vim.dtb
Linux Branch:          master
Distribution:          Debian
Distribution Release:  buster
Distribution Type:     server
Distribution Arch:     arm64
Install Type:          SD-USB
Final Image:           VIM1_Debian-server-buster_Linux-5.5-rc2_arm64_SD-USB_V0.8.3-20200310.img
*********************************************************

Info: Build host: bionic
Info: Installing build dependencies
Info: Requires root privileges, please enter your passowrd!
Hit:1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease                                         
Hit:3 http://ppa.launchpad.net/eh5/pulseaudio-a2dp/ubuntu bionic InRelease                                 
Get:4 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                             
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]                                
Hit:6 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease                                      
Get:7 https://dl.yarnpkg.com/debian stable InRelease [17,1 kB]                                             
Err:7 https://dl.yarnpkg.com/debian stable InRelease                              
  The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <yarn@dan.cx>
Fetched 163 kB in 1s (213 kB/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://dl.yarnpkg.com/debian stable InRelease: The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <yarn@dan.cx>
W: Failed to fetch https://dl.yarnpkg.com/debian/dists/stable/InRelease  The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <yarn@dan.cx>
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libusb-1.0-0-dev : Depends: libusb-1.0-0 (= 2:1.0.21-2) but 2:1.0.23-2build1 is to be installed
E: Unable to correct problems, you have held broken packages.
Makefile:7: recipe for target 'all' failed
make: *** [all] Error 100

My build machine runs ubuntu 18.04.4, and I had issues regarding unmet dependencies,
any idea to fix this ?
May I suggest that you provide a docker solution ? fenix is much easier with docker image ready to use…
tks