Build vim2 firmware including root support

I do not know how. Maybe @superceleron can comment.

Can I install android tv on my vim2 or as it got to be android?

Superceleron offers an Android 9 based ATV for the VIM2. Both User and Debug versions are here.

What’s the difference between android and android tv so you can install both on the vim2

Android 9 Pie is like the OS you’d find on a Android phone or Tablet,
Android TV is the OS you’d find on a android smart TV

But you can install both on the vim2

So both would work on the vim2 then

They were made for the VIM2, why woudn’t it ?

Can you Oreo from the same coder

Can you get Oreo for the vim2 from the same guy

This is a message for RDFTKV the guy for the custom rom as not got back to us can you contact him for us and find out how to get the icons like Wi-Fi and Ethernet icon on the upper status bar

I am not sure he has a Oreo build,
an SDK for Oreo never came…
it was a direct jump from Nougat to Pie…

I think he has Android and ATV versions based on Android 7. See here for ATV. See here for Normal Android.

I recommend carefully reading his posts on those to avoid possible difficulty.

As to contacting superceleron, I “@” him above. He will get a notification and likely reply when time permits. As I understand it, he is currently very busy with his professional work. It could be a bit before he has time to reply, patience may be needed.

1 Like

I’ve gone back to nougat I think this works much better I find in the custom rom userdebug scrolling didn’t work properly copy and paste didn’t work and trying to download apks the whole thing would crash I think there is definitely bug in it, now nougat works perfect like you said he’s going bring out another custom rom that’s going to be better than this version hopefully soon

You ain’t it’s rebooted again I’ve had enough I think it’s damaged because I thought I fixed by replacing the image it’s just reset or reboot I’ve been in contact with khadas

I am sorry to hear that. Hope you get it resolved.
Please keep us posted.

Khadas Abby as got back to me but they want us to shoot a video thing is I don’t know when it’s going to restart or reboot this is so frustrating I’ve told them the only proof I’ve got is explaining to you but this has been happening since beginning of the year

What do you think it could be that’s causing the vim2 to reboot constantly I thought I’d fixed it because wasn’t doing it until yesterday it restarted again I’ve tried to google it to see what is causing this I couldn’t find anything but when I think I’ve flashed the firmware I’ve factory reset I couldn’t change the plug because it doesn’t work with any other plug it only works with khadas plug

Hard for me to know the cause from here. It has all the earmarks of a power starvation issue, however, it could literally be anything. Since others are not reporting this, I assume the firmware is not the cause. It is possible physical damage has occurred to a critical component, would not be my first guess. However, if I recall correctly, you said you ran the board with no heatsink and/or fan for quite a while, it is possible thermal stress has affected the CPU or other heat sensitive component.
Perhaps try powering the VIM2 through one of the other power inputs as seen here. I know you have confidence in the power supply you are using, but if you have a suitable substitute, please give it a try.

What type of male to male usb cable have I got to look out for any type plus what said no one has reported this issue I’m having bad luck lately I’m waiting for Abby khadas to back to us I need them to replace it I think it’s definitely faulty vim2