[ROM] SC VIM2 Pie ATV Debug/User Builds v1.0

Hi there guys and girls, one more rom/fw for you all!
Many thks to Khadas for sending me the device to play
Ok guys im going to write the max i remember i did on sdk… i can’t remember all of it!
Build from Latest source.
Debug Build ( i might do in the future a rls build with my own keys )
I also added my layout(in zip format in internal storage) for squarehome3, is not hard to import it.


IF YOU HAVE TO MANY ISSUES IN THE BUILD AFTER FLASH EVEN IF THE FLASH WENT OK, JUST REFLASH AGAIN THE IMG BECAUSE YOU GOT A BAD FLASH EVEN IF IT SAID IT WAS OK.


On the first boot you guys need to update some google apps manually in playstore.


Differences of USER and USERDEBUG builds:

User Build : This build is done to be as close to a company rls as possible, it does not have root or twrp and is compiled with rls keys and SELINUX enforced, what this means for you?
Well it means lot more apps show in Playstore that didn’t show before, (EX: my isp android live tv app, only shows in Playstore non rooted and SELINUX enforced devices, also the streams in the app does not even play in rooted devices.). Like this there’s lots of other ISP/NON ISP apps Out there…

UserDebug Build: This build does have root, selinux is permissive and some other stuff you will see in changelog down there…, but of course you will lose the above…


Changelog v1.0:

  • Used latest SDK
  • Used ATV path of the sdk.
  • It behaves like the real ATV. ( do not expect navigation/status bars and recents )
  • Selinux fixes
  • Added Reboot to another OS or can also be used to reboot to TWRP if you do not have any sdcard or usb stick with other OS connected, LONG PRESS POWER BUTTON ON THE REMOTE ( DEBUG Build Only )
  • Google Webview is now default, plz let me know if you find any issues and i switch back to AOSP webview.
  • Fan control works just fine in my VIM2.
  • Added support for many Gamepads, and i mean really many. ( Kernel Drivers )
  • Fixed weird looking and missing panels and icons in some apps.
  • Added AFRD app(Debug only), and is working fine. ( Many thks to its creator/s )
  • Custom Root (Only on userdebug build, well this is a userdebug build doh… lol)
  • Enabled write/delete to external storages without asking for permission.
  • Reduced time from 5s to 1s of notifications auto dismiss.
  • Reduced the time mouse icon stays on screen.
  • Some changes to the kernel kernel.
  • Removed some “Null” pop ups
  • Some additions and fixes to settings provider
  • Modified TVSettings, added “Display” to menu to call DroidSettings
  • Added squarelauncher3 and also added my layout to internal storage so you guys can import it from there if you like my layout of course!
  • Added many KL’s for many keyboards, gamepads and remotes.
  • Added Provision.
  • Added some apps. ( not many since i dont like to add to much crap in my roms )
  • Compilation done with optimizations.
  • Changed system and vendor partitions size.
  • Optimized lots of stuff.
  • Some small fixes to systemui.
  • Some other minor tweaks.
  • I know there are more… i but i can’t remember now, keeping a good log is not my strong at least when is not for my work place, lol…

Bugs v1:

  • Volume pop up is misaligned ( it should show on top but is showing in the middle to right side )
  • No TWRP at the moment.
  • Blank screen if you use with DTV board, you can leave it connected but you need to power the vim from the USB-C plug, that will leave the DTV board disabled.
  • Of course there is bugs… there always be bugs…

Want to buy me a beer?


Download SC v1.0 IMG:


Install instructions:

  • Use usb burning tool 2.2.0 to burn the IMG.
  • More information on how to put the device in flash mode refer to khadas wiki!

THIS ROM DELETES ALL YOUR DATA SO DO A BACKUP!

USE AT YOUR OWN RISK!

Enjoy it :slight_smile:

5 Likes

Thank you superceleron, I know you are very busy. Very nice of you squeeze these in. Looking forward to giving it a spin.

3 Likes

ты прошлые не допилил а уже новую выложил .где поддержка DTV.разочарован

hi there, please does the ‘user build’ image works in vim2 1.2? I tried and it updates with success but it does not boot, see only the khadas logo for a long time

By any chance you have the DTV board attached?
Mine is also the v1.2 and works just fine.

Reflash to see if it gets corrected.

I apologize, it seems that this problem was described, and the problem was either with the power supply unit, or with the power supply cable, now I don’t remember exactly

hi, I tried to reflash 2 times and had the same problem, I dont have a dtv board, I also tried the ‘user build’ from here - [ROM] SC VIM2 Pie “Normal” Debug/User Builds v1.0 - and the flash fails for this one almost in end of the progress bar

Are you using version 2.2.0 of the USB Burning Tool? Also, set tool to “Erase all”.

Can’t reproduce it here, it always boots.
Maybe yours as some hw issue?!

If you have a successful flash, but it doesn’t boot, as Vladimir.v.v stated, ensure power supply is adequate and functioning normally.

For the sake of experiment, you can try different firmware more, so that there is no doubt about the firmware from Superceleron :slightly_smiling_face:

hi all, thanks a lot for the support, I had already tried other builds and also the manjaro kde one and they all worked fine, now based in the comment from RDFTKV about the USB Burnning Tool I was able to figure it out, I was trying the update using a sd card but it worked fine after using the USB Burnning Tool, however I was trying to install the non-root images because wanted to use the ‘HBO Go’ app but it doesn’t work and shows a message saying ‘this device is rooted’, so in summary the ‘normal’ and ‘atv’ firmwares from Superceleron work fine but for some reason the HBO app sees them as rooted

1 Like

Ye i know, is because of SELINUX that is in permissive mode, i had to do it like that since in this sdk the user build is all broken in SELINUX and to fix it, it takes a time that i do not have.
So all this new builds im going to post to all VIMS are like that.
If you plan on using a app that also checks for selinux permissive/enforced, then you have to wait a while until i have the time to fix it, or use a older USER build for the other vims.
VIM2 i do not have one older user build unfortunately.

thanks Superceleron, I already tried some old builds from the forum here but could had the same issue with hbo in all of them, I’ll keep following things here and hope some day you or maybe some other user can fix it, appreciate your efforts in making these builds, thanks once again

1 Like

Nice work.
Flashed the SC_VIM2_DEBUG_ATV-v1.0-20200802

Running all day today.
No issues detected so far.

Subscription Apk’s all playing fine.

Surprising Low Temperatures during playback for an S912

Thanks again @superceleron

2 Likes

а вентилятор и тюнер пашет или ражно недоделанное

sorry i do not speak russian, from the translation i see you complaining about the fan and tv tuner board.
Well fan here works just fine i can control it just fine.
TV tuner board, that is something that needs to be khadas to do it, i do not work for khadas!

1 Like

Плата ТВ-тюнера можно прикрутить

Yes it can be screwed just fine(i have mine screwed), you just can’t power the vim2 from that board, you always have to use vim2 usb-c to power it on.
If you try to power it from the tv board then you only get a black screen.