Brand new fresh out of the box VIM2 dead

I tend to believe birty regarding the Khadas 24w supply. If true, and it probably is, then the damage to your board was probably not caused by the 24w supply. That being the case, perhaps your VIM2 arrived damaged, if so, I would think about returning it to your supplier.
If you modify it by working on it, you might not be able to return it.

so as not to break your head, you need to take the original power supply and that’s it

Learnt the hard way from my first failed attempt at making my USB backplane board!

This is quite a good explanation of the various bits of USB-C in a not too technical manner (how i like it!)

1 Like

Well this makes me feel better i ddint screw it up on my own.

OK so just so i know for the future, USB-C is fool proof?

What if i use the khadas 25watt power supply to charge my phone? It will only power what the phone needs?

So the 24watt supply should of worked if the board didnt have an issure or no?

If the 25 watt supplys 5, 9 and 12 then why didnt the board ask the supply for only 5v and work like this 10 watt one?

Or is it because the 25watt is USB-C out to USB-C in and th e10 watt is USB to USB-C?
This is confusing

Now that i have the 10Watt supply, the blue tooth still has issues, it still shuts off randomly and comes back on randomly

I will say so, use a power supply similar in characteristics to the original,this is the easiest solution

From what I understand, the 24w will not work with the VIM2 as the VIM2 has no PD circuit, nor does it have the pull up resistors to set the charger’s output.

USB-C should be foolproof assuming the Khadas charger is PD compliant, no reason to think it isn’t.
Of course, cannot rule out a defective power supply, but as you have used that same 24w power supply on your other Khadas boards without issue, that is unlikely.

The VIM2 lacks the circuitry to let the 24w supply know what it wants/needs, so they cannot communicate.

As stated, the USB-C port on the VIM2 is USB-C by connector only, it functions as a USB2.0 port. So the 10w charger is a USB-A. And yes, with the supplied cable, it goes from USB-A to USB-C.

As to charging your phone, provided the 24w is PD compliant and your phone is also, should work.

ok i see its the device that dictates what the power supply puts out.

So that made sense why the 24 watt was dead when i first plugged it in with that supply

I then tried my phone chargers but they wouldnt boot all the way wasnt till i used the firestick supply with a USB-A male to male that it finally worked in the 900mAh port that it actually started to some what function

When using, “image Dump . from < EMMC”, the file produced has extension zst.
When using "image Write to… > EMMC, it only seems to recognize files with the zst or kresq extension. I copied other firmware files to the Dumps folder, as well as to the Downloads folder. I tried firmware files, as downloaded and uncompressed(*.7z), also tried extracting the downloaded 7z file and placed the resulting *.img files in those directories. None are recognized or seen when using Write to eMMC.

I may not be doing it right, but it seems the only firmware files that I can flash with Krescue are firmware files with the *.kresq extension, at least with the GUI.

Can you tell or show me how I can use Krescue to flash regular firmware files(*.img)?

I have to try it out, will report back to you soon :slightly_smiling_face:

So i got the replacement VIM2 today and it seems ok, but im having the same issues

#1.Bluetooth works ok for a while then shuts off
#2 trying to install pie doesnt take it

Tried USB burning tool and the PC beeps as if a new USB device but in burning tool its not seeing the board, looking in device manager its not recomized in windows

So i fire up different laptop and plug iin the VIM2 and i get the same issue, does this board need drivers? if so where do i get em? I get the little yellow ! next to the device that says “Vim2” so its not reconizing the device

Or maybe i need to hold the reset or power when i plug it in? ill try that just incase thats how some other devices work

NVM i got it to work using the buttons

1 Like

That was fast for a return.

I know you already got it going, but just an FYI, drivers are installed when the USB Burning Tool is installed. In the tools program folder, you will find Worldcup driver folder. The driver can be uninstalled and reinstalled from an exe in that folder.

my fan doesnt work again, when i installed the superceleron rom the fan on that rom didnt work either

Does yours work on this rom? pie

All settings, auto, low, medium and high work.

Your fan does not run even when selecting low, mid, or high? Has the fan ever worked? If not, check connector orientation.

yeah all settings, it did the same thing with the other vim2 board, the stock rom works fine. new rom everything works but the fan

I couldnt get the khadas pie rom to work on the old one, this one i got it to load but its the same thingas SC rom no fan

I left it on auto and it got up to 55C and i just shut it down after that i didnt push it any further because with the stock rom it would kick on at 50c in auto mode

Are you installing he same version of pie? V200624?

On the machine it says build 20200624, Kernal 4.9.113

Is the superceleron rom built around this same pie rom?

Ill try and load it again maybe it was a bad install but how can 2 roms do the same thing but the stock rom works fine? i cant live with out a fan ill nuke it

When i ran the antutu benchmark i ran a fan off the usb port just to get it threw the benchmark

My VIM2 is an earlier version, 1.2 I think. You have the later version(1.4)? Maybe the difference is there, they use different fans. Keep in mind, this Android Pie is a preview release. You may want to post the issues over here and let Terry know. Hopefully the issues can be resolved in a subsequent release.

FYI If I recall, the fan worked in both superceleron’s SCV-1 and SCV-3 ROMs.
The ROMs by superceleron are not based on Android Pie. I think they are based on 7.1

Until the issue gets resolved, as you have found any fan you can direct towards the heatsink should keep temps under control. To get through times like this, I often use a generic 12volt BB fan run from the GPIO’s 5 volt pins. It is adequate for cooling, and though it runs all of the time, as a 12v fan running on 5v, it is pretty quiet.

1 Like

I find that I sometimes need to uninstall / reinstall the burning tool will get the vim2s to be recognised. No idea why but worth a try as it’s easy!

Yeah that usually happens, especially for the driver to get recognized, it needs to get reinstalled for some reason, it happened to me recently, it is very annoying, need to get the tool fixed :confused: