Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


#41

Thanks for your reply.
I have searched and could not find the discussion you mentioned.
Do you have any advice about which router settings might be causing the problem?
I have tried resetting the router, tried both modules, tried installing to eMMC and still can’t make the internal Broadcom chip work.
I’ve tried a USB wifi adapter which worked.


#42

Alas, I can’t remember the topic where it was written and I have no model VIM (2\8) to check the operation of the Wi-Fi. Perhaps the owners of this model will write how they work.


#43

Hello Balbes150!
Wonderful work : also tested your build (1509) : works as you described (VIM2 MAX).
Monitoring the cpu is a pleasure to see : optimizations and efficiency.
Almost usable (wifi, remote) : video is sluggish. KODI has a hard time to display. Video stutters.
I’m aware of the video driver problem (ARM policy, not AmLogic).
Are there any plans to circumvent this show stopper?
Thks a lot!


#44

There are plans, but when it’s decided, I don’t know.


#45

Update test image 4.14.0-rc1-next-20170922.


#46

Burned latest 4.14. rc1 image, it shows khadas logo, and stays like this forever, sd card image.

I can’t figure it out why it won’t boot, am i the only one who is unlucky with your images, always having problem with them.

Tried to download the same image 2 times, always same result, it shows only khadas logo.


#47

You have added the correct file “dtb.img” to the root FAT partition ?


#48

Thanks for help, i didn’t fo that, where to download dtb.img for Vim?


#49

It is not necessary to download. All the files are there in the image. Open the directory /dtb and copy it from file “kvim.dtb” in the / (root FAT partition) and rename it to “dtb.img”.

kernel 3.14
/boot/kvim.dtb -> /dtb.img

or

kernel 4.x
/boot/meson-gxl-s905x-khadas-vim.dts -> /dtb.img


#50

I have succeeded to run it, next issue is wifi, when i run sudo modprobe wifi_dummy, i get the message "modprobe: FATAL: Module wifi_dummy not found in directory /lib/modules/4.14 .0.-rc1-next-20170922-amlogics905x.

Thanks balbes for helping, i am a noob when it comes to Linux.

I see you can’t view cpu temperatures with armbianmonitor -m, it shows cpu loads and stuff, is there a way to monitor it?


#51

Test image kernel 4.1x - not meant for home usage. Use version with kernel 3.14 and 4.9.


#52

Image update Armbian 3.14.29_20171012.
Added some scripts for fan control and install the firmware for the VIM2.
To enable fan control, you need to uncomment the line in /etc/rc.local


#53

Image update 5.34 Armbian 3.14.29_20171020.

In the Test directory added images kernel 4.9.40


#54

Update 3.14.29_20171027.

Changes.

  1. Fixed the launch KODI.
  2. Fixed installation mode of the OS in eMMC.
  3. Update packages to current versions.

#55

update image Server and XFCE 3.14.29 Debian 9 (Stretch) 20171104

for VIM (s905x) and VIM2 (s912)


#56

Image update Armbian kernel 4.9.40 20171112 for VIM2 (a Test folder on the website). Added support for Wi-Fi on the VIM2.


#57

Hi @balbes150,

thanks a lot for the new build, you are updating really fast. I tried the 20171112 version, but I could not get WiFi on the VIM2 Pro to work. I tried loading several modules like sudo modprobe broadcom, sudo modprobe b43.

In the end, my dmesg log showed Broadcom43xx driver loaded (the wifi module is a broadcom4359), but I could not find any WiFi network interface. Is there another module I should load?


#58

use the dhd module

sudo modprobe dhd


#59

Hi,

I downloaded the images to test, I have the VIM2 PRO (32 GB).

I want to run them directly into the internal memory (eMMC).
Is it just to do the same procedure with the USB Burning tool that I already used for other firmware?

I was confused how to load these images into the VIM2.

Thank you


#60

p.s.
I wanted to post the link in the first post of this topic, but I have no rights to edit.