Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

On the screen enter username and password (in lightdm) in the upper right corner of the screen there is a menu where you choose which GUI to run. The list will be three items (two rows with kodi) and the last line mate. Select mate (something opposite mate was the point), then enter the username and password. The system remembers the last selected mode. If at the next login or what not to choose in this menu, system at the entrance will trigger the option that was turning off in the previous session.

Update TEST images kernel 4.13.0-next_20170905. In these images there is USB support for S905X and S912.

Please to those who have VIM2 (s912) to check the USB in these images.

Hi, Balbes150:
You still haven’t got the VIM2 device? :smile:

I was told that within 1-2 days to deliver. :slight_smile:

Hello balbes150, it will be several hours before I get to the cave, but I will start testing when I get there.
Thanks for all of your efforts on the VIMs.


@balbes150 USB has been working for me on the test versions (I’ve only used a keyboard to test). The only issue I’ve had is a slight graphic distortion, but it might be the cable or monitor I’m using.

Edit: Tested Mate and XFCE versions as well

1 Like

Used Mate image, USB wired keyboard and trackball work.

1 Like

Can you show (take a picture), or describe what kind of distortion you get ? Which monitor / TV is used and how it is connected (directly or via adapter) ?

Hi, thank you for the test. You have no image distortion is not observed ?

No distortion observed. I mostly booted, checked USB and did not spend much time with it due to prior commitments. I will look for distortion next go. Might be helpful to know when/where the distortion is affecting the display.

Hi @balbes150,

Which dtb should I use for VIM2? I’ve tried meson-gxm-q200.dtb and meson-gxm-q201.dtb, but the usb is not working.


What image check ? What model VIM2 (pro base max) ? I don’t have VIM2 , so check the images on Vega S96 (dtb vega-s96). Last image 4.13.0-next_20170905 USB works (keyboard, mouse, can run from USB flash drive).

Hi balbes150,

The image is Armbian_5.32_S9xxx_Ubuntu_xenial_4.13.0-next-20170905_mate.img, and the model is VIM2 Base (2GB/16GB).

I’ve tried meson-gxm-vega-s96.dtb, the usb is working on VIM2, and meson-gxm-q200.dtb is ok too. I just did something wrong. Thanks a lot!

1 Like

I’ve tried other ROMs on my VIM2 and they all had the distortion so its not balbes150’s ROMs. I’ll open a new thread to keep this one from going off track to get a solution.

Version update TEST kernel 4.13.0_next_20170907. Added support for sound for all models S905X and S912. Pay attention to one feature of the work of sound - on the desktop has to be set 1920x1080 resolution. Not clear to me yet why the sound only works in this screen resolution.

For some recent images to use these additions, you can only download the kernel and dtb files (deb packages are in the directory TEST\deb) to install in the existing system (don’t forget to update the file “dtb.img” to a new version).

In images enabled sound via HDMI to s912 (and s905x). Work sound tested on a Tronsmart Vega S96 (s912). Sound works through HDMI on test files from the image. Once again - you need to have 1920x1080 resolution (you can go into desktop settings in the tools menu and select directly in the working system needs a permit).

I am now testing obtained Khadas VIM2 MAX (Khadas thank you for the provided sample). :wink:

All images Armbian work.

With kernel “3.14.29” everything works (wired LAN, BT, sound) except WiFi and video hardware acceleration. Copy to manual dtb in this manner is not required, suitable in the internal memory (eMMC) from the regular Android firmware from the factory. I recorded the image on the USB flash drive, connect USB flash drive to VIM2, pressed and hold button “Function” (middle button), turn on the power supply, wait for 3-5 seconds and released the button. Activated multiboot USB flash drive and start Armbian. You can also activate the multi-boot via the standard update.

Tested the version-4.13.0-next (the last image 20170915). With the addition of dtb (gmx_q200) working wired network, sound, USB, display resolution can be switched from the working system on the fly (to change the resolution, rotate the screen). After running the MATE desktop, is still free more than 2GB of RAM. The next step is to install the radiator and fan (I will use the for VIM2 and check additional cooller).

1 Like


I can’t get Wifi working on the latest 3.14.29 Arbian images on Khadas VIM 8GB model. I’ve tried both the Jessie and Xenial images.
I’ve tried both “dhd” and “wifi_dummy” modules.
With both modules (dhd and wifi_dummy), network-manager shows the list of available connections and can successfully connect and authenticate to a network. But the network doesn’t work. DNS doesn’t work.

If I’ve read correctly, others have reported Wifi working on 3.14.29 Armbian.

I’ve tried stopping NetworkManager and configuring /etc/network/interfaces directly as described in this post.

I am not very experienced with Linux networking so I’ve probably missed something.
Would appreciate help debugging. My dmesg is here -
I noticed the line “Error getting the SSID”

I’m wondering if its an issue with the DTB? I have the Vim model with 2GB RAM and 8GB eMMC (not the Pro version which has 16GB). The table on the product page shows that the 8GB model has AP6212 wifi instead of AP6255 in the Pro.
Can anyone recommend the right DTB to use with the 8GB non-Pro version of the VIM? I’ve tried the kvim.dtb and gxl_p212_2g.dtb in the dtb folder on the boot partition.


I’ve also got a question about hardware acceleration in the Mate/Xfce desktop and Chromium browser, which I’ve started a new topic for:

I remember that this problem has been discussed before and if I’m not mistaken, there was a problem with the router (after resetting the anchor Wi-Fi on the router, the network work).

Thanks for your reply.
I have searched and could not find the discussion you mentioned.
Do you have any advice about which router settings might be causing the problem?
I have tried resetting the router, tried both modules, tried installing to eMMC and still can’t make the internal Broadcom chip work.
I’ve tried a USB wifi adapter which worked.