Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


Hello Oleg,

Do you notice that Ubuntu Mate 18.04 is not smooth as Ubuntu Mate 16.04 and Ubuntu XFCE 18.04?
When drag the window on Ubuntu Mate 18.04 is very slow.


Hi Nick.
I’ll check with myself What image have you tried ?


Hello Oleg,

The image I use is Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_mate_20180729.img.xz. It’s not smoothly as Ubuntu Mate 16.04 when you drag the windows.



Hi Nick
I checked. Yes, there are some delays when moving the window (the mouse cursor moves before moving the window). But the window itself moves smoothly, without brakes. I haven’t looked for a reason.


Suport HW video to Armbian for S912 (VIM2).


Image Armbian 5.55


Install Armbian (only kernel 4.18) to eMMC.


Good news. U-boot-2018 files work on all vim1 (S905X) and VIM2 (S912) models. That is, you can use the files from the link above as well on VIM2. :slight_smile:


Add new version 5.55 20180817.

Add supports USB audio.


Tested work Tone Board with the latest version of Armbian 20180817, everything is fine automatically determined and works. When you connect the sound card, the system automatically switched to it. :slight_smile:


Important information.


Launched the latest version of the image 5.55 (20180817) to vim2 connected to TV LG 4K , when start the system automatically detects the presence of 4K and switched to the screen resolution 3840x2160. :slight_smile:

Edge: No SD card ? and Highest DESKTOP resolution?

Dear Balbes150

Seems this file Armbian is corrupt. Could you check it?
Thank you.




It work, tested this build few minutes ago. Maybe it broken for you during download process?


Ok, thanks.
I will try once again.



Update. 5.59 (20180823). Fixed WiFi work on Khadas VIM1 (s905x).


I downloaded your latest image, bionic desktop with 4.18 kernel , copied dtb, pasted it to root folder, renamed it to dtb.img, and i still don’t have wifi network.

I did even try to load modules, modprobe wifi_dummy and modprobe dhd, as root of course, nothing worked.

Device is Vim1 pro.


New version 20180829.

A fixed package with firmware for legacy images. It must be installed with the command

sudo dpkg -I

If there are errors when installing this package, you must remove the packages that prevent it from being installed.


Now I have VIM1_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31 and how I can boot with Armbian build?


You need to contact @numbqq to clarify which u-boot option is used in this version and what steps you need to take to activate the universal multi-boot.