Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


Hi dangear,

It’s the same to Android.

Please refer to


I use Win32DiskImager to create USB Drive with Armbian and try boot via Keys mode. But I see black screen only. I need to install Android and then update VIM bootloader for multiboot from it?


Good news. :slight_smile:
With the support of @narmstrong , it was possible to get a working version of u-boot-2018 for all models of VIM2 (S912). I checked on the VIM2 Basic and Max, u-boot-2018 works with SD card and eMMC. This will allow you to use Linux in normal disk mode with the latest version of u-boot on all VIM2. For those who want to try the new u-boot-2018, I uploaded two files to the site, for VIM and VIM2.


I managed to install Armbian in EMMC with MBR version 5.59 with two partitions, a BOOT of 122MiB and ROOT of 57,47GiB, the first one is unallocated by 668MiB I do not know why.:smiley:
Has interruptions to the network and boots pretty fast.


Which hub do you connect to 100Mb or 1Gb ?

Primary 700Mb is the service part when using the regular u-boot-2015. If you use u-boot-2018, it will be possible to exploit the full capacity of eMMC for the system (minus the 4MB service in the beginning to u-boot-2018).


We stopped the network and created another connection with modified parameters, now it works.

How to install u-boot 2018, I saved u-boot 2018 for VIM2.
Thank you.


Install u-boot-2018 eMMC easy (to download and burn the dd command to eMMC). But the big question is, what are you going to use it for ?


I do not know but I’m trying to learn.
What format does the partition do not see with gparted either


Please note that u-boot-2018 does not support all the features that u-boot-2015 has. It is intended primarily for Linux\Libreelec-9 users with the “4.1 x” kernel. If you created an MBR using a script from Armbian for u-boot-2015, you will be able to work with eMMC via gparted. But do not delete existing partitions or modify the MBR table.


Ok not delete existing partitions. With u-boot 2015 can i install kernel 3.14?


Hi @balbes150

Thanks for your great work.

On one of my VIM2 I run 3_in_1 and copied VIM2/u-boot.bin (md5sum 3eeffb0193daf958a1d78714062a25ad) with dd to /dev/bootloader (I was booted in LE).

But now the box does not finish boot (I can provide serial log):

=> version
U-Boot 2018.07-rc2-armbian (Sep 11 2018 - 17:36:32 +0300) khadas-vim2

aarch64-linux-gnu-gcc (Linaro GCC 7.2-2017.11) 7.2.1 20171011
GNU ld (Linaro_Binutils-2017.11)

The sdc_update command seems not available to revert back to previous u-boot from SD card.

I tried tftp as well and it timed out

=> tftp 1080000 u-boot.bin
Speed: 1000, full duplex
Using ethernet@c9410000 device
TFTP from server; our IP address is
Filename 'u-boot.bin'.
Load address: 0x1080000
Loading: #T T #T T #T ##T T #T T #T #
Retry count exceeded; starting again

note that could ping during attempt:

standby /tftpboot # ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.167 ms
64 bytes from icmp_seq=2 ttl=64 time=0.189 ms
64 bytes from icmp_seq=3 ttl=64 time=0.187 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 119ms
rtt min/avg/max/mdev = 0.167/0.181/0.189/0.009 ms

and tftpserver is correctly working on

desktop ~ # tftp standby
tftp> get u-boot.bin
tftp> quit
desktop ~ # ls u-boot.bin

Question: how shall I revert back to previous u-boot and/or adjust 2018 u-boot to work for 3_in_1?

I can use loadb to send previous u-boot from server disk to memory with kermit, but there is no store command to write to rom mmc. Perhaps another command exists?

Have a nice day


I warned you, you can not use u-boot-2018 in systems with Android partitions, he does not see them. To run from SD card latest version Armbian (kernel 4.18) VIM2 where you saved the u-boot-2015. Make a copy of the first 4 MB of eMMC (dd). Run this system on VIM2 with MultiOS And restore the first 4 MB to eMMC.


Thanks for reaction.
I must have misunderstood the u-boot-2018 purpose. My bad.
Sometimes translated text is not very clear to me in forum.
I am also not sure I understand restore procedure you kindly provide.
Note that I can no longer boot from SD. I tried with image Armbian_5.59_Aml-s9xxx_Ubuntu_bionic_default_4.18.0_20180908 and LibreELEC-S912.arm-9.0-devel-20180910093444-bdb5a5b.
I will contact you personally for specific instructions. I will document restoration here once successful.
Thanks for your valuable time !


Use version 5.55.
It has a built-in u-boot. There is no built-in u-boot in the 5.59 images (it needs to be written manually to the SD card after the image is written).


Thanks @balbes150 for kindly helping restore previous u-boot (2015)
[which I had replaced with 2018 one].
Note: I had a backup file from /dev/bootloader named bootloader.dd
(copied with dd) taken right before replacement. The dd bootloader size is 4MB.
Here is how to restore:

  • boot Armbian_5.55_Aml-s9xxx_Ubuntu_bionic_default_4.18.0_20180817 from SD
    [FYI: do not, like me, forget to install kvim2 dtb file as dtb.img :-)]
  • restore dd copy back verbatim to eMMC:
    dd if=bootloader.dd of=/dev/mmcblk1

Done. My 3_in_1 survived the adventure.

Have a nice day.


I thought we fixed it, there is a solution to randomly disconnect the network, I use the last Armbian 5.59.


What exact command is given for U-BOOT EMMC backup?


There were no corrections.

dd if=/dev/ of=uboot_backup.img bs=1M count=4


Have the last Armbian 5.59 I have on the SD card and so it happens

eth0 Link encap:Ethernet HWaddr 92:b4:f0:96:d6:xx
inet addr: Bcast: Mask:
inet6 addr: fe8… Scope:Link
RX packets:66459 errors:0 dropped:0 overruns:0 frame:0
TX packets:27677 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:76452482 (76.4 MB) TX bytes:3052445 (3.0 MB)

After dev / name of EMMC unit?


Yes. How could it be otherwise ?