Android builds without root


#41

All the commands are giving me error “adb: not found”
What am I doing wrong?
The adb shell is working and the device is authorized but it seems the adb has no root access.


#42

As the device is now not rooted so how can I carry these commands?
Will I need a custom recovery to modify the build.prop without root?
Any help is appreciated.
Thank you.


#43

In windows you cannot (you’ll need to perform it from a linux host)
But you can unroot a previous rooted firmware directly from android. Just follow the instructions from Vim 1 unroooted VIM_Marshmallow_170929


#44

Thank you for your reply.
The VIM2 already shows as unrooted with this NON ROOt firmware but still streaming services are detecting as rooted so I thought maybe it would be the keys used are test keys, so I wanted to try what terry suggested by modifying the build.prop and adjust the line to release keys like the line he had put.
Can I do that from Linux without the VIM2 being rooted?
Can you please direct me with some steps?
Thank you again.


#45

The easy way is to install Ubuntu and then install ADB


after that you’ll need to enter the commands that terry posted earlier.
On the Vim1 unrooted firmware VIM1_Nougat_NonRoot_V181030 safety net failed both the basic integrity test (because of busybox) and the cts profile test.
Plus nougat on VIM1 do not play well with netflix unless “Disable HW overlays” is used.
Check if on VIM2 the SafetyNet integrity test is true … if it fails, you’ll need to remove busybox after modifying build.prop .


#46

Thank you for your reply and help.
I have installed linux, adb and fastboot but unfortunately I get the same result “adb: not found”
So, what could be the problem?
If terry would be generous and compile the firmware with the modified build.prop for the user keys line (description and fingerprint) and also without busybox so that we can test it, his help and efforts would be greatly appreciated.
Please terry if you can do this it would be great.
Thank s in advance.


#47

By the way, I forgot to mention that I can view the build.prop with the last command “vi” but not able to edit it.
What I noticed going through the lines that there are other entries with “test-keys” and “userdebug” in the lines, would these affect the booting when changing the fingerprint line? are these lines inter-linked because if so it would cause failure to boot.
Please advise.


#48

Sorry for bothering you all that much.
I have finally managed to edit the build.prop file and rebooted the VIM2 but unfortunately it all ended with the same result and the streaming apps refusing to play detecting the device as rooted.
Please any of the experts to the rescue.
Maybe it’s because of busybox like paperinik mentioned or maybe because of the other lines in the prop file containing “test-keys” and “userdebug”, I don’t know.
Isn’t there any android tv box (not android tv only android) works with pure non-rooted firmware
Please if anyone can help with this it would be marvelous.


#49

I have found something interesting.
After changing the build.prop file I have used 3 Root and Safetynet checking apps and all of them gave the VIM2 non-rooted status, however, safetynet checks (CTS profile and Basic integrity) fail to complete they are stuck in checking status and do not give an end result and I have to press back button to kill the process and one of the apps give “API Error”.
This is different than before as it was giving status rooted in CTS profile and Basic integrity checks.
Any one can have a lead from this finding?


#50

Hi samkatta,
the other lines in build.prop should not be changed.
I do not have VIM2 so I cannot test it, but on Vim1 busybox causes safetynet integrity check to fail, which would cause ctsprofilematch to fail too.
https://developer.android.com/training/safetynet/attestation (look at the table Possible attestation results)

-For the apps that get stuck in checking status = google services are not updated yet (you can fix it with a reboot)
-The one that gives an api error = an app that the developer has not updated and does not use the latest api for the safetynet certification.


#51

Hi paperinik and thank you very much for your continous support and replies.
First, what I was referring to is that before changing the build.prop line the check tests continued till the end, however, when I did change the build.prop “fingerprint” line these tests failed to continue and got stuck in the checking status. I don’t know but maybe it’s because of mismatch in the fingerprint device and the rest of the build.prop lines.
Second, indeed as you mentioned, the checks revealed that busybox is installed and there are also remnants of SU binaries. So the VIM2 with this firmware pass the root check but “CTS profile match” and “Basic Integrity” both fail in Safetynet checks.
I don’t know if it’s feasible to have a firmware without busybox or any other SU binaries or not?
Can we have a vanilla firmware for the VIM2? only our beloved Khadas Staff can answer this question.


#52

You’re welcome.
Have you cleared the data and cache of those apps before checking with the modified build.prop? If they still get stuck try after a factory reset. The finderprint line is unrelated with the rest (at least for the safetynet test)
Did you try to remove busybox? (I can’t help any further since I do not have a machine to test)
You can either wait for a reply from terry or another VIM2 owner or you can try the guide/instructions I posted on how to unroot an already rooted VIM… it only takes 10 minutes and you’ll be up and running in no time.


#53

Thanks again.
I installed the busybox app to uninstall busybox but it gives error when it starts because of no root access so this is not applicable.
With the guide you are referring to wouldn’t it give the same result? what would be the difference? will I be able to remove all root traces and the device will pass safetynet checks?
Correct me if I’m wrong, I’m starting to believe that the firmware being modified (I mean Custom ROM without root or anything) alone by itself will cause the safetynet checks to fail.


#54

This is a non rooted firmware, so it’s normal that you cannot uninstall it with the app.
For removing it you should use a linux host. adb shell and the command
rm -f /system/xbin/busybox
(if busybox resides in the xbin folder)

For the guide you’ll install a rooted firmware so you will have full access in the system directory files.
Yes. if you follow the steps it will leave the machine completly unrooted and will pass all the tests and both safetynet checks.

If it is unrooted and it does not have busybox (I do not know if it is busybox itself or is caused because busybox is located in the xbin directory in this firmware), it will pass the integrity check = you will be able to install Netflix from the store. the “CTS profile match” is not needed for Netflix, but you will fail installing other apps than need also the “CTS profile match”.


#55

Hi Terry, not rooted does not seem enough. My VIM2 still fails to play Optus sport on unrooted firmware * VIM2_Nougat_NonRoot_V181030.
When I run Safetynet test it fails:

So I connected to linux machine, installed adb, opened terminal and did:

adb shell
# adb root
# adb remount
# adb shell
vi /system/build.prop

I get the screen with ro.build.fingerprint and I can change it, but I do not see any option to save changes, so I am stuck


#56

What’s the application did you install? I will have a test for it when I have free time.:grinning:


#57

It is called SafetyNet Test by Free Android Tools from google play store.
(The app I actually want to use is called Optus Sport)