Android builds without root


#1

Hi

I’ve just got my vim 2 and I was wondering if there is a version without root so I can install netflix,
apparently netflix only plays in 480p on rooted devices.

I tried androidTV netflix worked, but amazon video is "not available for this device"
I have also tried installing the very latest firmware on the docs site (VIM2_Nougat_V171028) but it was rooted.

I aim to make a mostly media box, but also being able to play my vast collection of emulators
and maybe some play store games too

Thank you


#2

Hi,

vim2 rom comes with supersu and as such you can completely remove root from within supersu settings.

S.


#3

Awesome, thank you
I didn’t do that just in case it bricked it
Thanks for the help!


#4

turns out it only disables root, it still fails safetynet.
SO I guess now I’m looking for a build without supersu


#5

Are there any builds that pass safetynet?


#6

You can try to set the value of Selinux with adb command :smiley:

# adb connect ID_ADDR(IP address of your VIMs)
# adb shell
# su
# setenforce enforcing
# getenforce

#7

Oooh, I will give that a try now, Thank you


#8

unfortunately you have to do that every reboot, which requires su installed,
which makes it fail the safetynet check.

A img with selinux set to enforce and no su installed is required.
Oh the joys


#9

Quite a few video apps on google play store have started to refuse to play content on a rooted device.
I use the VIM2 as a TV media player (which I am sure a lot of people do) and it is becoming harder to do so, especially because these streaming service companies are starting to block the service to android browsers. When you try to stream through a browser, the streaming service fails and demands you install the app, which then fails as the device has root access.

I need a ROM for VIM2 that makes it work as an unrooted device. I realise that this is weird and contradictory, but that is what I need at the moment.

Terry: is such a thing as “unrooted android firmware for VIM2” possible?


#10

What app do you install on VIMs from google play store? I will confirm it and consider releasing uproot firmware. Thanks.


#11

Last time I tried, Netflix would only play in standard definition.

Getting Magisk to work would be an amazing !!!


#12

Hi Terry,

Some standard android apps do not function on my VIM2 running VIM2_DualOS_Nougat_Ubuntu-16.04_V180622.

They fail because root access is detected. They are all video streaming apps:

I am sure there are more, but the ones I have found are:

optus sport (australian)
foxtel (australian)
NPO-start (dutch)
BVN (dutch)

They either do not install or fail to play any content and will say something like: “This device is Jailbroken or Rooted”.

I need firmware which successfully hides root access, or firmware that simply does not offer root access.
Can this be developed?


#13

Hi Terry.
any updates regarding this? I need unrooted android firmware for VIM2.


#14

Hi Terry

Any update.
At the moment I have a board that is not useful for my needs, I paid for the best one
but I don’t use it for the intended purpose that I bought it for


#15

Hi, guys:
We already build non-root ROM, as it’s China National Holiday from 1st Oct to 7 Oct, so we will release after the holiday.

Good day!


#16

Have you got an ETA on this build now you’re back from Holidays?


#17

Hi Gouwa.
Please release non-root android version or indeed give clear ETA.

I assume it can be flashed, and allows change of boot, so that boot from SD will be available.


#18

Hi
We will release the non-root ROM next week.

Have fun!


#19

Roughly when is this lit rom going to drop?


#20

It’s almost 2 weeks now, so when will the non-rooted ROM be available?