Android builds without root


#21

Hi, in testing process, will release together with Ubuntu ROM before 31 Oct. :slight_smile:


#22

Thank you for the great efforts guys.
So, are we getting the non-root ROM tomorrow?


#23

she is there, in nonroot firmware


#24

Hi
@samkatta @BdK71 @Daitallica
I have uploaded the
VIM2_Nougat_NonRoot_V181029.7z
firmware. You can download it and have a test. Thanks


#25

Seems like the fan control is not working.
The fan does not turn on at all when activating it in the settings.


#26

I’m sorry for that. I have uploaded the new firmware VIM2_Nougat_NonRoot_V181030. It fixup some permission issues include fan control.


#27

Wow, That was a fast response!
I will download and try it!

Thanks for your great work!


#28

@terry
VIM1_Nougat_NonRoot_V181030 looks good.
Netflix and other vod apps do not work unless the developer options are enabled and “Disable HW overlays” is activated.

If possible since it is a problem for every nougat version for VIM1 till now:

  1. make the system to remember the developer setting “Disable HW overlays” between reboots and shutdowns.
    or
  2. provide us a similar unrooted version of marshmallow. eg. a VIM_Marshmallow_170929 without root would be fine.

#29

Awesome stuff. Thanks for getting this out there.

However, it still fails play store safety net, so Netflix still won’t download from the play store :frowning:


#30

Thank you guys, but unfortunately the device still appears as rooted and all root-hating applications refuse to work with the VIM2 with this non-root firmware.
Please we need a pure non-root firmware, even the keys should pass the check.


#31

Mine said it was not rooted, but still failed the safety net check


#32

@terry @Gouwa
Please guys can you find out what triggers the discovery of the device as being rooted by the safetynet checks.
Maybe the bootloader being unlocked or some remnants of supersu or the security keys being modified?
If that is not feasible can we have magisk with this version of the ROM and would it hide the root and pass safetynet checks?
Thank you for your great efforts and I hope that you will find a solution for us.


#33

What’s application did you have a test with this ROM? My ROM is really non root and you can install RootCheck application to verify it.:grinning:


#34

No problem with the root check it states device non-rooted but all streaming services will not play giving error device is rooted, some how these apps do find that the device is modified.
By the way I have tried un-rooting in different TV boxes before and all will give “device not rooted” with the root check apps but the problem still remains and the apps refuse to work due to the device being rooted.
I thought that this time you would provide some kind of genuine non-rooted firmware that will pass the checks of the streaming services.


#35

I used this one : https://play.google.com/store/apps/details?id=org.freeandroidtools.root_checker

Root check passes, but safety net check fails


#36

Yes, exactly.
We need a firmware that passes safety net check.
Please try to make a firmware that passes the safety net check.


#37

It is caused from the busybox.
If you compile the firmware without busybox the SafetyNet’s basic integrity will pass the check; the ctsprofilematch will still fail though (snce it is not certified by google)


#38

I had a test for it and but the safety net check pass. :sweat_smile:


Vim 1 unroooted VIM_Marshmallow_170929
#39

Also you can try to modify the build.prop file with adb command.

# adb shell
# adb root
# adb remount
# adb shell
# vi /system/build.prop

Change the value from

ro.build.fingerprint=Khadas/kvim2/kvim2:7.1.2/NHG47L/20181030:userdebug/test-keys

to:

ro.build.fingerprint=OnePlus/OnePlus6/OnePlus6:8.1.0/OPM1.171019.011/06140300:user/release-keys

#40

I will definitely try this out, but sorry for asking, how can I mount the device to windows?