5.7x version issues

I’ve been trying different systems for a long time. I used android 9 and xfce-gnome 4.9 version of for my LTE modem.

I created dozens of topics in this forum and other forums for integration. but I could not find a solution. I installed version 5.7 hopelessly. But the problem was resolved. I even made a connection to the operator. i am glad.

but there are still problems.

emmcye does not load. there is a green curtain on the screen. and the ram appears to be 2gb. cpu fan not worked.

these are just problems I’ve seen so far. Even that is enough for a start if I fix this screen problem.

my khadas vim 3 pro
android 9 on emmc

Please erase the eMMC to fully boot from SD card.

I could not delete emmc and flash it on pc. usb burn tool has failed. I don’t know how to load the system via sd card.

that is, the system is booted but it is opened on the sd card. Not from emmc. Does uploading this image to emmc fix these problems?

Yes, you can also write the SD card image to eMMC to fix the green screen issue.

Just one command to write the image to eMMC:

$ sudo emmc-install

yes i managed to install. Green screen problem is gone.

The problems I see

  1. The fan does not work. (Very serious problem. Overheating and card may burn;) hard)
  2. Wifi is unstable. For example, I connected to my modem’s wireless network. But it doesn’t see my Routure’s wifi network at all.

Which image you used?

https://dl.khadas.com/Firmware/VIM3/Ubuntu/SD_USB/VIM3_Ubuntu-gnome-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530.7z

This image both fan & wifi should work.

The fan is work on auto mode.

I used this. and the fan does not work. By default, automatic mode is selected. But the fan doesn’t work. I change the options manually but it still doesn’t work. Do not even want to save button comes out I’m saving. but when I restart it goes back to automatic mode.

Wifi is working. But the router doesn’t see my device at all. But he sees the modem’s wireless network. I can connect to it.

I am using version 5.7 rc7. and I was able to upload it to emmc.

Will the XFCE version of this version be released? Because that version is lite and faster. and I think it should be set to flash from the computer. This method is much simpler.

edit. I noticed something. Icons of all programs installed by Khadas do not appear in the application menu. It looks transparent. For example, I open the HDMI resolution application. There is no list, it is empty.

I checked on my side, the FAN works.

FAN control in /boot/env.txt doesn’t work for 5.x kernel now. The FAN works always on auto mode.

And the trigger temperature is 80 Celsius. Are you sure the board temperature is higher then 80 Celsius? So the FAN will not work unless the temperature is higher then 80 Celsius.

You can check the temperature like this:

$ cat /sys/class/thermal/thermal_zone0/temp

Anyway, you can trigger the FAN to work manually like this, but the FAN will stop if the temperature is not high enough.

  • LOW
$ echo 1 > /sys/class/thermal/cooling_device2/cur_state 
  • MID
$ echo 2 > /sys/class/thermal/cooling_device2/cur_state 
  • HIGH
$ echo 3 > /sys/class/thermal/cooling_device2/cur_state 

You can use such commands to check whether the FAN works.

I’m not sure what you mean. I can connect the AP on my side.

Yes, such applications should be removed, 5.x kernel don’t need these applications.

How can we set 80 to 60 or 65? I want to change the automatic operation limit of the fan.

I think I found the problem. Khadas cannot detect devices broadcasting on channel 13. I made the broadcast channel auto and it became 11. Then he started to see.

and you’re right the fan is working. But it should exceed 80.

Yes, it’s easy.

$ sudo -i
$ echo 60000 > /sys/class/thermal/thermal_zone0/trip_point_3_temp

Setup the trigger temperature to 60 Celsius.

2 Likes