3rd-Party Ubuntu ROM for Khadas VIM

I will post tonight. Balbes150’s may not be a daily driver solution on the Vim, but fun to try it because it requires no real commitment. Or as you might say, less painful. :slight_smile:
He continues to improve his images. Users of his Armbian on another S905x box, report very good results when using as a Plex and Embry server, so the Vim would have similar potential. To my knowledge, balbes150 does not have the Vim yet, so he has no specific Vim image. I hope to offer him some feedback, so maybe he can help tune for the Vim.

The RPi is very mature, so yes, I would expect it has an advantage in some ways. However, the S905x offers some advantages of its own. Khadas seems to be working very hard to refine the Vim and diversify and expand available OS options.

For instance, just saw the post about the forthcoming multi-boot.

My interest in the Vim is mostly focused on learning how to interact with the GPIO. An uphill climb for me. :slight_smile:
I have messed with Linux for years, but I am still a novice at best.

Should be a lot of fun and a good challenge.

[quote=“RDFTKV, post:55, topic:81, full:true”]
I will post tonight. Balbes150’s may not be a daily driver solution on the Vim, but fun to try it because it requires no real commitment. Or as you might say, less painful. :slight_smile: [/quote]
Don’t hurry, now that we’ve finally got the ‘official’ Ubuntu relaease that has landed to play with.
But still your procedure might be of great interest for trying other distros (myself I prefer Arch or rpm based distros over Debian based)

Quite true, confirmed with the effort to release the Ubuntu VIM version before the new year break, very nice gesture.

I’m in that process as well, it’s precisely why I first got the Rpi and I do I enjoy it. But what brought me to the VIM is that to my amazement I ended up thinking that with just some more horsepower, those SoC boards could actually be very decent desktop for my use.

Cheers !


Seems a bit superfluous now, but here it is…

I used an image from here. Images available with and without DE.

Latest, I have not tried these.

HDD RAW image burner.


His other Linux variants(Arch Here). I have not tried any of these on the Vim. Note: Login Info for other variants. Other variants may require additional steps.

For Windows+Android:
Card Prep:
1.) Format an SD card to FAT32. 4GB minimum( I generally use 16 and 32 cards), Class 10 or better recommended. The faster the better.
2.) Download and extract the file, the extracted file will be an image. I use 7Zip for extraction.
3.) Burn the image to the SD card. I use HDD RAW(portable ver.). Programs like Rufus or Win32DiskImager, etc should also work. Caution with HDD RAW, make certain you select the SD card as the target, HDD RAW will write over anything, it does not care about your feelings on the matter. It does have a couple of confirm notices, but be careful anyway.

To Run with prepared card: A few things take place, it does not just boot to Linux first go round.
1.) With the Vim running Android, insert the prepared card in to the Vim’s SD slot or use a USB card reader.
Note: I like to use a card reader with activity LED, so I can see something is happening. The first boot can take a few minutes and the flashing LED is reassuring. :slight_smile:
2.) At Android/Settings/About Device/System/updates.
From the Update and Backup App, under the UpdateLocale section, click Select, select aml_autoscript.zip, click update.
Note: Leave “Wipe Data” and “Wipe Media” unchecked/unticked. To be clear, do not use those options
-The Vim will reboot, it will do so a couple of times.
-Eventually you will see the initial login.
Initial login credentials, User: root Password: 1234
You will be asked to select a new password, do so. You will be asked to create a new User and P/W, do so.
-The box will reboot, this boot will be a bit slow, but ultimately should bring you to the desktop.

Once at the desktop, install gparted(sudo apt-get install gparted). Use it to resize the Ext partition on dev/sda to fill the card’s available space. Ext will be on /dev/sda.
Note: Correction. Please see balbes150’s post for DTB explination.

I don’t think I left anything out. The steps sound far more complicated than they are. Do it once, and you probably won’t need this guide the second time.
Still, I am not without error(understatement), so if you have any trouble or I have messed up, let me know.


Thank you very much for that, much appreciated.
Yesterday I got the VIM running Gouwa’s Ubuntu server with mate on top and also KDE (just because it’s a DE I know well, for comparison sake), an install I still have to setup right but already very promising.
But I’m pretty sure right after that I will try the Arch image you refered to.
It’s true that the whole procedure, especially with you nice write-up, isn’t that complicated.
Cheers !

You are welcome.
It should be noted that other of his versions, like Arch, may not have had the uboot and dtb selection included and required additional steps. The added steps were simple, but not automated and included, as it is in the image I used or later versions.

Running the card made from the image I used, will make the change to uboot. After that, I think any of his other variants would boot from card.
See here for specific login info for the other variants…

Clarification. The function to load the dtb data from the internal memory there is in all recent images. The principle of operation of this function. At the start image, the system checks for file “dtb.img” in the root of the first partition of the carrier. If there is no such file, the system tries to load the dtb data from the internal memory. By default, after recording of the image of such a file in the root of the no. So the system is trying to use the dtb data that exists in the current firmware. If you try to run the system (without the file “dtb.img” in the root of the first partition), the system doesn’t start, you need to manually copy the correct dtb file from the directory /dtb to the root and rename it to “dtb.img”. Kernel in images are frequently updated and changed, accordingly change the options\variables dtb files (included in the kit image in the directory dtb). Therefore, the data that is in the internal memory often does not correspond to the parameters of the kernel, so the system cannot be started without manually copying the correct file.


Balbes150, why is there root password error(bug) in your Ubuntu image, it is correct at login screen, but it doesn’t accept the same pass in terminal.

I am pretty much new in Linux, so i don’t know if it has anything to do with the post above?

Did anyone else posted this issue or is it specific to khadas vim?

Describe in detail Your steps. Just for reference. Open a terminal in a graphical environment and give the command “sudo su”, enter the user password (pay attention , you need NOT to enter the root password, enter user password). The system will switch to the root user.

Another variant of transition to the root user. To run the command “su -” (su “space”, “minus”). And enter the root password (pay attention, this command uses the password for the user “root”).

I see that many of the themes frequently mentioned option of images with LXDE along with my name. I want to draw the attention of all - I never published any of the images for Amlogic (armv8 aarch64 S905\S905X\S912), with a graphical user interface LXDE. All the images that I produced are based either on the graphical environment XFCE, or in a graphical environment MATE or the command line options (without graphical environment). I think this is important, XFCE is significantly different from LXDE. This is a different GUI and they are configured differently. So anyone who uses my images, I recommend to look for information on the Internet about setting up the graphical environment XFCE.

1 Like

Hi, Balbes150:
Will you built Mate/Gnome desktop in the future?

Hi Gouwa.
I’ve collected several options for desktop environments, including MATE.

What do you mean: have collected several options? :slight_smile:

I had previously collected to test multiple images with different graphical shells (XFCE IceWM LXDE LXQT MATE etc). :wink: But these images were not in the public domain. By the way, the last images armbian make it easy to install any GUI. For example, I have on one of the TV box is running the latest image Armbian (20170121 catalog Test) which, together with XFCE installed MATE (via synaptic) and automatically (at system startup) start the shell MATE. Enough after installing MATE to add to the user directory file .xinitrc indicating what shell I want to run (in the file, add one line “exec mate-session”) :slight_smile:


Very glad to see you here balbes150. :slight_smile:
Thanks for the clarifications.
My apologies for the errors.

Same with me! :heart_eyes:

A very good user manual. :slight_smile:

Thank you.
You make it easy.:slight_smile:
I have edited the post’s incorrect DTB info and linked to your post explaining it.

One question for you guys, and not trying to put any preassure on the developers, but is there any sort of ETA for the availibility of working WiFi and BT drivers for the Khadas Linux builds?
And what is the blocking factor for not having them now? Do the drivers need to be backported to the kernel being used?

Balbels50’s ROM support WIFI already, but for SD card installation.

EMMC installation ROM with WIFI supported ROM will be released today.

Those are great news.
Although I’ve never been able to up the wlan0 interface even on Balbels50 SD distribution. Is there a particular release where it does work? And is there anything in particular to configure in order to be able to use it?