3rd-Party Ubuntu ROM for Khadas VIM


#21

Hi,
I installed Vim_Ubuntu-16.04_V170102.
I followed your steps for shorting the M-register however no matter how long I held my tweezers against the m-registers and pressed reset I could not get it to go into upgrade. I haven’t got the kit to put it in serial mode. I will try ordering in a few days.
Any help in the mean time would be appreciated.


#22

Did you connect the USB-C cable to your PC?


#23

I certainly did. I forgot to mention that


#24

Normally, the M-register approach would work in any cases, can you try it out with another PC again?

It seems that the only way now is a serial tool.


#25

Tried it on a few machines now and nothing guess I’m stuffed without the serial adapter.


#26

Confirmed again with the following things;

  • Did you run the USB Upgrade Tool yet?
  • Did you connect the USB-C cable to PC?
  • Did you get a bootable SD card inserted into the VIM?

Good luck:grin:


#27

Upgrade tool running yes
USB-C to PC yes
Bootable SD card inserted yes
Is there any other way to wipe the eMMC because that would force boot from SD.
I’ve ordered the cable needed for serial tool and it should be here tomorrow thankyou Amazon. So it’s no big issue if I don’t get this fixed today it’s just annoying.
Maybe I’m doing something wrong when I try to short the m–register but I’m only trying to create a connection between the two points so I can not see how I’m doing that wrong.


#28

Hi, You must plug-out the bootable SD card! so can upgrade as USB-C cable.


#29

Thankyou, thankyou, thankyou.
That worked.
You guys are amazing.
Thankyou again for helping me through this


#30

Well, enjoy!:slight_smile:


#31

I tried to return to marshmallow via usb burning tool in win10, now it won’t connect to usb burning tool, did the same procedure i did when installing ubuntu, is there any way to reflash using sd card?


#32

http://docs.khadas.com/bootcamp/UpgradeViaTFBurningCard/
http://docs.khadas.com/develop/HowtoBootIntoUpgradeMode/

More info: http://docs.khadas.com


#33

I used keys mode to upgrade, now i can’t use them again, i am for now stuck on bad ubuntu.


#34

http://docs.khadas.com/develop/HowtoBootIntoUpgradeMode/#mregister-modemaskrom-mode

Try with the ‘M-Register’ mode, same problem with @Junks666


#35

How to do that, i need to open the case for it, what tweezers can i use for this, am a little scared that i won’t brick my vim.


#36

Another approach is Serial Mode, but you need have a Serial to USB module.


#37

So i am stuck with ubuntu unless i use m register?


#38

Hi, all:

There different ways to boot into upgrade mode to upgrade another ROM:

  1. Serial Mode
  2. M-Register Mode
  3. CLI Mode:
  • Boot into Ubuntu
  • Open a Terminal
  • Run the dd if=/dev/zero of=/dev/bootloader command to erase the bootloader partition on eMMC
  • reboot
  • example:
root@Khadas:~# dd if=/dev/zero of=/dev/bootloader
dd: writing to '/dev/bootloader': No space left on device
8193+0 records in
8192+0 records out
4194304 bytes (4.2 MB, 4.0 MiB) copied, 1.1226 s, 3.7 MB/s
root@Khadas:~# reboot

The 3rd approach will erase bootloader, and you can upgrade using USB-C cable or Bootable SD card.


#39

Try with the CLI way above, and kindly feedback to us with your result.

Thanks.


#40

Can someone ELI5 why I need to use a USB TTL adapter via GPIO for serial mode? Why is this not possible via the other USB or USB-C interfaces?